Go Back   AudiWorld Forums > Audi Models > Audi A4 > A4 (B5 Platform) Discussion
Sign in using an external account
Register Forgot Password?


A4 (B5 Platform) Discussion Discussion forum for the B5 Audi A4 produced from 1995-2001 B5 FAQ

Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 01-25-2011, 07:10 PM   #1
Audiworld Junior Member
Account #: 187335
 
M3tor2nR's Avatar
 
Join Date: Jul 2010
Location: Bay Area
Posts: 21
Default ** OIL service light reset!?!? **

So I have about 98k miles on my 1998 Audi A4 2.8 Quattro. The OIL service light blinks for about a minute when I turn the ignition on. So I got an oil change about a week ago and of course the light is still there. It's annoying and would like to get rid of the OIL service light.

I've read online 2 ways to reset it on your own, using the two ***** on the tach. But it doesn't work.



"A4 1995-1997

Requires diagnostic tool.

A4 1998-1999

Press and hold button on right side of instrument panel. Turn ignition to the "ON" position. "OIL" or "SERVICE OIL" will appear in display. Release button. Pull out button on left side of instrument panel until "---" or "SERVICE ---" appears in display. Turn ignition off."



1995-1997 models need the diagnostic tool or need to be taken to the dealership to reset the service light. 1998+ models can be reset without going to the dealership or using the tool. I have a 1998 model. Not the 1998.5 model. Does that mean I'm a part of the 95-97 model? That might explain why the reset methods don't work for me.


If anyone can chime in, I'd appreciate it. I took it to the dealership today thinking they'd reset it for free, but they wanted to charge me $75 bucks just to get rid of the damn light. I'm not paying that amount for them to just reset the light.
M3tor2nR is offline   Reply With Quote
Old 01-26-2011, 02:34 PM   #2
Audiworld Junior Member
Account #: 187335
 
M3tor2nR's Avatar
 
Join Date: Jul 2010
Location: Bay Area
Posts: 21
Default

anyone?
M3tor2nR is offline   Reply With Quote
Old 01-26-2011, 03:29 PM   #3
AudiWorld Super User
Account #: 37725
 
AudiMick's Avatar
 
Join Date: May 2002
Location: Redmond WA
Posts: 5,100
Default

Quote:
Originally Posted by M3tor2nR View Post
anyone?
If your car has a Delta Stereo it's early 98.

Early 98 will need a full version of VAG.com . Shareware version doesn't work.

Vag.com is $249 and up from Ross-tech. Almost all the old time Audi/ VW guys have one. It's the best $$$ you can spend it you want to own your car for a while.
__________________
2001 180 TTQ coupe (sold)
1976 Triumph Spitfire
2008 A4Q 2.0T (sold)
2003 A4Q 1.8T (sold)
1996 A4Q (sold)
AudiMick is offline   Reply With Quote
Old 01-26-2011, 11:29 PM   #4
Audiworld Junior Member
Account #: 192573
 
Join Date: Oct 2010
Location: Terra Linda, CA
Posts: 12
Default

Most likely if your car is a '98 it was produced during mid '97. I have the same problem in my '96 12v but I have never bothered spending any money on fixing it. It only beeps like 4 times and turns off by the time you get down the street. But, if you are planning on having an audi for a while I would definitely suggest investing in a vag-com. For the meantime, im sure if you find a audi/vw specialty shop they will clear this for much less than $75, never go to the dealer... BTW where in the bay area are u?
TL12vA4 is offline   Reply With Quote
Old 01-27-2011, 01:47 AM   #5
AudiWorld Member
Account #: 145843
 
weaselciuy's Avatar
 
Join Date: Mar 2008
Posts: 118
Default

If this method did not work for you:

"Press and hold button on right side of instrument panel. Turn ignition to the "ON" position. "OIL" or "SERVICE OIL" will appear in display. Release button. Pull out button on left side of instrument panel until "---" or "SERVICE ---" appears in display. Turn ignition off."

then you definitely need VAG-com to reset it. I use that on my 99 car and it worked everytime (service and OIL resets) Also i think removing battery will help but i don`t recommend
__________________
Audi A4 B5 Facelift 74kw 1.6i
weaselciuy is offline   Reply With Quote
Old 01-27-2011, 06:12 AM   #6
AudiWorld Super User
Account #: 37725
 
AudiMick's Avatar
 
Join Date: May 2002
Location: Redmond WA
Posts: 5,100
Default

FYI

If you can borrow a VAG.com you can change the default parameters for the SRIs so they show up less often.
__________________
2001 180 TTQ coupe (sold)
1976 Triumph Spitfire
2008 A4Q 2.0T (sold)
2003 A4Q 1.8T (sold)
1996 A4Q (sold)
AudiMick is offline   Reply With Quote
Old 01-27-2011, 09:19 AM   #7
Audiworld Junior Member
Account #: 192573
 
Join Date: Oct 2010
Location: Terra Linda, CA
Posts: 12
Default

Quote:
Originally Posted by AudiMick View Post
FYI

If you can borrow a VAG.com you can change the default parameters for the SRIs so they show up less often.
here is the DIY article for how to reset your SRI's if you can get your hands on the software.
http://audi.kris-hansen.com/SRIreset.htm
TL12vA4 is offline   Reply With Quote
Old 01-28-2011, 02:22 PM   #8
Audiworld Junior Member
Account #: 187335
 
M3tor2nR's Avatar
 
Join Date: Jul 2010
Location: Bay Area
Posts: 21
Default

Thanks for all the info everyone. Looks like I'm stuck getting it reset from a dealer/shop, or buying the vag.

Quote:
Originally Posted by TL12vA4 View Post
BTW where in the bay area are u?
I'm in the East Bay. Union City to be exact.
M3tor2nR is offline   Reply With Quote
Old 04-12-2012, 06:11 PM   #9
AudiWorld Newcomer
Account #: 233485
 
Join Date: Apr 2012
Posts: 1
Default Reset oil service light

Quote:
Originally Posted by weaselciuy View Post
If this method did not work for you:

"Press and hold button on right side of instrument panel. Turn ignition to the "ON" position. "OIL" or "SERVICE OIL" will appear in display. Release button. Pull out button on left side of instrument panel until "---" or "SERVICE ---" appears in display. Turn ignition off."

then you definitely need VAG-com to reset it. I use that on my 99 car and it worked everytime (service and OIL resets) Also i think removing battery will help but i don`t recommend
Yes this process does indeed work for a 1998.
Thanks
TVM Guru is offline   Reply With Quote
Old 04-13-2012, 10:14 AM   #10
AudiWorld Super User
Account #: 37725
 
AudiMick's Avatar
 
Join Date: May 2002
Location: Redmond WA
Posts: 5,100
Default

Quote:
Originally Posted by TVM Guru View Post
Yes this process does indeed work for a 1998.
Thanks
As already said not on an early 98 only 98.5+
__________________
2001 180 TTQ coupe (sold)
1976 Triumph Spitfire
2008 A4Q 2.0T (sold)
2003 A4Q 1.8T (sold)
1996 A4Q (sold)
AudiMick is offline   Reply With Quote
Old 04-13-2012, 10:14 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
1998, 2008, a4, audi, b5, charge, dealer, diagnostic, indicator, light, oil, q7, reset, sercvive, service, sri, tool, turn


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:21 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community