charcoal canister - AudiWorld Forums

Go Back   AudiWorld Forums > Audi Models > Audi A4 > A4 (B5 Platform) Discussion
Log In 


A4 (B5 Platform) Discussion Discussion forum for the B5 Audi A4 produced from 1995-2001 B5 FAQ

charcoal canister

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
Old 08-24-2009, 09:47 AM   #1
AudiWorld Member
 
Join Date: Apr 2006
Posts: 478
Default charcoal canister

Car won't start after pumping gas unless I am giving it some serious gas. CEL codes 1136 and 1138 (system to lean). Posted a couple of months back, have not driven the car in about 3 months. Looked a purge valve and check valve both appear to be fine. Time to look at the charcoal canister, looked for a writeup couldent find one. Can someone tell me exactly where this is located (I know in the back somewhere near the spare tire.) How much do these usually go for? Is it something I can clean out or do I need to order a new one?

Thanks
The Black Knight is offline   Reply With Quote
Old 08-25-2009, 06:22 PM   #2
AudiWorld Senior Member
 
Join Date: Nov 2006
Posts: 612
Default

I know exactly what causes that. I had the exact same problem. It most likely the purge valve. It will look ok but remove it and try blowing through it. If air goes through its bad. Also check the resistance the spec is 22-30 ohms.

Hope that helps
ps be ready to spend $100 for a new one
a4_1.8t_01 is offline   Reply With Quote
Old 09-22-2012, 11:40 AM   #3
AudiWorld Newcomer
 
Join Date: Sep 2012
Posts: 2
Default

Yes, I had a purge valve problem.
06 A4 USA model, 98k miles on it.

symptom: hard to start up after filling up gas tank, waited a few minutes then started up, but sometimes weak startup.

symptom: CEL on, then off, then back on over several weeks.

Audi dealer ran codes, said it was the PURGE N80 valve, replaced it. Audi quoted me $265 US Dollars for parts/labor. But a rival shop, Goodyear, quoted me $195. Audi came down a little bit due to my model year having so many issues.

A week later, engine started sputtering on acceleration, about 40-50 mph, and also on hard acceleration like when I accelerate to go onto the highway. Any ideas, anybody, as to diagnosis?
OCSadge is offline   Reply With Quote
Old 09-22-2012, 03:46 PM   #4
AudiWorld Senior Member
 
mtroxel's Avatar
 
Join Date: Oct 2003
Posts: 930
Default

Had the same. Got a purge valve at the junk yard. $10. Haven't had a problem since.
__________________
06 A4 Q 2.0T - 86,000 miles
Dakar Biege


99.5 A4 Q 2.8 - 222,000 miles
Hibiscus Red Mica
mtroxel is offline   Reply With Quote
Old 09-22-2012, 03:52 PM   #5
AudiWorld Super User
 
GTA_Driver's Avatar
 
Join Date: Aug 2004
Location: Toronto
Posts: 3,277
Default

Quote:
Originally Posted by OCSadge View Post
Yes, I had a purge valve problem.
06 A4 USA model, 98k miles on it.

symptom: hard to start up after filling up gas tank, waited a few minutes then started up, but sometimes weak startup.

symptom: CEL on, then off, then back on over several weeks.

Audi dealer ran codes, said it was the PURGE N80 valve, replaced it. Audi quoted me $265 US Dollars for parts/labor. But a rival shop, Goodyear, quoted me $195. Audi came down a little bit due to my model year having so many issues.

A week later, engine started sputtering on acceleration, about 40-50 mph, and also on hard acceleration like when I accelerate to go onto the highway. Any ideas, anybody, as to diagnosis?
Scan the car again. To save yourself the trouble of going to the dealer for a scan each time, buy yourself VAG-COM and use your laptop to scan the car yourself.
GTA_Driver is offline   Reply With Quote
Old 09-22-2012, 11:13 PM   #6
Audiworld Junior Member
 
TheChenga's Avatar
 
Join Date: Aug 2011
Location: Texas
Posts: 99
Default

Quote:
Originally Posted by The Black Knight View Post
Car won't start after pumping gas unless I am giving it some serious gas. CEL codes 1136 and 1138 (system to lean). Posted a couple of months back, have not driven the car in about 3 months. Looked a purge valve and check valve both appear to be fine. Time to look at the charcoal canister, looked for a writeup couldent find one. Can someone tell me exactly where this is located (I know in the back somewhere near the spare tire.) How much do these usually go for? Is it something I can clean out or do I need to order a new one?

Thanks
this is from audizine http://www.audizine.com/forum/showth...er-replacement
TheChenga is offline   Reply With Quote
 
 
 
Reply

Tags
2003, 2005, a4, a6, audi, b5, canister, cannister, cansiter, car, charcoal, cleaned, location, tt, valve

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel filter replacement robsilvr85 Q7 Discussion 4 08-17-2015 03:49 PM
More on my issue. Žob A4 (B5 Platform) Discussion 14 02-13-2003 05:43 PM
A4: Certainly a driver's car!! but a reliable car?? ohoda A4 (B5 Platform) Discussion 11 11-07-2001 04:17 PM
tint opinions needed... HDClown A4 (B5 Platform) Discussion 3 07-28-2001 01:40 PM
A4 Dealer Service Experience: Who you talk to is important! (long but informative) Adam S A4 (B5 Platform) Discussion 3 10-20-2000 09:55 AM


All times are GMT -8. The time now is 06:06 AM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community