Secondary Air Injection pump running with engine off. - AudiWorld Forums

Go Back   AudiWorld Forums > Audi Models > Audi A4 > A4 (B5 Platform) Discussion
Sign in using an external account
Register Forgot Password?


A4 (B5 Platform) Discussion Discussion forum for the B5 Audi A4 produced from 1995-2001 B5 FAQ

Secondary Air Injection pump running with engine off.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
Old 10-15-2006, 02:09 PM   #1
AudiWorld Senior Member
 
Join Date: Mar 2000
Posts: 780
Default Secondary Air Injection pump running with engine off.

Well I've STFA and while I've found folks with this problem I don't find too many where it's been solved. It appears that the SAI pump is running with the engine OFF thereby killing my battery. I haven't yet changed vac lines just because it's pretty weird that this thing would run with the engine off. Soooooo the question is. . . lines? Solenoid? Pump? something else the culprit?

Just looking for some ammo if/when I take it in.

Thanks.
__________________
Pokechop is offline   Reply With Quote
Old 10-15-2006, 02:13 PM   #2
Member
 
Join Date: Dec 2000
Posts: 14,940
Default Relay, most likely.

bitjockey (bum) is offline   Reply With Quote
Old 10-15-2006, 02:19 PM   #3
AudiWorld Senior Member
 
Join Date: May 2005
Posts: 974
Default Check the relay

The ECU does two things to activate secondary air injection: it energizes the relay to start the pump, and it activates a valve using a vacuum solenoid.

My guess is that the relay has seized in the 'on' position. Either that or (less likely) the ECU circuit controlling the relay is fried.

Should be fairly easy to check the relay (in 3-socket relay carrier in the E-box, at left in plenum chamber, position 2). Pull it out, use a meter to see if the contacts are still closed.
__________________
SHARD7 - 99 A4 2.8 QMS

Engine - 30V V6 AHA (Meticulously Maintained In Stock Form)
Brakes & Suspension - Bilstein Sport Shocks | A8 Front Rotors / Stock Rear Rotors | PBR Ultimate Ceramic Pads
Wheels & Tires - Summer : 16" Swings + Avon M500s / Winter : 16" Sport Editions + Dunlop Wintersport 3Ds
Interior - Dieselgeek Short Shifter | Motorized In-Dash Ipod Drawer | Integrated Bluetooth Hands-Free System | <a href="http://flickr.com/photos/shard7/162746489/in/photostream/">
Ashtray Phone Cradle</a>
Exterior - RS4 Front Grill | W8 Belly Pan | No Stinkin' Badges

theMarkPatel.com
Shard7 is offline   Reply With Quote
Old 10-16-2006, 12:43 PM   #4
AudiWorld Member
 
Join Date: Jun 2001
Posts: 226
Default Just pull the fuse....

its not necessary to have it until you go through inspection.
__________________
www.awe-tuning.com
www.dunloptires.com

2008 Audi A4 Avant S-line
QUATTRO/6SPD/CONV/BT/NAV
EuroA4 is offline   Reply With Quote
Old 10-16-2006, 01:12 PM   #5
AudiWorld Super User
 
Join Date: Sep 2005
Posts: 6,524
Default just curious does that throw a code?

__________________
-Rob
Tow/Work Vehicle: 2007 Chevy 2500 HD DMax 411whp 855wtq
AIM: ScratchRob13
ScratchRob13 is offline   Reply With Quote
Old 10-16-2006, 01:42 PM   #6
Member
 
Join Date: Dec 2000
Posts: 14,940
Default yes, it will.

bitjockey (bum) is offline   Reply With Quote
Old 10-16-2006, 02:32 PM   #7
AudiWorld Senior Member
 
Join Date: Mar 2000
Posts: 780
Default Oooooo. . .good info! Maybe I can get in there tomorrow. Thanks. BTW it DOES throw code.

__________________
Pokechop is offline   Reply With Quote
Old 10-19-2006, 10:57 AM   #8
AudiWorld Senior Member
 
Join Date: Mar 2000
Posts: 780
Default $33 relay was THE ANSWER. Thanks for the suggestions.

__________________
Pokechop is offline   Reply With Quote
Old 04-16-2008, 09:04 AM   #9
AudiWorld Member
 
Join Date: Apr 2008
Posts: 19
Default Re: Secondary Air Injection pump running with engine off.

How did you fix ? I have the same problem and have no solution ?
irek is offline   Reply With Quote
Old 03-09-2009, 11:47 AM   #10
AudiWorld Member
 
Join Date: Aug 2000
Posts: 106
Default Re: $33 relay was THE ANSWER. Thanks for the suggestions.

I have the same problem. Stealership want $60 for the relay. Anyone have a cheaper and better source???

TIA
funkyfresh is offline   Reply With Quote
Old 01-11-2010, 05:55 AM   #11
Audiworld Junior Member
 
Join Date: May 2009
Posts: 16
Default

Which relay was this? Is wasn't the one with "219" printed on it, was it?
LeftFrank is offline   Reply With Quote
Old 01-11-2010, 03:03 PM   #12
AudiWorld Member
 
Join Date: Jan 2005
Posts: 115
Default

Quote:
Originally Posted by funkyfresh View Post
I have the same problem. Stealership want $60 for the relay. Anyone have a cheaper and better source???

TIA
I have one. Pulled it years ago when my SAI pump started making noise. $20 shipped in the lower lower 48 and it's yours.
anarchyjet is offline   Reply With Quote
Old 01-11-2010, 03:03 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
42, a4, air, audi, b6, continuously, engine, injection, injector, install, pump, running, runs, secondary, w8

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:04 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community