Go Back   AudiWorld Forums > Audi Models > Audi A4 > A4 (B6 Platform) Discussion
Sign in using an external account
Register Forgot Password?


A4 (B6 Platform) Discussion Discussion forum for the B6 Audi A4 produced from 2002-2005

Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 03-25-2014, 02:22 PM   #1
AudiWorld Newcomer
Account #: 279807
 
Join Date: Mar 2014
Posts: 2
Default A4 3.0 Quattro new owner have Eng Code ???

JUST bought my 1st Audi not even 2 months ago. Picked up a '03 A4 3.0 Quattro and LOVE IT!!! Has 158k on it but looks new! Already had to put a front dr side wheel bearing and CV shaft in it. Now the check eng. light is on. Had it scanned at Autozone and 3 codes popped up. I'm very mechanically inclined, just need some help on where to start with these codes.

1. Charcoal canister/purge valve
2. AIS
3. Clutch solenoid

1. Fixed (I read you can basically over fill the tank when refueling and that can fix it)... and it worked!!!

2. AIS... I had this system on my bike. Everyone (including myself) removed the pump and tubing because it cause 'popping' on decel when aftermarket pipes where installed. Is the AIS a common issue and what are the steps in diagnosing this?

3. Car runs, drives, shifts great! No issues! Why would this code pop????????
CrazyFast383 is offline   Reply With Quote
Old 03-25-2014, 08:51 PM   #2
AudiWorld Member
Account #: 23729
 
Join Date: Aug 2001
Location: Vancouver, BC, Canada
Posts: 379
Default

Clutch solenoid might be an old code; don't know why it would register as a CEL - clear it and see if it comes back.
__________________
(CDN - Special Edition 2008 B7 Avant 2.0T S-Line Dolphin Gray 6MTQS)
A4Audi4Fun is offline   Reply With Quote
Old 03-26-2014, 04:24 AM   #3
AudiWorld Super User
Account #: 178332
 
Join Date: Feb 2010
Location: Fort Worth, Tx
Posts: 2,020
Default

So the CEL is gone? If so, leave the car alone. If not, get a VAGCOM download so you can narrow down the issue. The generic readers can be misleading on AUDIs.
__________________
02 sport quattro with 205K; killed by a 4x4). Now an 03 1.8t sport quattro with 101K
lyleswk is offline   Reply With Quote
Old 03-30-2014, 05:06 PM   #4
AudiWorld Newcomer
Account #: 279807
 
Join Date: Mar 2014
Posts: 2
Default

Quote:
Originally Posted by lyleswk View Post
So the CEL is gone? If so, leave the car alone. If not, get a VAGCOM download so you can narrow down the issue. The generic readers can be misleading on AUDIs.
Sorry so what is a CEL? Used my dad's scanner and it was a bit more informative. The AIS was from Bank 2. Looked through the pile of oil change/service receipts in the glove box to see that the AIS bank 2 code came up before. Mechanics replaced a seal with a "used part".

The clutch solenoid code came through as basically the torque converter not locking up. We cleared all codes and about 15 miles eng light came back on. Haven't had a chance to scan it again yet.
CrazyFast383 is offline   Reply With Quote
Old 03-31-2014, 07:22 AM   #5
AudiWorld Super User
Account #: 178332
 
Join Date: Feb 2010
Location: Fort Worth, Tx
Posts: 2,020
Default

CEL = Check Engine Light.

Did you write down the code numbers? That is helpful.
__________________
02 sport quattro with 205K; killed by a 4x4). Now an 03 1.8t sport quattro with 101K
lyleswk is offline   Reply With Quote
Old 03-31-2014, 07:22 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:49 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community