Car Shaking/Check Engine Light/High RPM on idle - AudiWorld Forums

Go Back   AudiWorld Forums > Audi Models > Audi A4 > A4 (B6 Platform) Discussion
Log In 


A4 (B6 Platform) Discussion Discussion forum for the B6 Audi A4 produced from 2002-2005

Car Shaking/Check Engine Light/High RPM on idle

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-30-2012, 08:29 AM   #1
AudiWorld Member
 
Join Date: Feb 2011
Posts: 107
Default Car Shaking/Check Engine Light/High RPM on idle

So this happened in a short time period. Over this past weekend I was driving my car and at stop lights I noticed the car was shaking, it went away when I accelerated. Then when I woke up this morning my check engine light came on and the shaking of the engine was worse. The engine seems to be louder than usual. I drove immediately to auto zone and got the following codes:

P0300 - random misfire
P0301 - Cylinder 1 misfire
P0302 - Cylinder 2 misfire
P0303 - Cylinder 3 misfire
P0304 - Cylinder 4 misfire
P0507 - Idle Air Control System RPM higher than expected
P0171 - System too lean (Bank 1)

When the car is in motion everything seems fine except for the check engine light being on.

Any ideas?
LoPoVe is offline   Reply With Quote
Old 04-30-2012, 08:31 AM   #2
AudiWorld Member
 
Join Date: Feb 2011
Posts: 107
Default

I changed the ignition coils and spark plugs when the recall happened about 2 or 3 years ago. I also need an oil change and I will be doing that any day now.
LoPoVe is offline   Reply With Quote
Old 04-30-2012, 08:32 AM   #3
AudiWorld Member
 
Join Date: Feb 2011
Posts: 107
Default

Also I changed the timing belt when I had 90,000 miles, I now have 156,000 miles.
LoPoVe is offline   Reply With Quote
Old 04-30-2012, 09:35 AM   #4
AudiWorld Super User
 
Join Date: Feb 2010
Location: Fort Worth, Tx
Posts: 2,448
Default

That sounds more like a vaccuum or intake leak.
lyleswk is offline   Reply With Quote
Old 05-01-2012, 03:46 PM   #5
AudiWorld Newcomer
 
Join Date: Jul 2011
Posts: 9
Default Hmm

Sounds like a PCV issue. I had the exact same problems, misfire at idle along with all those misfire codes. Have a reach under and check all the pcv lines and hoses. Turns out the one connecting to the oil filter was disintegrating as when we pulled it off it literally crumbled.
joelj is offline   Reply With Quote
Old 05-01-2012, 03:57 PM   #6
AudiWorld Member
 
Join Date: Jan 2002
Posts: 172
Default

Sounds like a some sort of VAC leak, I agree with lyleswk.

Check your suction jet pump...(do a search for the item, because I don't have any photos)
ggcrash is offline   Reply With Quote
Old 05-07-2012, 05:59 PM   #7
AudiWorld Member
 
Join Date: Feb 2011
Posts: 107
Default

Gentlemen,

Thank you for the replies. It was a vacuum leak. I had a mechanic replace the black plastic valve, cost me $180. I think I got off easy. Car runs like brand new. I hope my audi lasts forever.
LoPoVe is offline   Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vibration idle/drive Mystery on 2004 3.0 6spd PhillBrown A4 (B6 Platform) Discussion 8 09-23-2015 07:48 PM
Changed thermostat, still overheating....... jared8783 A4 (B5 Platform) Discussion 15 09-09-2015 08:18 AM
My 2006 a4 2.0t is misfiring very rough and it shows 3 codes p0300, p0304 and p310b gregorydouglas89 A4 (B7 Platform) Discussion 18 09-01-2015 10:33 PM
Audi 90 - Very high oil pressure hardipk5 Audi 90 / 80 / Coupe quattro / Cabriolet 4 08-31-2015 08:27 AM
Serpentine Belt Tensioner Kris Hansen A4 (B7 Platform) Discussion 0 08-27-2015 06:45 AM


Tags
2002, a4, audi, car, check, engine, high, idle, light, lopove, rpm, rpms, shakes, shaking, stopped

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:26 AM.