Dealer saying ECM Faulty and Broken Vacuum Line, asking $4000 for repair - AudiWorld Forums

Go Back   AudiWorld Forums > Audi Models > Audi A4 > A4 (B7 Platform) Discussion
Sign in using an external account
Register Forgot Password?


A4 (B7 Platform) Discussion Discussion forum for the B7 Audi A4 produced from 2005-2008.5

Dealer saying ECM Faulty and Broken Vacuum Line, asking $4000 for repair

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-22-2014, 07:39 PM   #1
AudiWorld Newcomer
 
Join Date: Apr 2014
Posts: 1
Default Dealer saying ECM Faulty and Broken Vacuum Line, asking $4000 for repair

I have a 2007 Audi A4 3.2 with 99500 miles, i've regularly serviced my vehicle at Audi dealerships since purchasing in 2008 and my car is running perfectly fine. My check engine light recently came on and I took it in to a Audi dealership today and they did a diagnostic scan and found a "broken vacuum line" and "ECM faulty." They quoted me around $4000 to get both repaired. Does this sound right? Has anyone else had this problem?
chloe0831 is offline   Reply With Quote
Old 04-23-2014, 02:59 AM   #2
Chief of Goat control
 
Kris Hansen's Avatar
 
Join Date: Oct 2000
Posts: 66,549,960
Send a message via MSN to Kris Hansen
Default

No, that sounds insane. You could probably replace the whole engine for less than that.
__________________
Kris Hansen is offline   Reply With Quote
Old 04-23-2014, 02:59 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:20 AM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community