Go Back   AudiWorld Forums > Audi Models > Audi A6 / S6 / RS 6 > A6 / S6 (C5 Platform) Discussion
Sign in using an external account
Register Forgot Password?


A6 / S6 (C5 Platform) Discussion Discussion forum for the C5 Audi A6 and S6 produced from 1998-2004

Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 11-19-2013, 10:59 AM   #1
AudiWorld Senior Member
Account #: 62573
 
Join Date: Sep 2003
Location: N.E. Ohio
Posts: 1,137
Default 2000 A6 interior lights stay on? dash show doors open

I have a 2000 A6 with a interior light issue. the drivers door seems to work properly, but on the dash it shows the other 3 doors always open,and interior light on, until you start the car then it goes out. if you hit the brakes the lights comes on again.... it doesn't matter if all doors are open or not. dash shows 3 always open. i have no codes in the conv module or instruments.
any ideas here?

I find it very hard to believe there are 3 bad door switches and of course that would not explain why do the interior lights and instrument display light up when you hit the brake...
jschick is offline   Reply With Quote
Old 11-19-2013, 12:16 PM   #2
AudiWorld Super User
Account #: 80057
 
GTA_Driver's Avatar
 
Join Date: Aug 2004
Location: Toronto
Posts: 3,277
Default

Your convenience module got wet at all?
__________________
2005 AR 2.7 Black: GIAC stage 1, 710N, H-sport sway bars, Depo LED taillights

Past Audis: 2001 A6 4.2 | 2000 A4 1.8T Quattro 5-spd | 1993 100 CS Quattro | 1984 5000 CD turbo FWD
GTA_Driver is offline   Reply With Quote
Old 11-19-2013, 02:04 PM   #3
AudiWorld Senior Member
Account #: 62573
 
Join Date: Sep 2003
Location: N.E. Ohio
Posts: 1,137
Default

I did not remove the module, but the carpets are dry, and it has no codes, I can access it with Vag, so I assume it's ok. and the brake lights shouldn't tie into it, so i am thinking grounds or crossed wires someplace, but where??
jschick is offline   Reply With Quote
Old 11-19-2013, 09:35 PM   #4
AudiWorld Super User
Account #: 80057
 
GTA_Driver's Avatar
 
Join Date: Aug 2004
Location: Toronto
Posts: 3,277
Default

I would check the wiring in the rubber boot between te door and the frame of the car. Wire insulation can get brittle and crack. Start with the driver's door.
GTA_Driver is offline   Reply With Quote
Old 11-21-2013, 10:58 AM   #5
AudiWorld Senior Member
Account #: 62573
 
Join Date: Sep 2003
Location: N.E. Ohio
Posts: 1,137
Default

module dry and good, even swapped with another with same results. also the floor was totally dry and no signs of corrosion on any of the wiring under the drivers carpet, ( I have seen many times the crimp connections corrode and loose connection)

Door wiring all seems good?????
any other thoughts?

I did replace the trans module under the Pass carpet last year do to water damage,but I am not aware of any wiring issues on that side of the car
jschick is offline   Reply With Quote
Old 12-03-2013, 08:30 AM   #6
AudiWorld Senior Member
Account #: 62573
 
Join Date: Sep 2003
Location: N.E. Ohio
Posts: 1,137
Default

still stumped on this one, wiring under pass carpets also seems good, coudn't find any bad crimp connections,

with the car running and in D, the lights will come on and off as does the dash display showing doors open. for the 3 pass doors.

drivers door display works, open drivers door and it shows on display properly.

the other 3 show up on their own, and continue to come on and off.....
if you open any of the other 3 doors it shows all 3 doors open. and the lights may stay off for a minute or so then come back on on their own or if you open any of the 3 doors???????

does the same thing with a new module????
jschick is offline   Reply With Quote
Old 12-03-2013, 09:25 AM   #7
AudiWorld Member
Account #: 261305
 
Join Date: Jul 2013
Posts: 281
Default

I would suggest replacing one of the three door lock actuators (with the switch) and see if that solves it for that door. If that works, then replacing the other two might be indicated.
georgeb944 is offline   Reply With Quote
Old 12-03-2013, 09:37 AM   #8
Tech Guru
Account #: 43812
 
4Driver4's Avatar
 
Join Date: Oct 2002
Posts: 33,256
Default

Why not use VAG-COM measuring blocks to do some further diagnosis? There is a lot more to VAG-COM than the ability to pull codes. You should be able to see exactly what signal the control unit is receiving from each latch switch.
__________________
4Driver4

Growing old is mandatory; growing up is optional.

2005 A6 Sedan Q 3.2 (wife's whip)
2000 A4 Avant Q 2.8 (daily driver)
1980 VW Scirocco (mid-life crisis car)
1983 Mazda RX-7 (revolutionary sports car)
2003 Mini Cooper S (just because)
1995 Mazda Miata, Superdupercharged(anti-Audi)
1999 Mazda Miata SSB (track beotch, no plate)
2003 GMC Yukon Denali XL (the anti-earth)
2004 Dodge Dakota (hey, at least it's stick and 4x4)
4Driver4 is offline   Reply With Quote
Old 12-03-2013, 01:07 PM   #9
AudiWorld Super User
Account #: 80057
 
GTA_Driver's Avatar
 
Join Date: Aug 2004
Location: Toronto
Posts: 3,277
Default

Quote:
Originally Posted by 4Driver4 View Post
Why not use VAG-COM measuring blocks to do some further diagnosis? There is a lot more to VAG-COM than the ability to pull codes. You should be able to see exactly what signal the control unit is receiving from each latch switch.
I second this! The fact that all 3 doors are doing this tells me it's not a simple door switch in every passenger door. The only way forward at this point is to use VCDS to scan the module and test the output of each door sensor.
__________________
2005 AR 2.7 Black: GIAC stage 1, 710N, H-sport sway bars, Depo LED taillights

Past Audis: 2001 A6 4.2 | 2000 A4 1.8T Quattro 5-spd | 1993 100 CS Quattro | 1984 5000 CD turbo FWD
GTA_Driver is offline   Reply With Quote
Old 12-03-2013, 05:56 PM   #10
AudiWorld Senior Member
Account #: 62573
 
Join Date: Sep 2003
Location: N.E. Ohio
Posts: 1,137
Default

each door switch is working correctly except one rear door, all locks are fine. i did not pay much attention to readings when it goes crazy, i don't remember what Vag showing anything and even with all door wiring unplugged at the door jams same result on dash, I even went as far back as the plugs further down the harness at the kick panels. with them all unplugged the lights come on and off on their own.
jschick is offline   Reply With Quote
Old 12-03-2013, 05:56 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
01, 2000, 27t, a6, audi, closed, dash, display, door, doors, drivers, interior, lights, show, stay, wont


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:31 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community