Go Back   AudiWorld Forums > Audi Models > Audi A8 / S8 > A8 / S8 (D3 Platform) Discussion
Sign in using an external account
Register Forgot Password?


A8 / S8 (D3 Platform) Discussion Discussion forum for the D3 Audi A8 produced from 2003-2010 and Audi S8 produced from 2006-2010

Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 08-18-2014, 11:28 AM   #1
Audiworld Junior Member
Account #: 266588
 
Join Date: Sep 2013
Posts: 13
Default Air Suspension Problems

Hi,
I am coming to the end of my rope with the air suspension on my car. I have replaced the front struts, replaced the valve block and refurbished the compressor (however it is quite noisy now, comes on goes off periodically as you might expect) and I still have a rattly sounding suspension.

2 Faults Found:
01577 - Turn-Off due to Over-Temp
001 - Upper Limit Exceeded - Intermittent
Freeze Frame:
Fault Status: 00100001
Fault Priority: 4
Fault Frequency: 1
Reset counter: 102
Mileage: 207736 km
Time Indication: 0
Date: 2014.08.11
Time: 14:01:22
01772 - Signal from Level Control Pressure Sensor (G291)
008 - Implausible Signal - Intermittent
Freeze Frame:
Fault Status: 00101000
Fault Priority: 3
Fault Frequency: 6
Reset counter: 106
Mileage: 207758 km
Time Indication: 0
Date: 2014.08.12

So there must be a leak somewhere! Problem is it is totally inconsistent, some days it sounds worse than others and some days it's fine. I run through the VAGCOM tests and it passes ok. So it must be a very small leak but tracing it is a real problem. I've gone through the soapy water spray everywhere and no sign of a leak!
I usually drive in dynamic mode and on the rare occasions when it goes into fault mode it is great!

Any ideas anyone?

Thanks

Last edited by obo110x; 08-18-2014 at 12:17 PM.
obo110x is offline   Reply With Quote
Old 08-18-2014, 12:30 PM   #2
AudiWorld Super User
Account #: 195381
 
mishar's Avatar
 
Join Date: Nov 2010
Location: Vancouver, Canada
Posts: 4,900
Default

I don't see any indication of a leak. I think that you need a new compressor.
mishar is offline   Reply With Quote
Old 08-18-2014, 06:36 PM   #3
Audiworld Junior Member
Account #: 257901
 
Join Date: May 2013
Posts: 82
Default

+1 on the compressor.

Quote:
Originally Posted by mishar View Post
I don't see any indication of a leak. I think that you need a new compressor.
Compressor Air Suspension Audi A8 Model D3 | eBay
Petah Shillingford is offline   Reply With Quote
Old 08-21-2014, 09:21 AM   #4
Audiworld Junior Member
Account #: 266588
 
Join Date: Sep 2013
Posts: 13
Default New Compressor

Hi,
Thanks for the feedback I bought a new compressor off ebay had it fitted today and now I have a very unusual problem that hopefully somebody can offer a solution to.
The mechanic fitted the compressor and tested it, all running nice and quiet, put it into "Lift" position and he got the upper limit exceeded, the amber car symbol is flashing but it won't go into any other mode now, so it's stuck looking like a Q7! I got my VAGCOM plugged in to calibrate and the controller is refusing the security access key constantly, even after a battery reset!

Any ideas how I can get the thing down????
obo110x is offline   Reply With Quote
Old 08-21-2014, 09:36 AM   #5
AudiWorld Super User
Account #: 195381
 
mishar's Avatar
 
Join Date: Nov 2010
Location: Vancouver, Canada
Posts: 4,900
Default

Is that upper limit exceeded only code you got? What happens when you clear it?
mishar is offline   Reply With Quote
Old 08-21-2014, 09:48 AM   #6
Audiworld Junior Member
Account #: 266588
 
Join Date: Sep 2013
Posts: 13
Default

There is a fault code logged relating to the steering angle sensor implausible signal which returns. 01826 Sensor for Stering Angle (G85), Supply Voltage Terminal 30 000---

I guess that's the issue then, fuse popped or not plugged in properly, couldn't find the fuse in the handbook though.

Last edited by obo110x; 08-21-2014 at 10:03 AM.
obo110x is offline   Reply With Quote
Old 08-21-2014, 10:28 AM   #7
AudiWorld Super User
Account #: 195381
 
mishar's Avatar
 
Join Date: Nov 2010
Location: Vancouver, Canada
Posts: 4,900
Default

That code is not directly related with suspension level but it can trigger suspension limp mode (through ESP) and prevent any level changes. Try clearing it. There is no fuse for that.
mishar is offline   Reply With Quote
Old 08-21-2014, 10:50 AM   #8
Audiworld Junior Member
Account #: 266588
 
Join Date: Sep 2013
Posts: 13
Default

Hi,
Unfortunately this fault is persistent :-(
What is the location of the sensor and the unit that provides it with power?
obo110x is offline   Reply With Quote
Old 08-21-2014, 11:04 AM   #9
AudiWorld Super User
Account #: 195381
 
mishar's Avatar
 
Join Date: Nov 2010
Location: Vancouver, Canada
Posts: 4,900
Default

Steering Angel Sensor is just under your steering wheel (has to be removed). It is powered from Steering Column Electronic Systems Control Module and that one from the fuse 9, fuse panel B (left side of dashboard). If that fuse is burnt many things won't work.
mishar is offline   Reply With Quote
Old 08-21-2014, 11:37 AM   #10
AudiWorld Member
Account #: 112031
 
03_AR_CO's Avatar
 
Join Date: Jul 2006
Location: Colorado
Posts: 184
Default

Was the relay replaced when the compressor was replaced? It is advised to do so.
__________________
2006 A8L W12 Black/Black
MMI Firmware to 4610
VAG convenience locks/windows/sunroof open/close with remote fobs
VAG calibrated suspension, lowered ride height
Car has everything on it

2004 A8L Atlas Gray Metalic
MMI Firmware Upgrade from 0600 to 4610
OnStar to Bluetooth conversion
VAG convenience locks/windows/sunroof open/close with remote fobs



2003 allroad Burgundy (Sold but not forgotten, 212,000 great miles of driving)
03_AR_CO is offline   Reply With Quote
Old 08-21-2014, 11:37 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:16 AM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community