Go Back   AudiWorld Forums > Audi Models > Audi allroad
Sign in using an external account
Register Forgot Password?


Audi allroad Discussion forum for the original Audi allroad

Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 02-05-2008, 10:24 AM   #1
New Member
Account #: 144077
 
Join Date: Feb 2008
Posts: 1
Default ESP/ABS/Self-Leveling Suspension Warning Lights on Simultaneously

I have a 2002 Allroad, and recently, the ESP, ABS and Self-Leveling Suspension Warning Lights have been coming on all at once. Once I shut the car off and turn it back on, the warning lights are gone (though they may reappear after an hour or two of driving).

The leveler seems to be working fine, as are the brakes, though the air compressor for the leveler seems to run more often than usual on start up.

I took it to an Audi dealer for service, who thought it was the brake pedal switch, which was replaced. The tech also thought it might be the electric brake that was installed about a year ago, when I had the Audi Class 2 hitch installed. However, the warning light problem is recent, I've had the electric brake accessory for 18 months.

Any thoughts or suggestions would be appreciated.

Thanks,
Steve
DenverAllroad is offline   Reply With Quote
Old 02-05-2008, 10:54 AM   #2
AudiWorld Super User
Account #: 63674
 
Join Date: Oct 2003
Posts: 18,424
Default I've had two brake pedal switches replaced..

in the first 100K of ownership.
__________________

4/23/11: S4 Premium Plus, S'Tronic, Nav, Titanium body


Original Ride:
Bought New May 2003 allroad 2.7t 6 Speed
Sold @ 217,856 miles on April 23, 2011



-Mod/Repair Log
2400 Miles 5/28/11
New Conti Extreme DWS A/S Tires--smooths out the ride
OEM Dipstick--Need to see and smell the oil
OEM Rubber Mats--Look better than Stock Carpet and last longer
paulroad is offline   Reply With Quote
Old 02-05-2008, 11:10 AM   #3
AudiWorld Member
Account #: 137291
 
Join Date: Nov 2007
Location: Boston, Ma
Posts: 132
Default Me too, 1st at 26k and just last at 49k...brake pedal switch

__________________
Jeffrey

Alumni of a chipped - 04 2.7Tip
BlueAllroad is offline   Reply With Quote
Old 02-05-2008, 11:31 AM   #4
New Member
Account #: 137119
 
Join Date: Nov 2007
Posts: 154
Default Put me down for 4 of them in the first 45k. I now keep one in the glovebox.

__________________
-ChattanoogAR
"ZF5HP19FLA" is a four-letter word!

Current: '08 Subaru Outback
'01 Nissan Pathfinder SE 3.5
'84 VW Vanagon Wolfsburg

Past: '04 Audi allroad
'81 VW Rabbit LS
'85 VW GTI
'76 VW Westfalia
'89 Nissan Sentra 4sp
'92 Isuzu Trooper LS
'91 VW GTI 16v
'97 VW Jetta GT
ChattanoogAR is offline   Reply With Quote
Old 02-05-2008, 11:45 AM   #5
AudiWorld Super User
Account #: 55347
 
Join Date: Apr 2003
Posts: 17,262
Default I am about to have my 2nd replaced shortly. lights came on for me yesterday.

__________________


gragravar is offline   Reply With Quote
Old 02-05-2008, 01:37 PM   #6
Audiworld Junior Member
Account #: 85048
 
Join Date: Dec 2004
Posts: 323
Default Just happened to me yesterday, glad that's all it is - I will keep a couple in the glovebox now too!

__________________
Current:
'94 100 CSQ
'84 4000S 2.2L
Past:
'01 allroad
'86 4000S
'94 100Q Avant
'89 200 (I miss your 5cyl turbo)
'86 5000 CDT
'81 5000S
stevie_bc is offline   Reply With Quote
Old 02-05-2008, 02:34 PM   #7
AudiWorld Member
Account #: 98535
 
Join Date: Oct 2005
Posts: 207
Default Annoying but fairly common it seems.

__________________
A4toAR is offline   Reply With Quote
Old 02-05-2008, 03:03 PM   #8
Member
Account #: 120343
 
Join Date: Jan 2007
Posts: 243
Default Mine does the same thing but went away. Should I go ahead and rep

and is it something simple DIY?
OC02ALLROAD is offline   Reply With Quote
Old 02-05-2008, 04:23 PM   #9
AudiWorld Member
Account #: 7849
 
Join Date: Jul 2000
Posts: 309
Default Re: ESP/ABS/Self-Leveling Suspension Warning Lights on Simultaneously

Happened to me for a couple of months. The warning lights would always go away after turning the car on and off....however, they eventually would not go away. I took it in and they said the problem was (I'm copying in from the service receipt - I picked it up late that night and no one could explain what this all really meant):
Bag R+I Steering wheel R+R Clock spring code unit - performed zeroing - restore electrical power - r/t
__________________
-Former 2008 Audi Q7 3.6 Premium
-Former 2005 Audi Allroad 2.7T
-2004 Infiniti FX35
-Former 99.5 Santorin Blue A4 2.8Q-tip
gobridge is offline   Reply With Quote
Old 02-05-2008, 06:27 PM   #10
Audiworld Junior Member
Account #: 85048
 
Join Date: Dec 2004
Posts: 323
Default What's the P/N for a "brake pedal switch"....

I was just at the dealer getting a rear wiper blade and remembered this thread so I asked him how much one was, but he could not find anything called a "brake pedal switch" on the schematics.
__________________
Current:
'94 100 CSQ
'84 4000S 2.2L
Past:
'01 allroad
'86 4000S
'94 100Q Avant
'89 200 (I miss your 5cyl turbo)
'86 5000 CDT
'81 5000S
stevie_bc is offline   Reply With Quote
Old 02-05-2008, 06:27 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
08, abs, allroad, audi, esp, kit, leveling, light, lights, outback, selfleveling, subaru, suspension, system, warning


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:23 AM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community