Oil Level Check Error? - AudiWorld Forums



Q5/SQ5 MKI (8R) Discussion Discussion forum for the First Generation Audi Q5 SUV produced from 2008 to 2017

Oil Level Check Error?

Reply
 
 
 
Thread Tools Search this Thread
Old 04-16-2014, 11:17 PM   #1
Audiworld Junior Member
Thread Starter
 
hanyc42's Avatar
 
Join Date: Jan 2014
Location: Los Angeles
Posts: 25
Default Oil Level Check Error?

When I go to Car selection mode and to Oil Level check.

It says "The oil level display is available after approximately two minutes. The engine must be warm and turned off"

When I checked before this message has never popped up during any time and I was able to check the oil level without any problems. Now it shows no matter what circumstances...

Any solution or experiences on this matter??
hanyc42 is offline   Reply With Quote
Old 04-16-2014, 11:36 PM   #2
AudiWorld Super User
 
spijun's Avatar
 
Join Date: May 2010
Location: Sarajevo /BiH
Posts: 3,092
Default

It's normal when you open the hood of cars

http://forums.audiworld.com/showpost...7&postcount=12



Last edited by spijun; 04-16-2014 at 11:39 PM.
spijun is offline   Reply With Quote
Old 04-17-2014, 12:06 AM   #3
Audiworld Junior Member
Thread Starter
 
hanyc42's Avatar
 
Join Date: Jan 2014
Location: Los Angeles
Posts: 25
Default

Quote:
Originally Posted by spijun View Post
It's normal when you open the hood of cars

http://forums.audiworld.com/showpost...7&postcount=12


I did open the hood a few days ago and it has been like this since.
I am still not understanding why the oil level is not showing up...

DO I have to somehow reset it ?
hanyc42 is offline   Reply With Quote
Old 04-17-2014, 01:40 AM   #4
AudiWorld Super User
 
spijun's Avatar
 
Join Date: May 2010
Location: Sarajevo /BiH
Posts: 3,092
Default

Quote:
Originally Posted by hanyc42 View Post
I did open the hood a few days ago and it has been like this since.
I am still not understanding why the oil level is not showing up...

DO I have to somehow reset it ?
Everything is explained in the attached PDF : Oil Level Display

You need to wait a little longer sometimes 4-5 minutes
spijun is offline   Reply With Quote
Old 04-17-2014, 04:18 AM   #5
AudiWorld Super User
 
uberwgn's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 5,016
Default

Quote:
Originally Posted by hanyc42 View Post
I did open the hood a few days ago and it has been like this since.

I am still not understanding why the oil level is not showing up...

DO I have to somehow reset it ?
The system is constantly checking the engine oil level (dynamic measurement) with the engine running. It assumes that you added oil if you opened the hood. It takes several days, IME, for it to come up with a recalculated value. There is no way to accelerate this process.

You can check the oil level while driving by accessing the MMI once a new reading has been calculated.

If you want a real-time, static measurement: open the hood, engine off, view reading in MMI. I'm quite certain the engine needs to be hot for this to work.

uberwgn is online now   Reply With Quote
Old 04-17-2014, 08:08 AM   #6
Audiworld Junior Member
Thread Starter
 
hanyc42's Avatar
 
Join Date: Jan 2014
Location: Los Angeles
Posts: 25
Default

I have waited long time.... and it has been a couple days.
Still not showing up, thats why I am confused...
hanyc42 is offline   Reply With Quote
Old 04-17-2014, 08:09 AM   #7
AudiWorld Super User
 
uberwgn's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 5,016
Default

How many miles have you driven since opening the hood?
uberwgn is online now   Reply With Quote
Old 04-17-2014, 08:15 AM   #8
AudiWorld Senior Member
 
Join Date: May 2011
Location: Western Mass
Posts: 642
Default

After you have driven enough that the car is warm. Turn off the car, then push in the key without your foot on the brake (turn on ignition without starting). Wait a minute or two maybe longer sometimes as Spijun says above. Should be working again.
Did you do that yet? I have to do that every time I open my hood. Works every time.
rdA4WtQ5 is offline   Reply With Quote
Old 04-17-2014, 10:48 AM   #9
Audiworld Junior Member
Thread Starter
 
hanyc42's Avatar
 
Join Date: Jan 2014
Location: Los Angeles
Posts: 25
Default

Quote:
Originally Posted by uberwgn View Post
How many miles have you driven since opening the hood?
at least 30miles
hanyc42 is offline   Reply With Quote
Old 04-17-2014, 11:22 AM   #10
AudiWorld Super User
 
uberwgn's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 5,016
Default

That may not be far enough to log the new values.

You can always open the hood, key on, engine off and get an instant reading as an alternate.
uberwgn is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
:: ECS Tuning :: NEW!! B8 A4 2.0T ECS Baffled Oil Catch Can ECS Tuning-Audi A4 (B8 Platform) Discussion 14 12-23-2016 04:46 AM
Q5 Hybrid System Fault lazaroni77 Q5/SQ5 MKI (8R) Discussion 2 12-23-2015 03:47 AM
Thanks for helping! (New D3 owner) LONG CPLYONS A8 / S8 (D3 Platform) Discussion 7 09-07-2015 08:19 PM
:: ECS Tuning :: NEW!! B7 A4 2.0T ECS Baffled Oil Catch Can ECS Tuning-Audi A4 (B7 Platform) Discussion 0 09-01-2015 10:16 AM
:: ECS Tuning :: NEW!! B8 A5 2.0T ECS Baffled Oil Catch Can ECS Tuning-Audi Audi A5 / S5 / RS5 Coupe & Cabrio (B8) 0 09-01-2015 09:27 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 08:44 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send