Audi Q7 trailer hitch electrical Brake light problem - AudiWorld Forums

Go Back   AudiWorld Forums > Audi Models > Audi Q3 /Q5 / Q7 > Audi Q7 > Q7 Discussion
Sign in using an external account
Register Forgot Password?


Q7 Discussion Discussion forum for the Audi Q7 SUV
Sponsored by: Audi

Audi Q7 trailer hitch electrical Brake light problem

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
Old 05-28-2011, 04:50 PM   #1
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default Audi Q7 trailer hitch electrical Brake light problem

I recently had my dealership add an Audi hitch, and electrical harness with electric brake controller to my Q7.
When I hooked up my Pop Up Trailer Camper most everything works (turn signals, hazard lights) except the brake lights. When starting the car I get a message that the brake bulbs are out, first on the left side, then both. I took it to the dealer and after 2 days there they toll me the problem is on may trailer camper.
Notes: The trailer lights are brand new, and work fine on a ford f150 pick up truck. They are standard bulb lights (not LED).

Has Anybody else here had the same problem ??
__________________
2007 Q7 3.6 Premium
Calla White / Expresso Brown Premium Cricket Leather
Tamo Brown Beltline Trim
Panoroma Sunroof
4-Zone Climate Control
20" 5-spoke wheels Toyo Proxes ST II 295/45/20
Convenience package
Technology package
Infotainment package
15% Tints
Invision DVD Headrest with Sirius XM Back Seat TV
Smoked Tail Lights
Thule Euro Roof Rack
Tow Package
K&N Air Filter
Fleetwood EVO E3
Happy Camper!!!
marioec is offline   Reply With Quote
Old 05-29-2011, 01:13 PM   #2
AudiWorld Super User
 
Join Date: May 2006
Location: Ireland, Dublin
Posts: 7,334
Default

http://wiki.ross-tech.com/wiki/index...trofitting_(4L)
Did they recode after install?
That bulb fail report is typical of not being set for the heavier draw with extra bulbs.
Did they test your trailer on another Audi?
Did they test a different trailer (known to work) on your Q7?
Did anyone check the trailer plug wiring is correct for your Q7?

Sorry I have no definite answers but others have had similar probs. Plenty of web pages re; retrofit hitch, trailer VAG codes, Q7 trailer wiring.
Jusforfun is offline   Reply With Quote
Old 05-29-2011, 04:24 PM   #3
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default

Thank you for the reply !!

The Trailer camper lights all work good when towing with my ford F-150 the problem is when I connect the Q7 everything works but the break light signal. I also get the break light bulb light on the dash. When I'm backing up with the trailer the rear sensors are on and the beeping sound is also on. It seems that the Q7 those not recognize there is a trailer attach to it.

Question ? Do the backing up sensor turn on when backing soothing connected to the hitch ???
__________________
2007 Q7 3.6 Premium
Calla White / Expresso Brown Premium Cricket Leather
Tamo Brown Beltline Trim
Panoroma Sunroof
4-Zone Climate Control
20" 5-spoke wheels Toyo Proxes ST II 295/45/20
Convenience package
Technology package
Infotainment package
15% Tints
Invision DVD Headrest with Sirius XM Back Seat TV
Smoked Tail Lights
Thule Euro Roof Rack
Tow Package
K&N Air Filter
Fleetwood EVO E3
Happy Camper!!!
marioec is offline   Reply With Quote
Old 05-30-2011, 06:14 AM   #4
AudiWorld Super User
 
Join Date: May 2006
Location: Ireland, Dublin
Posts: 7,334
Default

No, once trailer electrics are plugged in the sensors go off or at least silent. The MMI screen will show you the traier. I think they still work because when you engage reverse it shows the type of trailer like the sensors can detect if it is a long narrow draw bar or a box and changes display accordingly.
Just check on your mmi control to see if towing mode is active once plugged in. (you can manually set it if you need. Handy for maneuvering without electrics plugged in (boats).
I suspect the coding is wrong as you have two problems showing up. There are 4 areas of coding to be done!
If the coding is not correct the ASM, anti sway, transmission settings, brake balance and lights (and air suspension if fitted) will not be working properly.
I hope they used the correct module/ plug loom and not used relays or bridge connectors.

The only reason I mentioned testing another trailer was in case your trailer and F150 were wired compatably to each other but not Q7.
Jusforfun is offline   Reply With Quote
Old 05-30-2011, 08:30 AM   #5
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default

I don't see in the MMI control the towing mode Is this something it should show in the MMI ?

I'm going to connect a jet ski trailer to the Q7 in a little while with a 7 blade to 4 pin flat adapter to see what happens and report back.
__________________
2007 Q7 3.6 Premium
Calla White / Expresso Brown Premium Cricket Leather
Tamo Brown Beltline Trim
Panoroma Sunroof
4-Zone Climate Control
20" 5-spoke wheels Toyo Proxes ST II 295/45/20
Convenience package
Technology package
Infotainment package
15% Tints
Invision DVD Headrest with Sirius XM Back Seat TV
Smoked Tail Lights
Thule Euro Roof Rack
Tow Package
K&N Air Filter
Fleetwood EVO E3
Happy Camper!!!
marioec is offline   Reply With Quote
Old 05-30-2011, 09:27 AM   #6
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default

I was checking the Q7 before driving to the storage to try to hook up the Jet Ski trailer to test it and when I plug the "HOPKINS ADAPTER part #47345 7 BLADE TO 4 BLADE FLAT" I get the left brake light bulb light in the dash again... Note: I still haven't plug the Jet trailer to the adapter is only plugged in the Q7 hitch plug.

Any thoughts on this ?
__________________
2007 Q7 3.6 Premium
Calla White / Expresso Brown Premium Cricket Leather
Tamo Brown Beltline Trim
Panoroma Sunroof
4-Zone Climate Control
20" 5-spoke wheels Toyo Proxes ST II 295/45/20
Convenience package
Technology package
Infotainment package
15% Tints
Invision DVD Headrest with Sirius XM Back Seat TV
Smoked Tail Lights
Thule Euro Roof Rack
Tow Package
K&N Air Filter
Fleetwood EVO E3
Happy Camper!!!
marioec is offline   Reply With Quote
Old 05-30-2011, 12:44 PM   #7
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default

Just got back from trying the Jet ski trailer to the Q7 and I get the same problem rear brake light on the dash again.

I think I will have the same problem regardless of the trailer a connect to the Audi.
This is really pissing me off. My vacation is coming up and I have this problem.
__________________
2007 Q7 3.6 Premium
Calla White / Expresso Brown Premium Cricket Leather
Tamo Brown Beltline Trim
Panoroma Sunroof
4-Zone Climate Control
20" 5-spoke wheels Toyo Proxes ST II 295/45/20
Convenience package
Technology package
Infotainment package
15% Tints
Invision DVD Headrest with Sirius XM Back Seat TV
Smoked Tail Lights
Thule Euro Roof Rack
Tow Package
K&N Air Filter
Fleetwood EVO E3
Happy Camper!!!
marioec is offline   Reply With Quote
Old 05-30-2011, 01:23 PM   #8
AudiWorld Member
 
Join Date: May 2010
Posts: 181
Default

If you are not getting the Tow option appearing in the MMI it sounds like it has not been set up properly for towing when they fitted the package.

With the factory package mine worked perfectly when the trailer was plugged in and you can also access the Tow option even when it is not plugged in.
scotskier is offline   Reply With Quote
Old 05-30-2011, 03:12 PM   #9
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default

Do you have Air suspension ?
__________________
2007 Q7 3.6 Premium
Calla White / Expresso Brown Premium Cricket Leather
Tamo Brown Beltline Trim
Panoroma Sunroof
4-Zone Climate Control
20" 5-spoke wheels Toyo Proxes ST II 295/45/20
Convenience package
Technology package
Infotainment package
15% Tints
Invision DVD Headrest with Sirius XM Back Seat TV
Smoked Tail Lights
Thule Euro Roof Rack
Tow Package
K&N Air Filter
Fleetwood EVO E3
Happy Camper!!!
marioec is offline   Reply With Quote
Old 05-30-2011, 03:53 PM   #10
AudiWorld Member
 
Join Date: May 2010
Posts: 181
Default

yes
scotskier is offline   Reply With Quote
Old 05-30-2011, 07:22 PM   #11
LOP
AudiWorld Member
 
LOP's Avatar
 
Join Date: Feb 2010
Location: Live Music Capital of the World, TX
Posts: 209
Default

One thing I learned is NOT to drive or even start the Q7 with the adapter in and the trailer lights NOT hooked up...I would get those errors if I did.

Shut it down, unplugged adapter, started Q7, everything normal.

Shut it down, plug in adapter AND trailer lights into adapter...all hooked up, start Q7 and everything works as normal.

Try it that way, you have nothing to lose but time.
__________________
2010 Q7 4.2 FSI Prestige S-Line
LOP is offline   Reply With Quote
Old 05-31-2011, 05:42 AM   #12
AudiWorld Member
 
Join Date: Jan 2004
Posts: 262
Default

I had the same problem this weekend hooking my car trailer (some lights working but the defective bulb message). I have pulled this trailer many times without a problem. Turned out I did not fully engage the plug from the trailer into the harness plug. I unplugged and replugged the connection and worked perfectly again.
__________________
-------------
2013 Audi S7 - Glacier White, Innovation, B&O, Cold Weather, Comfort Seats, Carbon Atlas
2010 Audi Q7 TDI - Prestige, Adaptive Air, Towing, Sunroof Delete, Warm Weather Package, Cold Weather Package
2002 Audi A6 4.2

2014 Porsche Cayman S
2007 Porsche GT3 (part time Track Car....)
1981 Porsche 911 SC (Track Car)
mikemdd is offline   Reply With Quote
Old 05-31-2011, 09:11 AM   #13
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default

I have no air suspension on my Q7. I'm going to the Audi dealer again today after work. I have checked everything and conected three different working trailers and I get the same problem.
__________________
2007 Q7 3.6 Premium
Calla White / Expresso Brown Premium Cricket Leather
Tamo Brown Beltline Trim
Panoroma Sunroof
4-Zone Climate Control
20" 5-spoke wheels Toyo Proxes ST II 295/45/20
Convenience package
Technology package
Infotainment package
15% Tints
Invision DVD Headrest with Sirius XM Back Seat TV
Smoked Tail Lights
Thule Euro Roof Rack
Tow Package
K&N Air Filter
Fleetwood EVO E3
Happy Camper!!!
marioec is offline   Reply With Quote
Old 05-31-2011, 10:07 AM   #14
LOP
AudiWorld Member
 
LOP's Avatar
 
Join Date: Feb 2010
Location: Live Music Capital of the World, TX
Posts: 209
Default

Quote:
Originally Posted by marioec View Post
I have no air suspension on my Q7. I'm going to the Audi dealer again today after work. I have checked everything and conected three different working trailers and I get the same problem.
...and you followed my instructions?

I hope you get it corrected, good luck!
__________________
2010 Q7 4.2 FSI Prestige S-Line
LOP is offline   Reply With Quote
Old 05-31-2011, 10:14 AM   #15
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default

Yes, I did what you toll me and nothing
__________________
2007 Q7 3.6 Premium
Calla White / Expresso Brown Premium Cricket Leather
Tamo Brown Beltline Trim
Panoroma Sunroof
4-Zone Climate Control
20" 5-spoke wheels Toyo Proxes ST II 295/45/20
Convenience package
Technology package
Infotainment package
15% Tints
Invision DVD Headrest with Sirius XM Back Seat TV
Smoked Tail Lights
Thule Euro Roof Rack
Tow Package
K&N Air Filter
Fleetwood EVO E3
Happy Camper!!!
marioec is offline   Reply With Quote
Old 05-31-2011, 03:37 PM   #16
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default

Problem solved !!!


I just got back from the dealer after explaining the service adviser the problem for the second time they went into the trailer setting in the VAG com and got it fixed. It was a simple configuration of the towing integration into the system.
marioec is offline   Reply With Quote
Old 05-31-2011, 06:53 PM   #17
LOP
AudiWorld Member
 
LOP's Avatar
 
Join Date: Feb 2010
Location: Live Music Capital of the World, TX
Posts: 209
Default

Quote:
Originally Posted by marioec View Post
Problem solved !!!


I just got back from the dealer after explaining the service adviser the problem for the second time they went into the trailer setting in the VAG com and got it fixed. It was a simple configuration of the towing integration into the system.
sweet!
__________________
2010 Q7 4.2 FSI Prestige S-Line
LOP is offline   Reply With Quote
Old 06-01-2011, 01:54 PM   #18
AudiWorld Member
 
Savior Six's Avatar
 
Join Date: May 2004
Location: Redondo Beach Los Angeles CA
Posts: 160
Default

Marioec,

That's awesome they got it fixed for you. I am running into the same problem. Did you bring your Q7 to the dealership with the trailer connected?

Quote:
Originally Posted by marioec View Post
Problem solved !!!


I just got back from the dealer after explaining the service adviser the problem for the second time they went into the trailer setting in the VAG com and got it fixed. It was a simple configuration of the towing integration into the system.
Savior Six is offline   Reply With Quote
Old 06-01-2011, 02:48 PM   #19
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default

Quote:
Originally Posted by scotskier View Post
If you are not getting the Tow option appearing in the MMI it sounds like it has not been set up properly for towing when they fitted the package.

With the factory package mine worked perfectly when the trailer was plugged in and you can also access the Tow option even when it is not plugged in.
Do you have air suspension ?
__________________
2007 Q7 3.6 Premium
Calla White / Expresso Brown Premium Cricket Leather
Tamo Brown Beltline Trim
Panoroma Sunroof
4-Zone Climate Control
20" 5-spoke wheels Toyo Proxes ST II 295/45/20
Convenience package
Technology package
Infotainment package
15% Tints
Invision DVD Headrest with Sirius XM Back Seat TV
Smoked Tail Lights
Thule Euro Roof Rack
Tow Package
K&N Air Filter
Fleetwood EVO E3
Happy Camper!!!
marioec is offline   Reply With Quote
Old 06-01-2011, 02:50 PM   #20
AudiWorld Member
 
marioec's Avatar
 
Join Date: Dec 2009
Location: Miami, Florida
Posts: 148
Default

I took it to the dealer with no trailer.
__________________
2007 Q7 3.6 Premium
Calla White / Expresso Brown Premium Cricket Leather
Tamo Brown Beltline Trim
Panoroma Sunroof
4-Zone Climate Control
20" 5-spoke wheels Toyo Proxes ST II 295/45/20
Convenience package
Technology package
Infotainment package
15% Tints
Invision DVD Headrest with Sirius XM Back Seat TV
Smoked Tail Lights
Thule Euro Roof Rack
Tow Package
K&N Air Filter
Fleetwood EVO E3
Happy Camper!!!
marioec is offline   Reply With Quote
Old 06-01-2011, 02:50 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
2, audi, brake, electric, electrical, hitch, light, lights, problem, q3, q7, qaudi, tow, trailer, usa, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:20 AM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community