Go Back   AudiWorld Forums > Audi Models > Audi S4 / RS4 > S4 (B8 Platform) Discussion
Sign in using an external account
Register Forgot Password?


S4 (B8 Platform) Discussion Discussion forum for the B8 Audi S4 produced from 2009-present

Parking Brake Malfunction help...

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 08-24-2011, 12:23 PM   #1
Audiworld Junior Member
Account #: 217593
 
turr520's Avatar
 
Join Date: Jul 2011
Location: Plano, Texas
Posts: 64
Default Parking Brake Malfunction help...

Hello all, I have a 2011 S4 with only 2000 miles. Last night when I started the car, I got a warning message for "Parking Brake Malfunction" and at the same time the Air Bag light came on and the "Passenger Airbag Off" light came on too (this was with an adult passenger sitting in the passenger seat). I drove the car, everything seems fine. About an hour later, I started the car again, the same warning message/lights came on.

Now the weird part is today I started the car and drove to work, no messages/lights. Everything seems as normal as before last night.

So..anyone had this problem before? Should I still take it to the dealership and had it checked out?

Thanks!
__________________

2012 VW GTI - Candy White. To be modified...
2011 Audi S4 - Prem+, Brilliant Red, DSG, Sport Diff, B&O, Nav, Nappa leather, Eurocode Alu Kreuz, Stvbek CF Aero Front Lip, DEVAL CF Rear Valence, Hüper Optik ceramic tint.
2006 Porsche Cayman S - Lapis Blue, Bose, 997TT-style wheels, Sprint Booster, HIP clear engine cover, Schild trunk liner, Milltek catback exhaust, CF aerodynamics, BumperPlugs painted interior trims.
turr520 is offline   Reply With Quote
Old 08-24-2011, 12:25 PM   #2
Audiworld Junior Member
Account #: 217593
 
turr520's Avatar
 
Join Date: Jul 2011
Location: Plano, Texas
Posts: 64
Default

Ohh...just wanted to add that today I didn't have anyone in the passenger seat. That's the only difference from last night I think. Thanks.
__________________

2012 VW GTI - Candy White. To be modified...
2011 Audi S4 - Prem+, Brilliant Red, DSG, Sport Diff, B&O, Nav, Nappa leather, Eurocode Alu Kreuz, Stvbek CF Aero Front Lip, DEVAL CF Rear Valence, Hüper Optik ceramic tint.
2006 Porsche Cayman S - Lapis Blue, Bose, 997TT-style wheels, Sprint Booster, HIP clear engine cover, Schild trunk liner, Milltek catback exhaust, CF aerodynamics, BumperPlugs painted interior trims.
turr520 is offline   Reply With Quote
Old 08-24-2011, 12:38 PM   #3
AudiWorld Super User
Account #: 44443
 
rktskicar's Avatar
 
Join Date: Oct 2002
Location: Seattle area
Posts: 10,854
Default

call your dealer and report this.

Bruce
__________________
"once a B5 S4 owner, always a B5 S4 fan"

APR ECU, 010 6MT Sprint Blue B8 S4. Premium +, Sport diff, B&O
BBS CH, 255/40/18 Bridgestone RE960 AS, Milltek resonated cat-back + DPs


Past:
01.5 6MT ASP Stage 3 S4 (4/01 to 9/09)
rktskicar is offline   Reply With Quote
Old 08-24-2011, 12:51 PM   #4
Audiworld Junior Member
Account #: 66425
 
Join Date: Dec 2003
Posts: 35
Default

Did you try to engage the parking brake? I had the same issue with my 2006 A6. The message would dissapear, but when i actualy try to engage the parking brake, i got the warning again. Took it to the dealer and they replaced faulty parking brate motor....
__________________
2012 6MT, Prestige, RSD, B&O, AWE Exhaust...
vanja026 is offline   Reply With Quote
Old 08-24-2011, 12:58 PM   #5
Audiworld Junior Member
Account #: 217593
 
turr520's Avatar
 
Join Date: Jul 2011
Location: Plano, Texas
Posts: 64
Default

No I never touched the parking brake before this happened. Then when I saw the warning message I tried and was able to engage/disengage the parking brake with no problem.

I'll drive around some more (maybe also with a passenger again) and see if this problem reappears.
__________________

2012 VW GTI - Candy White. To be modified...
2011 Audi S4 - Prem+, Brilliant Red, DSG, Sport Diff, B&O, Nav, Nappa leather, Eurocode Alu Kreuz, Stvbek CF Aero Front Lip, DEVAL CF Rear Valence, Hüper Optik ceramic tint.
2006 Porsche Cayman S - Lapis Blue, Bose, 997TT-style wheels, Sprint Booster, HIP clear engine cover, Schild trunk liner, Milltek catback exhaust, CF aerodynamics, BumperPlugs painted interior trims.
turr520 is offline   Reply With Quote
Old 08-24-2011, 04:03 PM   #6
AudiWorld Member
Account #: 189837
 
PsYkHoTiK's Avatar
 
Join Date: Aug 2010
Location: Redmond, WA
Posts: 438
Default

I had something like that happen where I got the warning on screen and a loud beep/noise (lol I can't remember what). Was sitting at a light and wanted to engage it (car was in neutral) when it gave a warning. I turned the car off and restarted it and the parking brake worked fine. Scanned with VAGCOM and there was a fault code (it's somewhere on this forum). Cleared it and it hasn't come back yet.
__________________
Current: 2013 Audi RS5 | Sepang Blue | Matte Alu-Optic | NAV

Former: 2011 Audi B8 S4 | Ice Silver | DSG | Sport Diff | APR 93 stage II+ V2
PsYkHoTiK is offline   Reply With Quote
Old 08-26-2011, 02:56 PM   #7
AudiWorld Senior Member
Account #: 42603
 
ayap's Avatar
 
Join Date: Sep 2002
Posts: 1,628
Default

It's under warranty, so take it to the dealer so they can check. But if it happened only once, could just be a glitch when turning the ignition on. It happens.

Quote:
Originally Posted by turr520 View Post
Hello all, I have a 2011 S4 with only 2000 miles. Last night when I started the car, I got a warning message for "Parking Brake Malfunction" and at the same time the Air Bag light came on and the "Passenger Airbag Off" light came on too (this was with an adult passenger sitting in the passenger seat). I drove the car, everything seems fine. About an hour later, I started the car again, the same warning message/lights came on.

Now the weird part is today I started the car and drove to work, no messages/lights. Everything seems as normal as before last night.

So..anyone had this problem before? Should I still take it to the dealership and had it checked out?

Thanks!
__________________
====================================
2012 Audi S5, Monsoon Gray, Black Leather
Tip Auto, Prem Plus+, Navi, Adv. Key, Carbon Fiber Trim, Sports Differential
----------------------------------------
2013 Audi Allroad, Phantom Pearl Black, Black Leather
8-Spd T-tronic, Prem Plus, Navigation/Rear Camera, Adv. Key, Sports Package/Paddles

-----------------------------
2006 Atlas Gray A6 Avant (gone, traded-in for 2013 Allroad, farewell)
2007 BMW 328xi Coupe 2Dr Sapphire Black (gone, traded-in for S5)
2008 Infiniti EX35 2WD Black (gone)
2004 Mazda RX8 Gray (gone)
2003 Cobalt Blue Audi Allroad (gone)



ayap is offline   Reply With Quote
Old 08-26-2011, 11:49 PM   #8
Audiworld Junior Member
Account #: 217593
 
turr520's Avatar
 
Join Date: Jul 2011
Location: Plano, Texas
Posts: 64
Default

Thanks all for your help. I did take it to the dealer. They gave me a Q5 2.0T as a loaner.

I took it in on Wednesday evening. Today (Friday) they told me they won't be able to check it out until Monday so I'm keeping the loaner for the weekend. It's probably not a big deal but I certainly didn't expect to be without my car for so long. :/
__________________

2012 VW GTI - Candy White. To be modified...
2011 Audi S4 - Prem+, Brilliant Red, DSG, Sport Diff, B&O, Nav, Nappa leather, Eurocode Alu Kreuz, Stvbek CF Aero Front Lip, DEVAL CF Rear Valence, Hüper Optik ceramic tint.
2006 Porsche Cayman S - Lapis Blue, Bose, 997TT-style wheels, Sprint Booster, HIP clear engine cover, Schild trunk liner, Milltek catback exhaust, CF aerodynamics, BumperPlugs painted interior trims.
turr520 is offline   Reply With Quote
Old 08-29-2011, 03:26 AM   #9
AudiWorld Newcomer
Account #: 221069
 
Join Date: Aug 2011
Posts: 6
Default Q5 - brake jammed on slope

I bought new 2011 Audi Q5 in Feb 2011. Last friday I parked it on a slope at the grocery shop's parking lot. After I put in reverse it starts to roll and the car lost barkes, Even if the geared were changed to park position the car kept rolling backwards and I hit the curb. Luckily no other car was involved and no one got hurt. But what if this happens again.
Did any one else experienced this?
Q52011hp is offline   Reply With Quote
Old 08-30-2011, 06:07 PM   #10
AudiWorld Member
Account #: 166606
 
Join Date: Jul 2009
Posts: 202
Default

FYI about the EPB, if you don't use it for a long time, the warning will come on. Just use it one in awhile.
oaktreelimb is offline   Reply With Quote
Old 08-31-2011, 10:01 PM   #11
Audiworld Junior Member
Account #: 217593
 
turr520's Avatar
 
Join Date: Jul 2011
Location: Plano, Texas
Posts: 64
Default

Thought I should give an update. I dropped my car off with my dealer last Wed evening. A week later (today) they finally told me that they need to replace the weight sensor for the passenger air bag. In addition to triggering the airbag warning light, it for some reason also is triggering the parking brake malfunction light.

Anyway, dealer told me they're ordering the part which has to be shipped from Germany. It will take another week to get here. So I may be getting my car back by the end of next week, in a best case scenario.

Sigh...any suggestions/advices are welcome.
__________________

2012 VW GTI - Candy White. To be modified...
2011 Audi S4 - Prem+, Brilliant Red, DSG, Sport Diff, B&O, Nav, Nappa leather, Eurocode Alu Kreuz, Stvbek CF Aero Front Lip, DEVAL CF Rear Valence, Hüper Optik ceramic tint.
2006 Porsche Cayman S - Lapis Blue, Bose, 997TT-style wheels, Sprint Booster, HIP clear engine cover, Schild trunk liner, Milltek catback exhaust, CF aerodynamics, BumperPlugs painted interior trims.
turr520 is offline   Reply With Quote
Old 09-14-2011, 08:34 PM   #12
Audiworld Junior Member
Account #: 217593
 
turr520's Avatar
 
Join Date: Jul 2011
Location: Plano, Texas
Posts: 64
Default

Updating this thread for future reference.

It took almost 3 weeks for me to get my car back. First they weren't sure what the problem was because the warning lights only came on "sporadically". Then they decided it was the passenger seat weight sensor that needed replacing. A part (8K0-898-522-L) had to be ordered from Germany and it took almost a week to arrive. Then they installed it and the fault was still there. Finally I think they disconnected and reconnected the battery and everything worked.

Specifically dealer "removed and replaced J706 service kit for seat occupied recognition control module." Eventually "disconnected battery for 15 minutes then reconnected. Cleared DTC's. Ran GFF. Performed adaptation of J706. checked operation. Test drove. OK."

I'm just glad I got my car back, in one piece. Whew...
__________________

2012 VW GTI - Candy White. To be modified...
2011 Audi S4 - Prem+, Brilliant Red, DSG, Sport Diff, B&O, Nav, Nappa leather, Eurocode Alu Kreuz, Stvbek CF Aero Front Lip, DEVAL CF Rear Valence, Hüper Optik ceramic tint.
2006 Porsche Cayman S - Lapis Blue, Bose, 997TT-style wheels, Sprint Booster, HIP clear engine cover, Schild trunk liner, Milltek catback exhaust, CF aerodynamics, BumperPlugs painted interior trims.
turr520 is offline   Reply With Quote
Old 09-14-2011, 09:15 PM   #13
Audiworld Junior Member
Account #: 221033
 
Join Date: Aug 2011
Posts: 58
Default

Well you had a loaner at no cost and they went through the process and fixed it so I would say everything was fair and good. sometimes things take longer than ideal becasue everything is not always an exact logged issue and fix but the good news is in the end you are back in business and no worse for the wear.
sepangS4 is offline   Reply With Quote
Old 02-26-2013, 05:08 PM   #14
AudiWorld Newcomer
Account #: 224875
 
Join Date: Oct 2011
Posts: 4
Default Q5 Parking Brake Malfunction Light and Air Bag Light

I have a 2012 Q5 and just wanted to confirm that an Air Bag fault can also set Parking Brake Malfunction Light. I removed the front passenger seat to clean a small spill between the seat and console and this caused the Parking Brake Malfunction Light and Air Bag Light to come on after plugging back in the wiring harnesses. I believe I caused this by turning on the ignition when the seat was unplugged. Took it to the dealer and they cleared the faults.
peakcityaudi is offline   Reply With Quote
Old 02-24-2014, 01:18 PM   #15
Audiworld Junior Member
Account #: 243880
 
Join Date: Sep 2012
Location: Portland, OR
Posts: 12
Default Help!!

Quote:
Originally Posted by peakcityaudi View Post
I have a 2012 Q5 and just wanted to confirm that an Air Bag fault can also set Parking Brake Malfunction Light. I removed the front passenger seat to clean a small spill between the seat and console and this caused the Parking Brake Malfunction Light and Air Bag Light to come on after plugging back in the wiring harnesses. I believe I caused this by turning on the ignition when the seat was unplugged. Took it to the dealer and they cleared the faults.
In reading your post it sounds like you are suggesting that the Airbag fault can also turn on the Parking Brake Malfunction warning?? I have a 2010 S4 and my friend who works at a car audio installation place was helping me make a new dash piece for my iPad install. He accidentally unplugged the hazard switch/pass airbag warning light warning light plug that is located in the factory trim bezel. Now my airbag light and parking brake malfunction light are both on. I have a code scanner but everytime I run it the device states no codes. Any ideas? Just wait it out?
x05179x is offline   Reply With Quote
Old 02-24-2014, 01:18 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
2010, 2011, a4, a8, audi, b8, brake, failure, fault, fix, malfunction, parking, q5, s4, system


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



Join AudiWorld

All times are GMT -8. The time now is 11:07 AM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community