Go Back   AudiWorld Forums > Audi Models > Audi S4 / RS4 > S4 / RS4 (B5 Platform) Discussion
Sign in using an external account
Register Forgot Password?


S4 / RS4 (B5 Platform) Discussion Discussion forum for the B5 Audi S4 & RS4 produced from 1998-2002

Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 07-27-2014, 06:09 PM   #1
Audiworld Junior Member
Account #: 68711
 
Join Date: Jan 2004
Posts: 70
Default Help with hesitation and turbos.

Advice on boost leak, hesitation and possible turbo lady.
2000 stage 2 175k. Last weekend I pulled away from a light briskly I would say 2/3 throttle. The car started hesitating badly so I pulled over and turned the car off. When I restarted the hesitation was gone but the right turbo was noticeably louder when boosting. I drove home and parked the car . This weekend I pressure tested the intake and no leaks were detected, I pulled the intercooler hoses and the left side had no more than a few drops of oil and the right side was bone dry. I have not put the pressure tester on the turbo inlet yet to check for leaks down there. I took the car on a test drive today and the right turbo is definitely still louder but boost and power seems normal at full throttle. The hesitation is back it occurs at tip in for 1-2 seconds but then the engine smooth's out.

No check engine light but I did pull 2 codes
17521 o2 sensor that has been there since last winter
16622 manifold pressure/ boost pressure sensor g31 signal too high

Any advice on my next things to check is much appreciated.
More info to help.
APR bibipe
Spider hose is 3 years old with approx. 20k on it.
MTM stage 2 chip
original ko3's
6 speed
Does not use oil
buch434 is offline   Reply With Quote
Old 08-03-2014, 12:22 PM   #2
Audiworld Junior Member
Account #: 68711
 
Join Date: Jan 2004
Posts: 70
Default

New boost sensor took care ok the hesitation. If I unplug the n75 sensor the turbo drill sound is gone ,it' just makes the normal spooling sound. Could that be because it's producing so little boost when unplugged ?
buch434 is offline   Reply With Quote
Old 08-03-2014, 12:22 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:57 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community