filled gas, epc light on, 4k max rpm warning? - AudiWorld Forums

Go Back   AudiWorld Forums > Audi Models > Audi A6 / S6 / RS 6 > S6 (C7 Platform) Discussion
Log In 


S6 (C7 Platform) Discussion Discussion forum for the C7 Audi S6 produced from 2012 - Present

filled gas, epc light on, 4k max rpm warning?

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-01-2014, 09:27 AM   #1
AudiWorld Member
 
Join Date: Apr 2013
Posts: 134
Default filled gas, epc light on, 4k max rpm warning?

last night I filled gas, started the engine and drove off. before I could even get out of the gas station, I hear a warning chime and an error message appeared. the EPC yellow light turned on and cluster said : reduced rpm, 4,000 rpm maximum. and the red lights went to 4k rpm. I stopped the car, turned it off and turned it back on. the warning went away and I was able to redline to 6500 again? I drove home last night and to work this morning, everything seems fine. I really don't want to waste time and go to the dealer if I don't have to. has this happened to anyone else? did they need to fix anything or was it a glitch?
mikec7s6 is offline   Reply With Quote
Old 04-01-2014, 09:33 AM   #2
Banned
 
Join Date: Mar 2010
Posts: 433
Default

Is the gas cap screwed on correctly?
in2dwww is offline   Reply With Quote
Old 04-01-2014, 11:15 AM   #3
Audiworld Junior Member
 
Join Date: Nov 2013
Posts: 41
Default

My EPC & Check Engine lights came on today too (it's been a few days since I refueled, so probably not that). As soon as it happened, I pulled over and shut the car off and restarted it but no joy. I was only a few miles from the dealer so I slowly limped it there. The engine felt and sounded like it wanted to stall and the transmission was almost violently rough. Currently waiting for a call from the service department with the diagnosis.
ronbars is offline   Reply With Quote
Old 04-01-2014, 12:38 PM   #4
AudiWorld Member
 
Join Date: Apr 2013
Posts: 134
Default

my car seems to be running fine? gas cap is installed correctly.
mikec7s6 is offline   Reply With Quote
Old 04-01-2014, 01:19 PM   #5
Audiworld Junior Member
 
Join Date: Jul 2012
Posts: 56
Default

I had a similar experience where I went to start car and it cranked and shut down. The acc mode stayed on with radio and llights wotking and pushing start stop button did nothing. The EPC and check engine light was on, I tried shutting car off with remote and didn't work. I then pressed start buton and tried jiggling it and it finally shutoff. Waited a minute and it started up fine. Didn't bother to take it in since it hasn't happened again. I am curious if this is a problem in our cars, waiting to see what your diagnosis is. Keep us posted.
teelo is offline   Reply With Quote
Old 04-01-2014, 02:50 PM   #6
AudiWorld Member
 
Join Date: Apr 2011
Location: The NH
Posts: 384
Default

Not to scare you, but I just read in the paper about a station local to me where the tanker truck driver accidentally put diesel in the gasoline tank underground. Hope that isn't it...just seems like too much of a coincidence that this would happen right after refueling.
__________________
2012 Mars Red Mercedes C63 AMG

2014 Scuba Blue Q5

*Need VCDS Mods in Southern NH?*
Will mod for beer!
nobbyv is offline   Reply With Quote
Old 04-01-2014, 03:02 PM   #7
AudiWorld Super User
 
tenspeed's Avatar
 
Join Date: Dec 2011
Location: Honeoye New York USA
Posts: 2,906
Default

Quote:
Originally Posted by nobbyv View Post
Hope that isn't it...just seems like too much of a coincidence that this would happen right after refueling.
Fuel oil in the gas tank would produce drastically low power and clouds of white smoke. My wife poured in 5 gallons of kerosene into our Jeep Cherokee years ago.
__________________
As I've grown older, I've learned that pleasing everyone is impossible,
but pissing everyone off is a piece of cake
2012 A7 3.0T Prestige, Ibis white/Nougat/Ash, 20" Sport, ACC, LED, HUD
tenspeed is online now   Reply With Quote
Old 04-01-2014, 09:25 PM   #8
Audiworld Junior Member
 
Join Date: Jan 2014
Posts: 16
Default

Quote:
last night I filled gas, started the engine and drove off. before I could even get out of the gas station, I hear a warning chime and an error message appeared. the EPC yellow light turned on and cluster said : reduced rpm, 4,000 rpm maximum. and the red lights went to 4k rpm. I stopped the car, turned it off and turned it back on. the warning went away and I was able to redline to 6500 again? I drove home last night and to work this morning, everything seems fine. I really don't want to waste time and go to the dealer if I don't have to. has this happened to anyone else? did they need to fix anything or was it a glitch?




Did you fill it up with the car running? That can trigger an EPC warning in most cars.
__________________
2014 S6 Glacier White, B&O, Black Optics, Piano Black Layered Aluminum inlays
lobosmd is offline   Reply With Quote
Old 04-02-2014, 06:39 AM   #9
Banned
 
Join Date: Mar 2010
Posts: 433
Default

There are a few check engine lights reported on the A6's as well:
http://forums.audiworld.com/showthread.php?t=2863282
in2dwww is offline   Reply With Quote
Old 04-03-2014, 06:15 AM   #10
Audiworld Junior Member
 
Join Date: Nov 2013
Posts: 41
Default

Latest word on my car is that a cam position sensor and some other sensor (the advisor didn't remember which) were showing faulty. They are working with Audi Techline, as apparently the two sensors are related and they're skeptical that they both failed at the same time - the idea being that there may be some fault further upstream causing the problem. I'm not thrilled that my <4,200 mile car is in the shop, but the dealer has been exceptional in their handling of everything thus far and I commend them for that.
ronbars is offline   Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
:: ECS Tuning :: NEW!! B8 S4 ECS Performance Lightweight Flywheel ECS Tuning-Audi S4 (B8 Platform) Discussion 2 03-27-2016 06:49 AM
:: ECS Tuning :: NEW!! B8 S5 3.0T ECS Performance Lightweight Flywheel ECS Tuning-Audi Audi A5 / S5 / RS5 Coupe & Cabrio 3 02-04-2016 08:36 AM
Help with 2005 Audi A6-3.2L quattro BKH bballfreak A6 / S6 (C6 Platform) Discussion 4 10-12-2015 05:14 PM
2009 TFSI engine oil change Help please sssmasss Audi A3 / S3 / RS3 11 10-07-2015 03:13 PM
2015 Q5 TDI 5,500 miles...Glow Plug light flashing.. SJGQ5 Q5/SQ5 Discussion 4 10-01-2015 08:44 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:33 PM.