Go Back   AudiWorld Forums > Audi Models > Audi A6 / S6 / RS 6 > S6 (C7 Platform) Discussion
Sign in using an external account
Register Forgot Password?


S6 (C7 Platform) Discussion Discussion forum for the C7 Audi S6 produced from 2012 - Present

Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 06-18-2014, 04:18 PM   #1
AudiWorld Newcomer
Account #: 266776
 
Join Date: Sep 2013
Posts: 9
Default latest issue... check engine light & "EPC"

Pulling out of a parking spot tonight in my 2014 S6... put car in reverse, took foot off brake and as soon as I started to reverse - the engines dies and the "check engine" and "EPC" lights came on. Then a warning "battery is disengaging (or discharging... I can't remember). Anyway, called Roadside Assistance and they informed me it's an electrical failure and car has to be towed to dealer. So, an hour later I'm home and my car is at the dealer.

Anyone else have this?
RHODEEHO is offline   Reply With Quote
Old 06-18-2014, 04:37 PM   #2
AudiWorld Member
Account #: 212616
 
Join Date: Apr 2011
Location: The NH
Posts: 340
Default

Quote:
Originally Posted by RHODEEHO View Post
Pulling out of a parking spot tonight in my 2014 S6... put car in reverse, took foot off brake and as soon as I started to reverse - the engines dies and the "check engine" and "EPC" lights came on. Then a warning "battery is disengaging (or discharging... I can't remember). Anyway, called Roadside Assistance and they informed me it's an electrical failure and car has to be towed to dealer. So, an hour later I'm home and my car is at the dealer.

Anyone else have this?
My EPC light came on the other day while heading to the dealer for my 15k service. There is a TSB to address the issue I had. But it sounds like you had more going on: I had no CEL or battery message. Sorry!
__________________
2013 Sepang Blue S6
2014 Scuba Blue Q5

*Need VCDS Mods in Southern NH?*
Will mod for beer!
nobbyv is offline   Reply With Quote
Old 06-18-2014, 06:15 PM   #3
AudiWorld Super User
Account #: 525
 
Join Date: Mar 2000
Posts: 20,314
Default

Quote:
Originally Posted by RHODEEHO View Post
Anyway, called Roadside Assistance and they informed me it's an electrical failure and car has to be towed to dealer. So, an hour later I'm home and my car is at the dealer.

Anyone else have this?
Sorry to hear! I carry a VCDS setup in my trunk because of an episode like this with my original C5...
__________________
Richard
'14 S6 4.0TQDSG
'01 A6 2.7TQM - Sold, Base bars available
"Turbos make torque, and torque makes fun." -Corky Bell

Please help get PDF manuals from AoA by supporting http://www.audipdfpetition.org
Richard Solomon is offline   Reply With Quote
Old 06-19-2014, 10:05 AM   #4
AudiWorld Member
Account #: 255751
 
Join Date: Apr 2013
Posts: 134
Default

epc light happened to me once and car also said reduced power/rpm to 4000 rpm, something like that. I turned the car off and back on and it seemed to have cleared itself. never had it happen again in about 5k miles.
mikec7s6 is offline   Reply With Quote
Old 06-20-2014, 02:27 AM   #5
AudiWorld Newcomer
Account #: 266776
 
Join Date: Sep 2013
Posts: 9
Default

Quote:
Originally Posted by RHODEEHO View Post
Pulling out of a parking spot tonight in my 2014 S6... put car in reverse, took foot off brake and as soon as I started to reverse - the engines dies and the "check engine" and "EPC" lights came on. Then a warning "battery is disengaging (or discharging... I can't remember). Anyway, called Roadside Assistance and they informed me it's an electrical failure and car has to be towed to dealer. So, an hour later I'm home and my car is at the dealer.

Anyone else have this?
Update: car spent the day at the dealer. Dealer found no issue, no faults recorded in computer. Car started immediately the morning after the engine died. Thankfully I took pics of the dash showing the lights & error message. I find these little glitches frustrating.
RHODEEHO is offline   Reply With Quote
Old 06-20-2014, 06:26 AM   #6
AudiWorld Super User
Account #: 22753
 
snagitseven's Avatar
 
Join Date: Jul 2001
Location: SE MA
Posts: 7,544
Default

Quote:
Originally Posted by Richard Solomon View Post
Sorry to hear! I carry a VCDS setup in my trunk because of an episode like this with my original C5...
You must also always have a laptop pc in your car (unless you bought the new standalone Ross-Tech scanner).
__________________

- 2013 A6 3.0T Prestige, Quartz Gray/Black, 19" Sport, Driver Assist, LED headlights,Cold Weather and B&O;
Bridgestone RE970AS tires; XPel Ultimate full front, mirrors and rocker panels, Opti-coat Pro
- 2002 allroad 2.7t - 13y/49K mi and still like new
- 2009 A4 3.2 Prestige w/Nav (sold at 4y/48K mi)
- 2001 A6 2.7t (sold at 8y/98K mi)
snagitseven is offline   Reply With Quote
Old 06-20-2014, 06:46 AM   #7
Audiworld Junior Member
Account #: 270386
 
Join Date: Nov 2013
Posts: 21
Default

I experienced the CEL+EPC with 4,000 RPM limit at 4166 miles. It turned out to be a short in the intercooler coolant pump, which blew a fuse thus depowering several other sensors on the same circuit. It took the dealer a few days to diagnose as Audi tech line was having them test every sensor/component on the circuit, and then another couple of days to receive and install the part. The dealer was fantastic throughout the whole thing and the car has been great since.
ronbars is offline   Reply With Quote
Old 06-20-2014, 07:11 AM   #8
AudiWorld Super User
Account #: 525
 
Join Date: Mar 2000
Posts: 20,314
Default

Quote:
Originally Posted by snagitseven View Post
You must also always have a laptop pc in your car (unless you bought the new standalone Ross-Tech scanner).
Yes, I did....originally this one:
Click the image to open in full size.

But then, yes, I did - more on that once I have the car
__________________
Richard
'14 S6 4.0TQDSG
'01 A6 2.7TQM - Sold, Base bars available
"Turbos make torque, and torque makes fun." -Corky Bell

Please help get PDF manuals from AoA by supporting http://www.audipdfpetition.org
Richard Solomon is offline   Reply With Quote
Old 06-20-2014, 07:51 AM   #9
AudiWorld Super User
Account #: 525
 
Join Date: Mar 2000
Posts: 20,314
Default

Quote:
Originally Posted by RHODEEHO View Post
no faults recorded in computer.
That actually surprises me greatly - I would be looking at power delivery (electrical) as almost nothing else would explain the ECU taking a dump and not recording it. Heck, fault codes in the C7 are even timestamped so I'm aghast that the ECU wouldn't log a failure - thus I presume that it *COULDN'T* log a failure.... which leads to power/ground questions.

Were I the technician, I would have grabbed hold of every connector I could find and given it a good wiggle, removed and reseated all ECU connections, and any other power distribution connectors I could reasonably easily reach.

I hope you got hit by cosmic rays or some other such gremlin, but it does make me nervous. OTOH, my HID igniter circuit failed exactly one time (in the dealership parking lot no less) throwing the dash indication and everything, then went away silently upon restart and hasn't reappeared (yet) in the intervening decade+.


When the original failure occurred, did you shut the car completely off and restart it? Kind of like a personal computer - shut down, wave hands and pray to the electronics gods, then restart?
__________________
Richard
'14 S6 4.0TQDSG
'01 A6 2.7TQM - Sold, Base bars available
"Turbos make torque, and torque makes fun." -Corky Bell

Please help get PDF manuals from AoA by supporting http://www.audipdfpetition.org
Richard Solomon is offline   Reply With Quote
Old 06-20-2014, 07:51 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:55 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community