Go Back   AudiWorld Forums > Technical Discussion > Electronics > VAG-COM Discussion
Sign in using an external account
Register Forgot Password?


Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 06-11-2014, 05:10 PM   #1
AudiWorld Newcomer
Account #: 279480
 
Join Date: Mar 2014
Posts: 8
Default Steering Angle Sensor / Steering Column Module (J527)

I have a 2003 Cabriolet 1.8t. Most of the electronics are not working, roof, windows, remote, wipers, turn signals, ect. I thought it was the CCM based on some research and replaced it but that didn't help. I finally found my cable so I ran the scan and this is what I came up with (after clearing all of the codes that were stored). Keep in mind the battery died on the car, it was jumpped, then the battery was replaced. Not sure if that is relevant to the problem. I see two main problems, the steering angel sensor and steering column module. I looked into this and it said most likely there are optic "eyes" that get dirty and need to be cleaned or the angle sensor needs replaced. I also heard it can be reset. Does anyone know where I can start to diagnosis this?

Thanks in advance!



Chassis Type: 8H (8H - Audi Cabrio B6/B7 (2003 > 2009))
Scan: 01 02 03 08 09 0F 11 15 16 17 18 25 26 36 37 45 46 55 56 57
63 65 67 73 75 76 77

VIN: WAUAC48H23K027820 Mileage: 266640km/165682miles
-------------------------------------------------------------------------------
Address 01: Engine Labels: 06B-909-518-AMB.lbl
Part No SW: 8E0 909 518 AF HW: 8E0 909 018 A
Component: 1.8L R4/5VT G 0003
Coding: 0016584
Shop #: WSC 00672 785 00200
VCID: 74E9D66C1490E0BE8FF-5178

1 Fault Found:
18107 - Powertrain Data Bus
P1699 - 008 - Missing Message from Steering Wheel Electronics
Readiness: 0110 1101

-------------------------------------------------------------------------------
Address 02: Auto Trans Labels: 01J-927-156.lbl
Part No: 01J 927 156 FF
Component: V30 01J 1.8l5VT USA 3011
Coding: 00001
Shop #: WSC 04940
VCID: 75EFEB684FEAF9B6B81-515A

No fault code found.

-------------------------------------------------------------------------------
Address 03: ABS Brakes Labels: 8E0-614-517.lbl
Part No: 8E0 614 517 G
Component: ABS/ESP front 2328
Coding: 04279
Shop #: WSC 00672
VCID: 2C590E0CDC20F87E17F-513C

1 Fault Found:
18036 - Powertrain Data Bus
P1628 - 35-00 - Missing Message from Steering Angle Sensor

-------------------------------------------------------------------------------
Address 08: Auto HVAC Labels: 8E0-820-043.lbl
Part No: 8E0 820 043 L
Component: A4 Klimaautomat 1116
Coding: 00100
Shop #: WSC 00672
VCID: 2A550814D6D4E64EE53-515A

No fault code found.

-------------------------------------------------------------------------------
Address 15: Airbags Labels: 8H0-959-655-84.lbl
Part No: 8H0 959 655 B
Component: Airbag 8.4EC 1015
Coding: 0010105
Shop #: WSC 00672 785 00200
VCID: 3977275873725DD69C9-5178

No fault code found.

-------------------------------------------------------------------------------
Address 17: Instruments Labels: 8E0-920-9xx-8E2.lbl
Part No: 8H0 920 950 E
Component: KOMBI+WEGFAHRS. RB4 D16
Coding: 02201
Shop #: WSC 03055
VCID: 2E5D0404EA3C8A6E39B-5178
WAUAC48H23K027820 AUZ6Z0C0062338

No fault code found.

-------------------------------------------------------------------------------
Address 55: Xenon Range Labels: 4Z7-907-357.lbl
Part No: 4Z7 907 357
Component: dynamische LWR D09
Coding: 00070
Shop #: WSC 00672
VCID: 040986AC1430D03EBFF-4B4A

No fault code found.

-------------------------------------------------------------------------------
Address 56: Radio Labels:
VCID: 55AF8BE8AC2A99B6981-4ECA
Note: Excessive Comm Errors


-------------------------------------------------------------------------------
Address 63: Entry Assist,D Labels: None
Part No: 8H0 959 760 A
Component: EasyEntry F H11 X023
Coding: 00005
Shop #: WSC 00065
VCID: 356F2B680F6AB9B6781-4B32

1 Fault Found:
00466 - Control Module for Steering Column Electronics (J527)
49-00 - No Communications

-------------------------------------------------------------------------------
Address 73: Entry Assist, P Labels: None
Part No: 8H0 959 760 A
Component: EasyEntry BF H11 X023
Coding: 00005
Shop #: WSC 00065
VCID: 356F2B680F6AB9B6781-4B18

1 Fault Found:
00466 - Control Module for Steering Column Electronics (J527)
49-00 - No Communications

End ---------------------------------------------------------------------
HereInOhio is offline   Reply With Quote
Old 06-12-2014, 05:53 AM   #2
AudiWorld Super User
Account #: 208615
 
jakematic's Avatar
 
Join Date: Feb 2011
Location: NC USA
Posts: 2,502
Default

First, thank you for posting a complete Auto-Scan as it always helps

My biggest concern is module 16 (steering wheel) is missing from the scan.
First thing I'd do is run an Optical Bus diagnostic to see if any other module is having a problem.

I suspect the radio has something to do with it, but that's just a guess at this point.
Next step is to isolate the issue and check all wiring and optical connections.

If that doesn't help, you might need to replace J527.
That might require immobilizer pairing which can only be done by a dealer or specially authorized shop though.
__________________
Links to Ross-Tech: forum, wiki

2012 A8L 4.2 Oolong/Titanium. Premium, LED, Driver assist, Rear seat comfort, Dual pane, Alcantara, Panorama
jakematic is offline   Reply With Quote
Old 06-12-2014, 07:37 AM   #3
AudiWorld Newcomer
Account #: 279480
 
Join Date: Mar 2014
Posts: 8
Default

I tried to run the module scan on the steering wheel and it said it didn't communicate. I didn't know if that could be if the sensor is bad or if the module is bad. If it could be the sensor I wanted to try to reprogram it before replacing it.

I pulled the radio and checked the 10 amp fuse, it was fine. The radio works fine besides the fact you can turn it on ANY time.

As far as the Optical Bus scan I beleive that is for CAN cars only which this one is before that time from what I researched. I will try anyways when I go home but don't think it will get far. The KII cable had a green light which should mean both K lines are ok and info is flowing completely.

I can probably get the steering angle sensor and the module fairly cheap, do you know how I can tell if it will need to be taken to the dealership to have paired?
HereInOhio is offline   Reply With Quote
Old 06-12-2014, 07:51 AM   #4
AudiWorld Super User
Account #: 208615
 
jakematic's Avatar
 
Join Date: Feb 2011
Location: NC USA
Posts: 2,502
Default

Quote:
Originally Posted by HereInOhio View Post
As far as the Optical Bus scan I beleive that is for CAN
BAH! We've already had that conversation, sorry

I'm kind of shooting in the dark on this, so hopefully others can give you more complete information, and you may get better support on the thread you started at Ross-Tech.
__________________
Links to Ross-Tech: forum, wiki

2012 A8L 4.2 Oolong/Titanium. Premium, LED, Driver assist, Rear seat comfort, Dual pane, Alcantara, Panorama
jakematic is offline   Reply With Quote
Old 06-12-2014, 07:51 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
a4, angle, audi, auto, fault, reset, sensor, v6


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:32 AM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community