B7 S4 Throttle Issues

 
Old 10-10-2017, 06:29 PM
  #1  
AudiWorld Newcomer
Thread Starter
 
Join Date: Oct 2017
Location: Monterey Bay
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default B7 S4 Throttle Issues

Hey guys, new to the forums here. Been searching all sorts of places for an answer and have tries things that were for similar problems but to no avail. I'll try and be as detailed as possible to eliminate any unanswered questions to keep this concise. I just bought a 2007 audi s4 avant, 41k miles, has had a prior n/a tune, and had a ppi done by auid and passed. I had the car delivered to me from half way across the country and after 5 minutes with this car it broke down. These are the codes i pulled after the epc and cel lighted.
05442 - angle sensor 1 for throttle actuator
05497 - throttle actuator
04465 - angle sensor 2 for throttle actuator
05465 - throttle body
05634 - power supply terminal 30: voltage too low
00518 - injector cylinder 6 circuit malfunction
00768 - random/multiple cylinder misfire detected
00774 - cylinder 6 misfire detected
I'll try and upload a picture with the codes as well but i wanted to get the ball rolling on suggestions first. I took it to audi and they said they couldn't read the codes and that the obd2 port needed replacing, they did so, they also flashed the ecu so remove to the tune and see if that fixes anything. Nothing foxed. they did some shotgun mechnicing and said i need a new ecu and throttle body. I said im not paying 3k for that and left with my car. Bought a ecu and throttle body for 300 from a junked who specializes in audis. Replaced the throttle body, but not the ecu because that would mean another trip to audi for them to update it. Ran perfect for 50 miles then i started getting idle issues. The throttle would sputter upon startup and would resolve under load from gearing movement, ie driving. Has progressively gotten worse so all im left with is to try and swap in the old throttle body back because it looked brand new, maybe a pre existing issue i think that i wasnt told about, and try the new ecu. But in the mean time i would appreciate any and all input. Since i just did the throttle body, all the misfires and stalling went away. Now i just have throttle issues, from sputtering to no response to pedal pushing. Thanks in advance anyone.
Bostonbird is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
deephouse
Audi Original "S" Cars
3
12-20-2007 05:38 PM
TTransport
TT (Mk1) Discussion
10
01-09-2007 08:54 AM
sadik007
Audi 90 / 80 / Coupe quattro / Cabriolet
1
06-05-2006 06:38 AM
zszabo
A4 (B5 Platform) Discussion
4
12-31-2004 12:19 PM
Milpitas2.7T
S4 / RS4 (B5 Platform) Discussion
4
07-07-2004 05:37 PM


Thread Tools
Search this Thread
Quick Reply: B7 S4 Throttle Issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: