Go Back  AudiWorld Forums > Technical Discussion > Engines > 4.2 V8 Discussion
Reload this Page >

Temperature gauge stops working

Temperature gauge stops working

 
Old 02-04-2014, 09:03 PM
  #1  
AudiWorld Newcomer
Thread Starter
 
ShaddowBlade's Avatar
 
Join Date: Jan 2014
Location: Chattanooga, TN
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Temperature gauge stops working

Hello all, I have a 2006 A6 4.2 Quattro. The temp gauge stops working after about 15-30 min, then awhile later the CEL comes on. When I check it, I get a 2181 code. I reset the code, I replaced the temp sensor in back of engine, it works normal again for awhile, but It still keeps going out. Any ideas? I went to dealer they say it's the thermostat $750 to fix. The car does not over heat, runs normal. Please help.
ShaddowBlade is offline  
Old 02-07-2014, 05:08 PM
  #2  
AudiWorld Super User
 
Prospeeder's Avatar
 
Join Date: Aug 2011
Location: Washington
Posts: 2,369
Likes: 0
Received 0 Likes on 0 Posts
Default

Ok so wheres what you need to do. Verify actual engine temperature when the gauge is claiming cold. If the upper radiator hose is not something higher than 150-160 degrees than the thermostat is sticking and not letting the engine warm up. If its fine, but gauge still doesnt work, wire harness for temp sensor, either the connector or harness.
Prospeeder is offline  
Old 02-12-2014, 12:37 AM
  #3  
AudiWorld Newcomer
Thread Starter
 
ShaddowBlade's Avatar
 
Join Date: Jan 2014
Location: Chattanooga, TN
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Ok thank you I'll check, is the connector/harness easy to replace or is it a dealer repair?
ShaddowBlade is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
aessis
A6 / S6 (C6 Platform) Discussion
6
11-19-2017 03:34 PM
7ofbc13
TT (Mk2) Discussion
0
07-05-2017 02:36 PM
dblake15
A4 (B5 Platform) Discussion
7
07-09-2003 10:07 AM
TicketProof
A4 (B5 Platform) Discussion
4
01-30-2002 01:48 PM
Johnny-cat
Audi 100 / A6 (C4 Platform)
6
10-16-2001 09:54 PM


Thread Tools
Search this Thread
Quick Reply: Temperature gauge stops working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: