A4 (B8 Platform) Discussion Discussion forum for the B8 Audi A4 produced from 2008.5-present

2010 Audi A4 - Random Stall

 
Old 03-12-2019, 06:40 AM
  #1  
AudiWorld Newcomer
Thread Starter
 
Join Date: Mar 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default 2010 Audi A4 - Random Stall

Some facts:
1. Got an oil change - Day 1
2. Hit a pole at low speed (front end), could have Jarred something, don't see anything visible - Day 3
3. Car stalled at low speed after stopping at a stop-light - Day 4
4. Pulled code P0341 - Camshaft position sensor. Replaced it - Day 5
5. Drove to work, drove home, stopped at intersection, car stalled in middle of intersection (didn't even get it past 10mph), turned car back on, drove home. - Day 6
6. Pulled codes, no codes shown - Day 6
7. Tested battery - 12.6v car off, turned on car - tricked from 12.6v to 13.8v - Day 6
** few months ago had all coils replaced **

From what I read, a low battery could make your car stall, but I don't know if 12.6 not running (car starts right up/lights are not dim/all instruments Ok), and 13.8v with the alternator charge, would cause this.

Any ideas what could be happening here, is it a battery or alternator issue?

Thanks
gtp01 is offline  
Old 03-12-2019, 06:50 AM
  #2  
AudiWorld Senior Member
 
Join Date: Aug 2010
Location: NY
Posts: 770
Likes: 0
Received 1 Like on 1 Post
Default

Originally Posted by gtp01 View Post
Some facts:
1. Got an oil change - Day 1
2. Hit a pole at low speed (front end), could have Jarred something, don't see anything visible - Day 3
3. Car stalled at low speed after stopping at a stop-light - Day 4
4. Pulled code P0341 - Camshaft position sensor. Replaced it - Day 5
5. Drove to work, drove home, stopped at intersection, car stalled in middle of intersection (didn't even get it past 10mph), turned car back on, drove home. - Day 6
6. Pulled codes, no codes shown - Day 6
7. Tested battery - 12.6v car off, turned on car - tricked from 12.6v to 13.8v - Day 6
** few months ago had all coils replaced **

From what I read, a low battery could make your car stall, but I don't know if 12.6 not running (car starts right up/lights are not dim/all instruments Ok), and 13.8v with the alternator charge, would cause this.

Any ideas what could be happening here, is it a battery or alternator issue?

Thanks
Normal full charged battery with key off and sitting for 15 minutes is 12.6 volts. If lower then it would need charge or replacement. Normal running voltage is usually between 13.7 to 14.2 volts. Anywhere in between is OK. At these voltages your battery and alternator are operating correctly. This would not make your car stall. You have an intermittent issue which would be hard to trace unless it gives a code. Possibly the dealer diagnostic system may find a fault but because it doesn't happen all of the time it would be difficult. At this point I would go to them. If it happens at stop or idle speed then I would look at the IAC or throttle body.
jagtoes is offline  
Old 03-12-2019, 11:46 AM
  #3  
AudiWorld Newcomer
Thread Starter
 
Join Date: Mar 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by jagtoes View Post
Normal full charged battery with key off and sitting for 15 minutes is 12.6 volts. If lower then it would need charge or replacement. Normal running voltage is usually between 13.7 to 14.2 volts. Anywhere in between is OK. At these voltages your battery and alternator are operating correctly. This would not make your car stall. You have an intermittent issue which would be hard to trace unless it gives a code. Possibly the dealer diagnostic system may find a fault but because it doesn't happen all of the time it would be difficult. At this point I would go to them. If it happens at stop or idle speed then I would look at the IAC or throttle body.
Thanks for your reply. I've read it could be many things, too many for me to look into. Going to take it to my guy, I'm sure he has a much more up to date scanner they use at the shop than I do.
gtp01 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
artemm
A4 (B5 Platform) Discussion
13
02-12-2008 12:19 PM
StreetCrawler(Cole)
S4 / RS4 (B5 Platform) Discussion
6
05-17-2005 09:02 AM


Thread Tools
Search this Thread
Quick Reply: 2010 Audi A4 - Random Stall


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: