Go Back  AudiWorld Forums > Audi Models > Audi A4 > A4 (B9 Platform) Discussion
Reload this Page >

Coding for turning on Audi Active Lane Assist (all cars with pre sense)

A4 (B9 Platform) Discussion Discussion forum for the B9 Audi A4 2017-

Coding for turning on Audi Active Lane Assist (all cars with pre sense)

 
Old 10-12-2016, 03:34 PM
  #11  
AudiWorld Member
 
gguy's Avatar
 
Join Date: Sep 2016
Location: Oregon
Posts: 525
Default

This is all new to me, so just to help me out: As I understand it, in my PP A4, if I activate this, the only way to turn it off is to go back in and "recode" it to remove the option? There is no way to just temporarily disable it for a few minutes while I am using it?
gguy is offline  
Old 10-12-2016, 03:40 PM
  #12  
AudiWorld Super User
 
HyperS4's Avatar
 
Join Date: Feb 2010
Location: Lawrenceville, NJ
Posts: 2,410
Default

Absolutely awesome work. Thank you for taking the time to figure this out and share it with the forum.
HyperS4 is offline  
Old 10-12-2016, 03:42 PM
  #13  
AudiWorld Senior Member
 
Strife1013's Avatar
 
Join Date: May 2012
Location: Little Rock, AR
Posts: 1,014
Default

So if you can all those features in a PP+ what do those black sensors do? Does traffic sign recognition work and if so will it come up on the HUD on the prestige models?
Strife1013 is offline  
Old 10-12-2016, 04:01 PM
  #14  
AudiWorld Senior Member
Thread Starter
 
Mitchfin's Avatar
 
Join Date: Apr 2016
Location: Utah
Posts: 955
Default

Originally Posted by Manny Lopez View Post
Are you kidding me, you're freakin awesome! Worked like a charm! It also added the menu in the mmi to turn vibration on/off and steering correction early/late. I wonder if this will work on my wife's 17 A4. She doesn't have VC but the A5 module is standard.
Glad it worked! this will work on 2017 A4 without VC.
Mitchfin is offline  
Old 10-12-2016, 04:05 PM
  #15  
AudiWorld Super User
 
SYMAWD's Avatar
 
Join Date: Apr 2016
Location: New Jersey
Posts: 4,113
Default

Originally Posted by Strife1013 View Post
So if you can all those features in a PP+ what do those black sensors do? Does traffic sign recognition work and if so will it come up on the HUD on the prestige models?
By black sensors, do you mean the 2 "bulbs" in the bumper in the DAP? They are for the adaptive cruise control.

Pre Sense City, lane assist, and traffic sign recognition are just camera based.
SYMAWD is offline  
Old 10-12-2016, 04:06 PM
  #16  
AudiWorld Senior Member
Thread Starter
 
Mitchfin's Avatar
 
Join Date: Apr 2016
Location: Utah
Posts: 955
Default

Originally Posted by HyperS4 View Post
Absolutely awesome work. Thank you for taking the time to figure this out and share it with the forum.
Of course, I become a dog with a bone when I can't figure something out, and there is NOWHERE on the internet that outlines the whole procedure for these new models (it took a lot of google translate). Also big thanks to AudiA4B6US for helping me figure out the missing link (SPE and STA, still don't know what they stand for).

I kind of feel like I'm gaming the system too, I like that
Mitchfin is offline  
Old 10-12-2016, 04:14 PM
  #17  
AudiWorld Senior Member
Thread Starter
 
Mitchfin's Avatar
 
Join Date: Apr 2016
Location: Utah
Posts: 955
Default

Originally Posted by Manny Lopez View Post
Figured it out! I did the initial A5 coding through the word description rather then the bits. Went back in to check the bits and they were not set. Recoded A5 and now I'm able to set the adaptations! Presense fault is no longer in the cluster. Now for the test drive!
Yes sorry, the bits are for the VCDS users because they don't have label files for these modules.
Mitchfin is offline  
Old 10-12-2016, 04:40 PM
  #18  
AudiWorld Member
 
gguy's Avatar
 
Join Date: Sep 2016
Location: Oregon
Posts: 525
Default

Originally Posted by Mitchfin View Post
Of course, I become a dog with a bone when I can't figure something out, and there is NOWHERE on the internet that outlines the whole procedure for these new models (it took a lot of google translate). Also big thanks to AudiA4B6US for helping me figure out the missing link (SPE and STA, still don't know what they stand for).

I kind of feel like I'm gaming the system too, I like that
That's funny. I agree and I wish I knew more about this so that I could play with it too, it sounds like a lot of fun. I will follow along and learn as much as I can.
gguy is offline  
Old 10-12-2016, 04:46 PM
  #19  
AudiWorld Member
 
Wuplur's Avatar
 
Join Date: Oct 2016
Location: SoCal
Posts: 224
Default

Originally Posted by Mitchfin View Post
Glad it worked! this will work on 2017 A4 without VC.
Tried it on her car real quick with no luck. Will give it another go when she gets home later tonight. Cluster would say lane assist malfunction and the lines wouldn't show also the mmi option was just grayed out.
Wuplur is offline  
Old 10-12-2016, 04:51 PM
  #20  
AudiWorld Senior Member
Thread Starter
 
Mitchfin's Avatar
 
Join Date: Apr 2016
Location: Utah
Posts: 955
Default

Originally Posted by Manny Lopez View Post
Tried it on her car real quick with no luck. Will give it another go when she gets home later tonight. Cluster would say lane assist malfunction and the lines wouldn't show also the mmi option was just grayed out.
There might be different coding for her instrument panel, send me an auto scan and a photo of her camera!
Mitchfin is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: