secondary air injection - AudiWorld Forums

Notices
A6 / S6 (C5 Platform) Discussion Discussion forum for the C5 Audi A6 and S6 produced from 1998-2004
Sponsored by:
Sponsored by:

secondary air injection

Reply

 
 
Old 04-09-2014, 02:22 AM
  #1
Audiworld Junior Member
Thread Starter
 
Join Date: Apr 2014
Location: south west England
Posts: 22
Default secondary air injection

Hi all, have 2002 a6 3.0 v6 a/t quattro which has random misfire codes for 2 months. Changed 6x plugs, 3 coil packs and replaced both flex on downpipes. Now have sai low flow to bank 1 idle is fine, misfires always around 2krpm causing cel to flash. Can anyone aged any light on this, I'm not too scared of getting my hands dirty.
clueless racer is offline  
Reply With Quote
Old 04-09-2014, 03:11 AM
  #2
AudiWorld Senior Member
 
Join Date: Feb 2009
Posts: 1,124
Default

Do you have any other codes? What are you using to scan? A generic OBD scanner? Or a Vag-Com?
jseklund is offline  
Reply With Quote
Old 04-09-2014, 06:36 AM
  #3
AudiWorld Super User
 
SloopJohnB@mac.com's Avatar
 
Join Date: Oct 2002
Location: Olney, MD
Posts: 7,206
Default

It wouldn't be unusual to have a failed SAI pump..they can be rebuilt (by you..check youtube or the resource menu button) or replaced. Vag-com would show you if the thing is working or perhaps you can listen for it to start up (I don't know..a long screwdriver touching it with one end to your ear while someone else starts the car from cold?).
SloopJohnB@mac.com is offline  
Reply With Quote
Old 04-09-2014, 01:02 PM
  #4
AudiWorld Member
 
Join Date: Oct 2012
Posts: 140
Default

Originally Posted by [email protected] View Post
It wouldn't be unusual to have a failed SAI pump..they can be rebuilt (by you..check youtube or the resource menu button) or replaced. Vag-com would show you if the thing is working or perhaps you can listen for it to start up (I don't know..a long screwdriver touching it with one end to your ear while someone else starts the car from cold?).
Are you suggesting that a bad SAI pump can cause a misfire or rough idle?
thall6594 is offline  
Reply With Quote
Old 04-10-2014, 04:36 PM
  #5
Audiworld Junior Member
Thread Starter
 
Join Date: Apr 2014
Location: south west England
Posts: 22
Default

Using obd, kinda hoping the vac lines are partially blocked as the car was sat around for a few months before I bought it.
clueless racer is offline  
Reply With Quote
Old 04-11-2014, 04:20 AM
  #6
AudiWorld Super User
 
SloopJohnB@mac.com's Avatar
 
Join Date: Oct 2002
Location: Olney, MD
Posts: 7,206
Default

Originally Posted by clueless racer View Post
Using obd, kinda hoping the vac lines are partially blocked as the car was sat around for a few months before I bought it.
hope springs eternal…if the lines weren't blocked before, a few months sitting around wouldn't likely block them unless spiders got into them, very unlikely.
SloopJohnB@mac.com is offline  
Reply With Quote
Old 04-11-2014, 12:12 PM
  #7
Audiworld Junior Member
Thread Starter
 
Join Date: Apr 2014
Location: south west England
Posts: 22
Default

Originally Posted by [email protected] View Post
hope springs eternal…if the lines weren't blocked before, a few months sitting around wouldn't likely block them unless spiders got into them, very unlikely.
Changed the panel filter when I got the car, and there was leaves and crap in the airbox and maf due to a clip not being fastened. Wonder if it's found its way into sai? Will find out tomorrow :$
clueless racer is offline  
Reply With Quote
Old 04-12-2014, 08:45 AM
  #8
Audiworld Junior Member
Thread Starter
 
Join Date: Apr 2014
Location: south west England
Posts: 22
Default

Well it turned out it was the PCV, stripped it down, cleaned and reinstalled. Took car out for a test and it no longer sounds like a Scooby, cel has gone out. Fingers crossed it'll last till the replacement arrives O I guess the previous owner overfilled with oil at some point.
clueless racer is offline  
Reply With Quote
Old 04-12-2014, 11:06 AM
  #9
AudiWorld Super User
 
SloopJohnB@mac.com's Avatar
 
Join Date: Oct 2002
Location: Olney, MD
Posts: 7,206
Default

PCV…vas is dis? The 3" round thing that honks like a goose when it shouldn't?

I've not had much luck with those…I've replaced them to stop the honking.
SloopJohnB@mac.com is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
lmariorod
Audi A5 / S5 / RS5 Coupe & Cabrio (B8)
6
08-07-2017 07:04 PM
Kerry G
Audi A5 / S5 / RS5 Coupe & Cabrio (B8)
3
06-07-2016 02:55 AM
bballfreak
A6 / S6 (C6 Platform) Discussion
4
10-12-2015 05:14 PM
random512
A6 (C7 Platform) Discussion
9
10-05-2015 07:00 AM
Markuzas
A6 / S6 (C5 Platform) Discussion
5
09-28-2015 06:38 AM

Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 11:40 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: