A6 / S6 (C6 Platform) Discussion Discussion forum for the C6 Audi A6 produced from 2004-present and Audi S6 produced from 2007-present

Help! Transmission!

 
Old 11-08-2018, 01:01 PM
  #1  
Audiworld Junior Member
Thread Starter
 
Join Date: Nov 2017
Posts: 15
Default Help! Transmission!

Hi everyone,

i have a A6 C6 4.2 2005 Quattro with some problems that i'm solving, but my biggest problem is the transmission. I've done the entire transmission rebuilt, everything that's possible i did. After i did the transmission, the gears didn't match with the right position.

So, now, after i did the transmission, appears as limp mode and still the gears doesn't match with the right position in the shifter. The position i supose it's the linkage or the shifter it's problematic, but the limp mode i really don't know.

I've heard that after change transmission oil, or make the transmission, whatever job done with the transmission, is needed to flash the tcm at the dealership.

My TCM, i guess, needs also to be updated.

So, the question is, it's necessary take the car to the dealership and flash the TCM, make the adaptation and if the case, update the software?

Thanks in advance!!
RodriguesV is offline  
Old 11-09-2018, 01:43 AM
  #2  
AudiWorld Super User
 
KevinGary's Avatar
 
Join Date: Mar 2005
Location: Long Island, New York
Posts: 6,082
Default

Are there any codes being thrown?
KevinGary is offline  
Old 11-09-2018, 03:25 AM
  #3  
mkv
Audiworld Junior Member
 
Join Date: Feb 2017
Location: Cape Town
Posts: 43
Default

Hello,

You don't need to "flash" the TCM after you do any job on the transmission, not sure who told you that. If it's the same TCM which has always been in the car then it should work just fine. Depending on the job you perform on the transmission, you may need to reset the adapted values of the clutches, but not resetting these will not cause the transmission to not work, and certainly not what you're describing above.

As Kevin asks, what codes are being thrown?

When you say that the gears don't line up on the shifter, are you saying that you get Drive at a different position to D? Or something like that?
When you reinstalled the mechatronic unit into the transmission, were you sure to line up the shift linkage with the correct pin on the plunger and sensor on the mechatronic unit/TCM?
See page 6 of this PDF: http://www.thectsc.com/images/pdf/th...eplacement.pdf
Although I think the transmission in your 4.2 is not a 6HP19, it's one of the bigger versions and should be very similar to the 19.
mkv is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
azn123
TT (Mk1) Discussion
4
10-17-2018 07:00 AM
Anton86
A4 (B5 Platform) Discussion
3
04-05-2008 09:56 AM
aurum
A6 / S6 (C5 Platform) Discussion
6
10-28-2006 02:51 PM
mdillian3690
S4 / RS4 (B5 Platform) Discussion
6
01-27-2003 11:18 AM
Audi4Ever
A4 (B5 Platform) Discussion
39
07-06-2000 08:06 PM


Thread Tools
Search this Thread
Quick Reply: Help! Transmission!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: