A8 / S8 (D2 Platform) Discussion Discussion forum for the D2 Audi A8 and S8 produced from 1994-2002

Transmission and MAF interaction

 
Old 06-11-2018, 03:15 PM
  #1  
Audiworld Junior Member
Thread Starter
 
radjaco's Avatar
 
Join Date: Aug 2017
Posts: 41
Default Transmission and MAF interaction

Hi, have 1997 Audi A8 (D2) 3.7 FWD w/automatic transmission and recently mechanics did the transmission rebuild work on it. Actually, it ran fine except for one serious problem: on downshift from 5 to 4 it has a very strong impact. We have also a VW 2000 V6 Passat and when MAF on it went bad I drove a couple of days with the MAF unplugged. It drove fine except the strong transmission impact on upshift from 4 to 5. Once I replaced the MAF everything went fine and it shifted smoothly as it should.
I did diagnostics several times and it did not throw any errors related to this problem except for some transmission errors which were cleaned in ECU.
So, my question is: can it be the same problem with my Audi as it was with VW? Can MAF be faulty and cause the rough downshift from 5 to 4?
I would appreciate any ideas on the problem.
Thanks
radjaco is offline  
Old 06-12-2018, 09:12 AM
  #2  
AudiWorld Senior Member
 
Join Date: Mar 2002
Location: Michigan
Posts: 1,814
Default

You had transmission rebuilt or had rebuild work done on it (not sure if that means it was rebuilt completely or what). None-the-less you paid someone to work on the transmission and now there is a problem so you go looking for another problem instead of going back to they guy who did the work and complaining. If someone installed a new heater in you house and it didn't heat right, would you go looking to see if there is a problem with your TV?
audijim113 is offline  
Old 06-12-2018, 09:53 AM
  #3  
Audiworld Junior Member
Thread Starter
 
radjaco's Avatar
 
Join Date: Aug 2017
Posts: 41
Default

Thanks for the reply. However, the work on the transmission was done Ok. I have driven the car after it was done and was perfect except for leaking some oil. After taking down transmission for the second time something apparently went wrong (I doubt about some wiring as I noticed that close to transmission all the wirings were so stiff that begin to break). So, now I have the harness from 4.2 quattro to replace some wires. However, harness that comes from the ECU is different in upper part but seems same in the lower part, especially cables connecting to the transmission. I am in the country where nobody is responsible for anything - this is developing former CIS country.
I have the question: what do you think - do the colors from 4.2 A8 harness connecting to the transmission match those of A8 3.7 of the same year? I noticed that connectors are 2 and look the same.
Thanks
radjaco is offline  
Old 12-06-2018, 10:05 PM
  #4  
AudiWorld Member
 
Join Date: Dec 2018
Posts: 51
Default

I usually go look at pics on ebay in that case because yes alot of cross over parts good luck brother!
a8gd is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Higher750
Off-topic Discussion
22
02-14-2007 08:19 PM


Thread Tools
Search this Thread
Quick Reply: Transmission and MAF interaction


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: