Turn signals work, but hazard lights (left side) don't work. - AudiWorld Forums

Go Back  AudiWorld Forums > Audi Models > Audi A8 / S8 > A8 / S8 (D2 Platform) Discussion
Reload this Page >

Turn signals work, but hazard lights (left side) don't work.

A8 / S8 (D2 Platform) Discussion Discussion forum for the D2 Audi A8 and S8 produced from 1994-2002

Turn signals work, but hazard lights (left side) don't work.

 
Old 11-27-2018, 06:13 AM
  #1  
Audiworld Junior Member
Thread Starter
 
shinigami's Avatar
 
Join Date: May 2010
Posts: 27
Default Turn signals work, but hazard lights (left side) don't work.

My turn signals (front and back) work, so I know it's not a bulb problem.

But when I do the hazard lights, only the right side blinks. It looks like I'm trying to turn right.

I think there is a wiring problem and need to replace something.
What do I need to buy? I am going to buy it on ebay or amazon so I can have it shipped to South Korea, where I live.
Thanks.
shinigami is offline  
Old 11-27-2018, 05:44 PM
  #2  
AudiWorld Newcomer
 
Join Date: Nov 2018
Posts: 3
Default

Originally Posted by shinigami View Post
My turn signals (front and back) work, so I know it's not a bulb problem.

But when I do the hazard lights, only the right side blinks. It looks like I'm trying to turn right.

I think there is a wiring problem and need to replace something.
What do I need to buy? I am going to buy it on ebay or amazon so I can have it shipped to South Korea, where I live.
Thanks.
Have you tested the emergency flasher relay?
Groosh is offline  
Old 01-09-2019, 08:37 PM
  #3  
Audiworld Junior Member
Thread Starter
 
shinigami's Avatar
 
Join Date: May 2010
Posts: 27
Default

Originally Posted by Groosh View Post
Have you tested the emergency flasher relay?
how do i do this?
shinigami is offline  
Old 01-17-2019, 10:45 PM
  #4  
AudiWorld Member
 
Join Date: Dec 2018
Posts: 51
Default

take out the bulb check for bulb gunk or blackening on contacts then clean with brake cleaner and toothbrush if so, good luck
a8gd is offline  
Old 01-21-2019, 03:46 PM
  #5  
AudiWorld Senior Member
 
Join Date: Jan 2004
Posts: 607
Default

Also check any double filament bulbs for a single broken filament creating a sneak circuit. If one filament breaks at one end, and lays across the other filament, when the good filament is energized, it back feeds power through the half broken filament in contact with it.
BrianC72gt is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
snakelegs
A4 Cabriolet (B6 Platform) Discussion
9
10-23-2018 08:07 AM
nyuschool22
A4 (B5 Platform) Discussion
0
10-22-2009 05:23 PM
COMPUTEK::WMS
S4 / RS4 (B5 Platform) Discussion
4
08-26-2009 01:06 PM
quattro.pilot
Audi Original "S" Cars
16
10-25-2008 07:01 PM
curaco
Audi 90 / 80 / Coupe quattro / Cabriolet
4
11-22-2005 02:55 PM


Thread Tools
Search this Thread
Quick Reply: Turn signals work, but hazard lights (left side) don't work.


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: