A8 / S8 (D3 Platform) Discussion Discussion forum for the D3 Audi A8 produced from 2003-2010 and Audi S8 produced from 2006-2010

Audi A8 MMI

 
Old 07-13-2019, 09:24 AM
  #1  
AudiWorld Newcomer
Thread Starter
 
Join Date: Jul 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Audi A8 MMI

I have a 2007 Audi A8, my MMI screen is blank and nothing is responding (functions that the screen allows me to use) back up camera is not coming showing on the screen. I cant even retract the screen back inside the port. When I touch the button to retract it, the screen shows "Audi multi media interface" after that goes dark. I'm not sure what all this is about. Have any ideas?
Marcos Pazos is offline  
Old 07-13-2019, 09:48 AM
  #2  
AudiWorld Super User
 
ltooz_a6_a8_q7's Avatar
 
Join Date: Sep 2003
Location: Fremont, CA
Posts: 4,320
Likes: 0
Received 4 Likes on 4 Posts
Default

Check all the fuses in the trunk, left side, 5A and other fuses on the right side in front, check if the power on CD changer is on and navigation
Get an optical loop and start bypassing devices.
read this may help
Cheers,
Louis
ltooz_a6_a8_q7 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Southendryder
Audio, Video and Security Discussion
2
04-26-2018 09:59 AM
ripvandyke
A6 / S6 (C6 Platform) Discussion
25
03-24-2010 07:20 AM
Teknic
Off-topic Discussion
0
02-23-2009 02:06 PM
snagitseven
A4 (B8 Platform) Discussion
4
12-25-2008 02:28 PM


Thread Tools
Search this Thread
Quick Reply: Audi A8 MMI


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: