Dealer unable to remove CP...? - AudiWorld Forums

Notices
A8 / S8 (D3 Platform) Discussion Discussion forum for the D3 Audi A8 produced from 2003-2010 and Audi S8 produced from 2006-2010

Dealer unable to remove CP...?

Reply

 
 
Old 08-07-2017, 01:49 PM
  #1
AudiWorld Member
Thread Starter
 
91quattro's Avatar
 
Join Date: Apr 2009
Location: Las Vegas, NV
Posts: 188
Default Dealer unable to remove CP...?

Replaced the CH in my 2005 A8, the "new" unit came out of a 2009 Q7 I got through ebay. Got it installed and it is recognized in the car, everything works except sound - which is normal for a CP device. And of course I can't recode it. Took it to the dealer to get CP removed, and they are telling me they could not remove the CP. How can this be? The unit is either defective or reported stolen? I'm not that familiar with CP but understood that the dealer is the only place where CP can be removed.

Any help is appreciated!
91quattro is offline  
Reply With Quote
Old 08-07-2017, 02:11 PM
  #2
AudiWorld Member
Thread Starter
 
91quattro's Avatar
 
Join Date: Apr 2009
Location: Las Vegas, NV
Posts: 188
Default Also replaced CAN gateway module

FWIW, I also replaced the CAN gateway at the same time (old number 4E0 907 468C, new one is 4L0 907 468B, per advice from this forum - I'm trying to retrofit a RVC)...I wonder if replacing both at the same time might have caused some kind of conflict. Is there a recommended order to use when replacing both gateway units?

Also - the car has MMI 4610, and the new CH already had 4610 on it.
91quattro is offline  
Reply With Quote
Old 08-08-2017, 08:52 AM
  #3
AudiWorld Member
Thread Starter
 
91quattro's Avatar
 
Join Date: Apr 2009
Location: Las Vegas, NV
Posts: 188
Default

In further checking...I don't think anything is wrong with either module. I was able to recode, and the car is VAR COM error-free, except for CP on the CH. Apparently the Las Vegas Audi dealers do not "participate" in removing CP on any cars. I had not run into this before and always assumed they would do it, if I was willing to pay for it. So now it looks like I will need to travel hundreds of miles to the next nearest dealer (if THEY are willing to do it).

Anyone run into this before?
91quattro is offline  
Reply With Quote
Old 08-08-2017, 09:16 AM
  #4
AudiWorld Member
 
Join Date: Mar 2017
Location: Kent, UK
Posts: 138
Default

Can't help too much other than to say that although Audi dealers were originally the only ones to perform CP 'unlock', authorised third parties are now able to do this if they have the appropriate online connection to Germany. Perhaps you can find someone else more local?

Julian
JulianHicks is online now  
Reply With Quote
Old 08-08-2017, 02:38 PM
  #5
AudiWorld Member
Thread Starter
 
91quattro's Avatar
 
Join Date: Apr 2009
Location: Las Vegas, NV
Posts: 188
Default

Didn't know this could be officially done outside the Audi dealer network. I did some checking, and it turns out there is a place in town that can do it, and is authorized by Audi. Planning to pay them a visit this week. Thanks for the tip Julian!
91quattro is offline  
Reply With Quote
Old 08-08-2017, 02:41 PM
  #6
AudiWorld Member
 
ScottCNelson's Avatar
 
Join Date: Oct 2004
Posts: 168
Default AUDI Wants You to Buy a Lexus

Originally Posted by 91quattro View Post
In further checking...I don't think anything is wrong with either module. I was able to recode, and the car is VAR COM error-free, except for CP on the CH. Apparently the Las Vegas Audi dealers do not "participate" in removing CP on any cars. I had not run into this before and always assumed they would do it, if I was willing to pay for it. So now it looks like I will need to travel hundreds of miles to the next nearest dealer (if THEY are willing to do it).

Anyone run into this before?
I have has similar heartburn with AUDI smartkeys, which you can only get a dealer to program. These sort of crappy customer service policies REALLY make me question the AUDI brand.

Handy with a soldering iron?


or

ABRITES LTD - ABRITES Diagnostics for VW, Audi, Seat, Skoda

Attached Images
  
ScottCNelson is offline  
Reply With Quote
Old 08-08-2017, 09:28 PM
  #7
AudiWorld Super User
 
ltooz_a6_a8_q7's Avatar
 
Join Date: Sep 2003
Location: Fremont, CA
Posts: 3,097
Default

2005 and 2009 have many different devices. As I understand, you don't have the graphical back up sensor. I would check the list to make sure what your car doesn't have is unchecked. Or better to install the missing ones.
Get the graphical and the camera controller, you may fix it.
Cheers,
Louis

Last edited by ltooz_a6_a8_q7; 08-08-2017 at 09:33 PM.
ltooz_a6_a8_q7 is offline  
Reply With Quote
Old 08-09-2017, 05:39 AM
  #8
AudiWorld Member
Thread Starter
 
91quattro's Avatar
 
Join Date: Apr 2009
Location: Las Vegas, NV
Posts: 188
Default

Actually I do have the graphical backup - I did that upgrade a year or two ago. I also have the camera module ready to go but wanted to get these two gateways installed and stable before adding the RVC module. I think I have all of the settings restored on both, but I will go through the CAN gateway install list one more time to be sure. At this point, the only fault code I have is for CP on the CH.
91quattro is offline  
Reply With Quote
Old 08-09-2017, 07:08 AM
  #9
AudiWorld Senior Member
 
Giovanni Giovino 6.0+6.0TT's Avatar
 
Join Date: Jun 2016
Location: Montgomery............ New Jersey
Posts: 609
Default

Hello 91,
Did the dealer actually state "The unit is either defective or reported stolen", if so, which one, or did they not even bother to try, or is that your thinking and they gave you no reason, there is no reason an authorized Audi dealer could not remove the CP on the MMI CH, unless it came back stolen, you know it is not defective as it is in working order with no fault codes, with the exception of the CP, so please tell us their reasoning.

Also as Scott has posted, I have done the same with one MMI CH, and with the 93C86 chip on a two KESSY modules swaps with success, so if you are handy with a hot air soldering tool, you can swap the chip from your old MMI CH, just be sure to note the orientation of the DOT depicting terminal #1 .

Or as noted in the video that Scott uploaded, you can use a carprog $60-$80 to read the bin file on the chip of your old MMI CH and write that bin file to the replacement MMI CH, BUT, sometimes the chip must be removed from the board for reading and writing, I have had some that read on the board, and some that would not, so I removed to read and write.





Originally Posted by 91quattro View Post
Actually I do have the graphical backup - I did that upgrade a year or two ago. I also have the camera module ready to go but wanted to get these two gateways installed and stable before adding the RVC module. I think I have all of the settings restored on both, but I will go through the CAN gateway install list one more time to be sure. At this point, the only fault code I have is for CP on the CH.
Attached Thumbnails
Dealer unable to remove CP...?-20170809_111715.jpg   Dealer unable to remove CP...?-20170809_111707.jpg   Dealer unable to remove CP...?-20170809_111631.jpg  

Last edited by Giovanni Giovino 6.0+6.0TT; 08-09-2017 at 07:26 AM. Reason: ADD PICTURES
Giovanni Giovino 6.0+6.0TT is offline  
Reply With Quote
Old 08-09-2017, 09:18 AM
  #10
AudiWorld Member
Thread Starter
 
91quattro's Avatar
 
Join Date: Apr 2009
Location: Las Vegas, NV
Posts: 188
Default

Hey Giovanni, thanks for the info. I talked to the mechanic who "tried" and he just said he followed the steps in their diagnostic system, and it would not unlock. And he really didn't know what else to do. I asked him if he thought it was defective, and he said no. And he said a couple of other things about coding and CP that made me think he was either following the directive from his boss to avoid any CP removal work, and they were just "trying" because I am a current/former customer, or else he really might not have known what he was doing. Either way I wasn't going to get anywhere at that dealer. I then called the only other Audi dealer here in LV, and they flat out declined to even try, and said that per management, the dealership did not do CP removal, because there were "liability issues."

I have read the other postings about adding the video circuit to an older CH unit, like the one that came with my car, but I'm not really interested in disassembling and soldering, or exchanging chips at this point.... I just want to exchange mine for the "A" module. The ebay seller I got the "A" module from says it was tested before he shipped it. At this point it is working in all respects, except for the CP fault code and of course no sound. No other VCDS errors. I have the name of an independent shop that others have said can remove CP, and they claim they can do it, so I'm planning to go there on Friday.
91quattro is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 11:41 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: