Audi 4KQ runs super rich - AudiWorld Forums

Notices

Audi 4KQ runs super rich

Old 12-08-2018, 05:15 PM
  #1  
Audiworld Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 12
Default Audi 4KQ runs super rich

I have an 87 4kq that is flooding itself. I replaced the injectors thinking that maybe they were maybe spraying a stream rather than misting. This only seemed to make the problem worse. To get the car to start I have to pull the fuel pump relay while cranking the key and than quickly put it back in when the car starts before it dies. It than runs terribly and runs super rich. I replaced the engine coolant temp sensor and checked the cold start injector. Is it my CIS system somewhere?
Alaskan4kq is offline  
Old 12-16-2018, 04:29 PM
  #2  
Audiworld Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 12
Default

I seemed to mostly have fixed it with the co screw. Now I just have a weird idle that wants to die and than the car revs up to about 1200. Maybe the idle is just too low?
Alaskan4kq is offline  
Old 12-19-2018, 11:53 AM
  #3  
AudiWorld Member
 
Erik Myers's Avatar
 
Join Date: Jun 2018
Location: Sylva, North Carolina
Posts: 67
Default

Sounds similar to what mine was doing. Are the "Throttle Closed" and "Throttle Open" switches both working? My closed one wasn't, I had to pull the manifold to get to it and replace it. After that I replaced the temp sensor and it fixed everything.
Cheers
Erik Myers is offline  
Old 12-21-2018, 04:28 PM
  #4  
Audiworld Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 12
Default

Hmm I'll have to look into the throttle closed switch. I didn't know it existed. The open seems to work though. I'm happy the car at least starts and idles now. I sometimes have to cycle the key a few times to get enough fuel into it to start it cold. Perhaps the new fuel pump is junk huh? I saw you posted the part number for the good pump
Alaskan4kq is offline  
Old 12-24-2018, 08:48 PM
  #5  
AudiWorld Member
 
Erik Myers's Avatar
 
Join Date: Jun 2018
Location: Sylva, North Carolina
Posts: 67
Default

Did you get a new one? My Bosche one seems to be doing just fine, but I replaced the filter too. Although, strangely enough, it does seem to occasionally make "sloshing" noises as if it sucks air. I think that's my own fault though, I haven't been able to take the car to the gas station so I keep it almost empty all the time. Good luck, let us know what you find. Cheers
Erik Myers is offline  
Old 12-25-2018, 11:21 AM
  #6  
Audiworld Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 12
Default

I haven't gotten a new one but I'm almost now thinking it's my cold start injector that isn't running. To get the car to start in the cold I cycle the key a few times but also have to turn the mixture screw half a turn to richen it up. Than once it fires I turn it back. So now I need to pull the cold start injector. I almost don't know of I care enough to yet though. I have a line on a 10vt from a 5000. It's actually a entire 5000 donor car I'd yank the motor from. Hopefully that seap is decently straight forward. I'm happy this thing is drive able at this point now though
Alaskan4kq is offline  
Old 12-26-2018, 01:47 PM
  #7  
AudiWorld Member
 
Erik Myers's Avatar
 
Join Date: Jun 2018
Location: Sylva, North Carolina
Posts: 67
Default

well good luck on that, there are plenty of resources around on swapping a 10vt in, I think Rogviler may have done it at some point, or posted on one that has. Cheers
Erik Myers is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Panagiotis Kyriakis
A8 / S8 (D3 Platform) Discussion
56
12-02-2018 09:09 AM
Ricky92
Audi A3 / S3 / RS 3 MKII
3
11-14-2018 04:05 PM
borisivan
Audi A5 / S5 / RS5 Coupe & Cabrio (B9)
3
11-09-2018 11:01 AM
autoteile
A6 (C7 Platform) Discussion
0
11-08-2018 03:00 AM
SalsaSullivan
A4 (B8 Platform) Discussion
0
11-05-2018 11:03 PM


Thread Tools
Search this Thread
Quick Reply: Audi 4KQ runs super rich


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: