A5 S-line 3.2L ENGINE LIGHT

 
Old 12-24-2018, 10:08 PM
  #1  
Audiworld Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Default A5 S-line 3.2L ENGINE LIGHT

Hi,

I have recently purchased my 2009 A5 S-line. The engine light just came on, however the car seems to be running perfectly without any seeming issues. Any ideas what it could be?

Also are there any cables you can buy to be able to hook it up and find out from the fault codes?

Cheers.
amirmehrabi is offline  
Old 01-03-2019, 06:50 PM
  #2  
Audiworld Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Default

Just a follow up. It appears the issue causing the engine light was the fact that I have been putting 95 premium unleaded fuel (What its called here in Australia), whereas I needed to put 98 ultimate unleaded fuel.

Strange, because I could have sworn in the manual it said minimum 95.
amirmehrabi is offline  
Old 01-12-2019, 08:30 PM
  #3  
Audiworld Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Default

another update.

Nope 95 petrol is just fine. hooked it up to the diagnostic, shows a throttle error. P0068. manifold absolute pressure sensor(MAP)/mass airflow sensor(MAF)/throttle position correlation.

probably the sensor needs changing but who knows. might have to take it to the mechanic.
amirmehrabi is offline  
Old 01-15-2019, 07:15 PM
  #4  
Audiworld Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Default another update

Took the car to mechanic who connected it to the diagnostics and the following codes came up.

P2070 Intake manifold tuning valve bank 1 stuck open
P307A Intake system airflow too low
P0068 Map/Maf throttle position correlation

I did a bit of research and it appears it might be caused due to carbon build up in the hose connected to the air filter or else leaks.

No one seems to comment, anyone have any ideas?
amirmehrabi is offline  
Old 01-16-2019, 07:03 PM
  #5  
AudiWorld Newcomer
 
Join Date: Jan 2019
Posts: 3
Default

Originally Posted by amirmehrabi View Post
Took the car to mechanic who connected it to the diagnostics and the following codes came up.

P2070 Intake manifold tuning valve bank 1 stuck open
P307A Intake system airflow too low
P0068 Map/Maf throttle position correlation

I did a bit of research and it appears it might be caused due to carbon build up in the hose connected to the air filter or else leaks.

No one seems to comment, anyone have any ideas?
I wish I could help bud. I recently had a similar issue. Purchased an 2010 S5 on Thursday, engine light/EPC light/coolant level light on Saturday and Sunday. I took it back to the dealership and they "stated" the they replaced water pump and a plastic pipe underneath the manifold. I did notice when I took it back to them my coolant was being used drastically. I filled the resivor up before I left for the dealership, and when I arrived it was below the fill line. I did communicate that to them when I dropped it off. However, I have not checked the level since returning but will check tommorrow as I'm smelling antifreeze again. They could have just messed with the sensors, they could have fixed my problems, or I could be mistaken on the antifreeze I'm starting to smell.

Lastly, no one really responds here. I posted the same question (with some small wording changes), in two different areas an no one has responded to my post.
Roc Norris is offline  
Old 01-18-2019, 09:44 PM
  #6  
Audiworld Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Default

Yeh I wonder if there are any better audi forums with more active members.

in any case its hard to know what exactly is causing your issues. One thing you can do is use this (or something similar) 15 dollar bluetooth OBDII scanner and google the fault codes its giving you: https://www.ebay.com.au/itm/173707405608
amirmehrabi is offline  
Old 01-19-2019, 04:44 AM
  #7  
AudiWorld Super User
 
Nikon1's Avatar
 
Join Date: Mar 2018
Location: South Jersey
Posts: 2,028
Default

Just a couple of suggestions that might get you some help:

1) If you look at the top of this sub-forum for your car models you’ll see two additional sub-forums. They are for the same Audi Models but broken down by generation — B8 for the older models & B9 for the latest model years. You may get help if you post your questions / concerns in the correct sub-forums.

2) You are requesting help with specific faults / problems that AudiWorld members may not have seen.

I’m just trying to be as helpful as I can be — but since your cars are before my Audi ownership started, I can’t provide any other information that may be helpful.

— John
Nikon1 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Paresh Chauhan
A6 / S6 (C6 Platform) Discussion
0
01-19-2017 07:38 AM
tommywerdz
2.0T FSI Discussion
0
04-09-2016 06:30 AM
dsbacon
A8 / S8 (D3 Platform) Discussion
5
04-15-2015 07:58 AM
sealf76
Q7 Discussion
1
04-10-2013 04:30 PM
dojin96
A4 (B6 Platform) Discussion
3
05-26-2003 08:03 AM


Thread Tools
Search this Thread
Quick Reply: A5 S-line 3.2L ENGINE LIGHT


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: