Audi A5 / S5 / RS5 Coupe & Cabrio (B8) Discussion forum for the B8 Audi A5, S5 and RS5 Coupe and Cabriolet Model years 2009 - 2017

anyone get the coolant pump recall fixed yet?

 
Old 01-09-2019, 05:56 PM
  #1  
Audiworld Junior Member
Thread Starter
 
a5.cw's Avatar
 
Join Date: Aug 2018
Location: Maryland, USA
Posts: 14
Default anyone get the coolant pump recall fixed yet?

Just wondering if there were any unexpected problems, before I get mine done.
a5.cw is offline  
Old 01-11-2019, 09:07 AM
  #2  
AudiWorld Member
 
Join Date: Aug 2012
Posts: 112
Default

Just got it done 2 days ago. No differences / problems so far.

Nice to know that I don't have to park outside to prevent my house from burning down with the car anymore.
findalex is offline  
Old 01-11-2019, 03:01 PM
  #3  
Audiworld Junior Member
 
Join Date: Nov 2018
Location: Tampa, FL
Posts: 5
Default

Had the recall work done Wed 1/9 on daughter's (former) 2014 A5 coupe. No issues though must say we've only had it since late October 2018. I kept it in the garage since we drove it down from D.C to Tampa Bay. Unless me/wife are out and about, our vehicles stay in the garage.
johnel is offline  
Old 01-31-2019, 10:13 AM
  #4  
AudiWorld Newcomer
 
Stephen Walton's Avatar
 
Join Date: Jan 2018
Location: TEXAS USA
Posts: 4
Default

When you say you've had the recall done, do you mean the install of the replacement pump? I had the disconnect (19N4) done 3 months ago and I'm tired of waiting for the replacement. Both local dealers and Audi Customer Experience tell me no pumps yet.
Stephen Walton is offline  
Old 01-31-2019, 10:50 AM
  #5  
Audiworld Junior Member
 
Join Date: Nov 2018
Location: Tampa, FL
Posts: 5
Default

Steven, when I called the dealer (Tampa Audi) I got confirmation that they did have the part in before I made the appointment. So based on that, I assume they installed the new after run coolant pump. Wait time was a couple of hours.
johnel is offline  
Old 01-31-2019, 11:52 AM
  #6  
AudiWorld Newcomer
 
Stephen Walton's Avatar
 
Join Date: Jan 2018
Location: TEXAS USA
Posts: 4
Default

Johnel,
I have no idea how they are doing this because Audi. Assuming that hot weather climates are getting it first (just a guess---I don't know this,) then it makes sense for you (FL) and me (TX) to be towards the beginning. But my 2 local dealers and ACE show no pumps. I just checked the Audi recall page (again) and it shows no open recalls for my car. I'm getting pissed off at how this is being handled. It's obviously a big enough problem that they extended our turbo warranty, but yet I'm allowed to drive around for 3+ months with the coolant pump disconnected and not be concerned. I guess that the potential liability claims of Audi owners' homes burning down was important enough to warrant the quick disconnect recall, but getting new pumps in the cars is secondary. I have owned/own the other German makes, but this is my first Audi and the way this is being handled isn't creating much loyalty to Audi on my part.
Stephen Walton is offline  
Old 02-01-2019, 08:46 AM
  #7  
AudiWorld Member
 
Join Date: Aug 2012
Posts: 112
Default

I think all you need to do is let the engine run at light load or idle a min or two before you shut off the engine and you should be fine. It's basically like the old school turbo timers. You just need to give the engine some time to cool down after running it hard.

Since most people aren't racing their cars and then immediately shutting off the engine, I believe the risk of overheating and catchig fire is fairly minor. But of course, the lawyers have to put in the disclaimer to park the car outside to CYA. There's is always that one idiot with no common sense.
findalex is offline  
Old 02-11-2019, 09:35 AM
  #8  
AudiWorld Member
 
Join Date: Mar 2011
Posts: 222
Default

Originally Posted by Stephen Walton View Post
Johnel,
I have no idea how they are doing this because Audi. Assuming that hot weather climates are getting it first (just a guess---I don't know this,) then it makes sense for you (FL) and me (TX) to be towards the beginning. But my 2 local dealers and ACE show no pumps. I just checked the Audi recall page (again) and it shows no open recalls for my car. I'm getting pissed off at how this is being handled. It's obviously a big enough problem that they extended our turbo warranty, but yet I'm allowed to drive around for 3+ months with the coolant pump disconnected and not be concerned. I guess that the potential liability claims of Audi owners' homes burning down was important enough to warrant the quick disconnect recall, but getting new pumps in the cars is secondary. I have owned/own the other German makes, but this is my first Audi and the way this is being handled isn't creating much loyalty to Audi on my part.
Keep in mind that this is the "after run" coolant pump. So the only time it comes into play is after the engine is shut off. Basically, it keeps the coolant circulating through the turbo for a couple of minutes after engine shut down, but only if the temp is above a certain threshold. You can easily hear if the pump is running or not when you shut down your car. The only time my runs is if it's a really hot day and I shut the car down immediately after running it hard. But in all honestly, I don't really ever do that. I tend to let the engine idle for a minute or so before shutting it off if I've been running the car hard. And in that case, the after run coolant pump doesn't even come on at all.

Beakerz is offline  
Old 03-05-2019, 10:24 AM
  #9  
AudiWorld Member
 
Join Date: Feb 2006
Location: Ohio
Posts: 52
Default Wrong pump

Recall was done about a month ago, now was reading this post and decided to check whether there are open recalls on my 2013 A5 - lo and behold it still lists it as open. So I call my dealership and the guy says they put the wrong pump in mine and he was going to call me. Turns out there are 01, 02 and 03 pumps, so have to go back for replacement.
It does not hurt to check recall status of your car here: Audi Recall Services by Vehicle Identification Number
bebl is offline  
Old 03-11-2019, 02:12 PM
  #10  
AudiWorld Member
 
oskidunker's Avatar
 
Join Date: Mar 2000
Location: San Francisco
Posts: 546
Default

Originally Posted by Stephen Walton View Post
When you say you've had the recall done, do you mean the install of the replacement pump? I had the disconnect (19N4) done 3 months ago and I'm tired of waiting for the replacement. Both local dealers and Audi Customer Experience tell me no pumps yet.
Same situation here in San francisco bay area. Called Audi and was told issue with parts distribuer. Said Spring
oskidunker is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
es4uerzo
S4 / RS4 (B5 Platform) Discussion
8
07-11-2004 08:55 PM
BOSTONBIM
Off-topic Discussion
8
02-22-2003 02:02 PM


Thread Tools
Search this Thread
Quick Reply: anyone get the coolant pump recall fixed yet?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: