Help Reprogramming Allroad Alarm/Door Lock with Ross Tech - AudiWorld Forums

Go Back  AudiWorld Forums > Audi Models > Audi allroad
Reload this Page > Help Reprogramming Allroad Alarm/Door Lock with Ross Tech
Notices
Audi allroad Discussion forum for the original Audi allroad

Help Reprogramming Allroad Alarm/Door Lock with Ross Tech

Reply

 
 
Old 10-24-2013, 06:42 PM
  #1
Audiworld Junior Member
Thread Starter
 
Join Date: May 2013
Posts: 16
Default Help Reprogramming Allroad Alarm/Door Lock with Ross Tech

Hi everyone

I've got an 04 Allroad 4.2l V8. I bought a used VCDS to reprogram my car. I've read on a few websites that the car can be programmed to unlock all the doors when you press the remote (currently it only unlocks driver's door), and to lock when you start driving unlock when you stop the car and pull out the key. Plus you can also program it to roll up the windows when you hold down the lock button on the remote.
I'm trying to do what was explained here
http://www.allroadfaq.com/content/conv_recode.shtml

I've got the details I wanted to program my car with, and following the instructions, I used the VCDS cable to go into Module "35" (Central Locks) and after 3 attempts it comes back with 'controller not responding' or 'no response from controller'. It does read some of the modules, such as Engine, ABS, Transmission, Instrument etc, but many modules inlcuding the central locking module it doesn't.

After doing some reading it appears some people have to unlock their doors to be able to communicate. Some people needed to charge their laptops, and some people had problems because they had an after market radio. I've tried the lock and unlock of the doors many times. I've tried it on 2 different laptops. I do have an aftermarket radio, but when I did a 'test' in VCDS it says the K lines were fine.

Can anyone suggest what I can do? At this stage all I want to do is to reprogram the locking/unlocking of the doors and rolling of the windows. I believe the cable is working as many of the other components are communicating fine. Any help would be appreciated
puunda is offline  
Reply With Quote
Old 10-25-2013, 08:01 AM
  #2
AudiWorld Super User
 
GTA_Driver's Avatar
 
Join Date: Aug 2004
Location: Toronto
Posts: 3,277
Default

I just plugged the cable and it worked, no special configurations.

What VCDS do you have? I have the full hex-USB.

Are you trying with the car ignition on, or running?

Is your radio on? May want to try disconnecting the radio for this job.

Edit: I thought you're supposed to access the convenience module, don't remember accessing central locks. That was also some time ago.

Last edited by GTA_Driver; 10-25-2013 at 08:04 AM.
GTA_Driver is offline  
Reply With Quote
Old 10-25-2013, 08:17 AM
  #3
AudiWorld Super User
 
silverd2's Avatar
 
Join Date: May 2010
Location: East TN
Posts: 2,557
Default

Originally Posted by GTA_Driver View Post
I just plugged the cable and it worked, no special configurations.

What VCDS do you have? I have the full hex-USB.

Are you trying with the car ignition on, or running?

Is your radio on? May want to try disconnecting the radio for this job.

Edit: I thought you're supposed to access the convenience module, don't remember accessing central locks. That was also some time ago.
I recoded my wife's Allroad by going directly to "central locking" and entering the new soft code, "do it" and done. I used what I still have...free download VCDS-Lite and a cheap eBay cable.

Same on my D2..."central Locking" module.
silverd2 is online now  
Reply With Quote
Old 10-25-2013, 08:29 AM
  #4
AudiWorld Senior Member
 
Mike B's Avatar
 
Join Date: Mar 2000
Location: Lombard, Illinois
Posts: 1,769
Default

Originally Posted by silverd2 View Post
I recoded my wife's Allroad by going directly to "central locking" and entering the new soft code, "do it" and done. I used what I still have...free download VCDS-Lite and a cheap eBay cable.

Same on my D2..."central Locking" module.
I think that the cheap eBay cable may be the problem. It seems that a lot of guys have had issues with those.
JMO.
Mike B is offline  
Reply With Quote
Old 11-02-2013, 12:11 AM
  #5
Audiworld Junior Member
Thread Starter
 
Join Date: May 2013
Posts: 16
Default

Originally Posted by GTA_Driver View Post
I just plugged the cable and it worked, no special configurations.

What VCDS do you have? I have the full hex-USB.

Are you trying with the car ignition on, or running?

Is your radio on? May want to try disconnecting the radio for this job.

Edit: I thought you're supposed to access the convenience module, don't remember accessing central locks. That was also some time ago.
I'm using the full hex-usb as well.
I've tried it with both the car running, and just 'on' with the lights on but engine off.
Tried with both radio on and off, and have even d/c the radio ... same thing.
I've tried the convenience module and just about every other module, and no replied from any of them.
I've done a full scan, and only about 5 or 6 of the modules actually respond.
I know Audi can reprogram it, but I'm sure they'll charge an arm and a leg for it
puunda is offline  
Reply With Quote
Old 11-02-2013, 12:12 AM
  #6
Audiworld Junior Member
Thread Starter
 
Join Date: May 2013
Posts: 16
Default

Originally Posted by silverd2 View Post
I recoded my wife's Allroad by going directly to "central locking" and entering the new soft code, "do it" and done. I used what I still have...free download VCDS-Lite and a cheap eBay cable.

Same on my D2..."central Locking" module.
I downloaded VCDS-Lite, but it doesn't work with my cable. It only has options for com ports, and not USB. Which cheap eBay cable do you have?
puunda is offline  
Reply With Quote
Old 11-02-2013, 03:46 AM
  #7
AudiWorld Super User
 
silverd2's Avatar
 
Join Date: May 2010
Location: East TN
Posts: 2,557
Default

Originally Posted by puunda View Post
I downloaded VCDS-Lite, but it doesn't work with my cable. It only has options for com ports, and not USB. Which cheap eBay cable do you have?
I believe it was this one...or one just like it >>>

http://www.ebay.com/itm/New-USB-OBD2-KKL-409-1-OBDII-Diagnostic-VAG-COM-Cable-for-Audio-Seat-Skoda-VW-/321168843386?pt=Motors_Automotive_Tools&hash=item4ac727a27a&vxp=mtr
BUT, the com ports on VCDS-Lite are usb connections. You hook it up to car and any usb port on your computer, with ignition on (not running), then test each of the 4 ports in the VCDS-Lite window...only one will work, then it stays there next time you use it.
silverd2 is online now  
Reply With Quote
Old 11-03-2013, 09:13 AM
  #8
AudiWorld Super User
 
GTA_Driver's Avatar
 
Join Date: Aug 2004
Location: Toronto
Posts: 3,277
Default

Originally Posted by puunda View Post
I'm using the full hex-usb as well.
I've tried it with both the car running, and just 'on' with the lights on but engine off.
Tried with both radio on and off, and have even d/c the radio ... same thing.
I've tried the convenience module and just about every other module, and no replied from any of them.
I've done a full scan, and only about 5 or 6 of the modules actually respond.
I know Audi can reprogram it, but I'm sure they'll charge an arm and a leg for it

Do you have an aftermarket radio? Is your ABS light on?
GTA_Driver is offline  
Reply With Quote
Old 11-03-2013, 09:16 AM
  #9
AudiWorld Super User
 
GTA_Driver's Avatar
 
Join Date: Aug 2004
Location: Toronto
Posts: 3,277
Default

Originally Posted by puunda View Post
I downloaded VCDS-Lite, but it doesn't work with my cable. It only has options for com ports, and not USB. Which cheap eBay cable do you have?

You said you have the full hex-USB cable? Is it authentic from Ross-Tech? If so, you can use the full version, no need for Lite.

Once you connect the cable to the OBD port and the USB, make sure you go into setup to configure the connection.

Also, how did you manage to scan 5 modules but then say that VCDS lite doesn't recognize the USB cable and wants com ports only?
GTA_Driver is offline  
Reply With Quote
Old 11-04-2013, 12:57 AM
  #10
Audiworld Junior Member
Thread Starter
 
Join Date: May 2013
Posts: 16
Default

Originally Posted by GTA_Driver View Post
You said you have the full hex-USB cable? Is it authentic from Ross-Tech? If so, you can use the full version, no need for Lite.

Once you connect the cable to the OBD port and the USB, make sure you go into setup to configure the connection.

Also, how did you manage to scan 5 modules but then say that VCDS lite doesn't recognize the USB cable and wants com ports only?
Sorry ... a bit of confusion.
I'm using the full hex-usb cable with the full VCDS ... however I can't get it to work programming my locks/windows, which is why I posted this asking for help.
Then someone said they managed to do it using the Lite version, so I downloaded the lite version, but that didn't work either.
The modules which were scanned were done using the full version. The lite version wasn't able to scan anything.
I do have an aftermarket radio, and no the abs light is not on. I've tried it with both the radio installed and disconnected
puunda is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Quick Cal
4.2 V8 Discussion
5
10-29-2015 09:25 PM
tmac2015
A8 / S8 (D3 Platform) Discussion
3
09-20-2015 04:29 PM
ericliquid
A4 (B8 Platform) Discussion
0
09-17-2015 06:13 AM
Irish1004
Audi allroad
2
09-16-2015 03:38 AM
avant22
Parts For Sale
2
09-14-2015 04:28 AM

Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 06:00 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: