What is wrong with my Q7? - AudiWorld Forums

Go Back  AudiWorld Forums > Audi Models > Audi Q3 /Q5 / Q7 > Audi Q7 > Q7 Discussion
Reload this Page > What is wrong with my Q7?
Notices
Q7 Discussion Discussion forum for the Audi Q7 SUV built from 2005 to 2015

What is wrong with my Q7?

Reply

 
 
Old 08-17-2015, 07:38 PM
  #1
AudiWorld Senior Member
Thread Starter
 
D3Audi's Avatar
 
Join Date: Mar 2015
Posts: 929
Default What is wrong with my Q7?

Ok, so I have 3 problems at the moment with my Q7. And they are driving me nuts...

#1.) Front Heated Seats and Heated Steering Wheel- the two front heated seats do not work and neither does the heated steering wheel.. This problem isn't urgent as I won't need to use these for another couple of months, but I have the app carista on my iPhone with a wireless OBD and I ran a scan and a couple of codes came back for it.. Any ideas on what to do?




#2.) Right Rear Tail Light is burnt out , but all the lights were just replaced less than a month ago... Last week the annoying error came on and the inside light of the right rear tail light was out again... Corrosion??



And then along with the tail light I was driving behind my Q7 tonight and this is what I saw.....




What is this??? The bumper tail lamp is working in place of the tail gate light! It looks so unpropirtional and dumb! The right turn signal works fine though on the tail gate... I am planning on upgrading to facelift LED's in the coming months.. I hope this won't be an issue.. Any ideas on what's causing this or how to fix the tail lights? I can post the codes for the bulb out error but that's all there is.. Just a plain old bulb out error


#3.) Ok this problem is actually making me sweat a little, Whenever I start my Q7 after it's been sitting for 5 minutes or more, it makes a weird ticking noise,, sort of like it is "back firing" but inside the engine, not the exhaust.. I have a video of it but I'm not sure how to post a video on here.. Any ideas what this could be? By the way my engine is the 2008 4.2 V8... This problem is the one I'm most concerned about.. I'm going to try to describe it.. I get in Q7, push start button, it starts to crank, but then makes the back fire noise and then starts... And then the car runs like normal and sounds like normal.. This is why it's weird, is it foreshadowing for something big?? Because if it is I'm gonna ditch this Q7 for another one before it's too late.. Lol! I hate engine problems..but I guess everyone hates engine problems.. So, any idea? I'm gonna try to post a video on here if I can figure out how too.. Thanks.
D3Audi is offline  
Reply With Quote
Old 08-17-2015, 07:54 PM
  #2
Audiworld Junior Member
 
Join Date: Feb 2015
Posts: 31
Default

Problem #2 - do check the boot lid lock mechanism inside the bottom plate. There is a left and right spring plate that engages a sensor. Ensure it is working properly by push testing both left and right plate, note for a click sensor sound. Then lower the boot to ensure that both plates are pushed in properly. If needed, put some tape on boot part to engage both plates.

https://www.audiworld.com/forums/q7-...stion-2786004/

2013 Q7 LED Tail Lights Out

Last edited by emailpeter; 08-17-2015 at 07:56 PM.
emailpeter is offline  
Reply With Quote
Old 08-17-2015, 08:17 PM
  #3
AudiWorld Member
 
B490MTL's Avatar
 
Join Date: Jan 2009
Location: Montreal
Posts: 589
Default What is wrong with my Q7?

In fact problem number 2, being the burnt light bulb causes the bottom light to work instead of those on the tailgate. Once fix it will go back to normal. Before I did the LED upgrade in the back I would burn through a lot of tail light bulbs. So it's pretty much normal. Try to find some long lasting bulbs if you want them to last longer.
B490MTL is offline  
Reply With Quote
Old 08-18-2015, 02:27 AM
  #4
AudiWorld Member
 
Join Date: Nov 2004
Posts: 562
Default

My Q7 used to burn through tail lights at at ridiculous rate. I kept 2 or three spares in the car at all times. I became very good at replacing those suckers.
Maui19 is offline  
Reply With Quote
Old 08-18-2015, 06:36 AM
  #5
AudiWorld Senior Member
Thread Starter
 
D3Audi's Avatar
 
Join Date: Mar 2015
Posts: 929
Default

Ok! Thanks! I am going to try to replace the bulbs today! Any idea as to what problem # 3 could be..? What does carbon build up sound like? It's in need of an oil change, could that be it??
D3Audi is offline  
Reply With Quote
Old 08-18-2015, 11:50 AM
  #6
AudiWorld Member
 
Phknlwyr's Avatar
 
Join Date: Jan 2009
Location: Rockville, Maryland
Posts: 191
Default

When you replace the bulbs, use a cloth between your fingers and the glass. I think that oils from your hands on the glass cause the bulbs to overheat and flame out prematurely.
Phknlwyr is offline  
Reply With Quote
Old 08-18-2015, 01:39 PM
  #7
AudiWorld Member
 
B490MTL's Avatar
 
Join Date: Jan 2009
Location: Montreal
Posts: 589
Default What is wrong with my Q7?

For problem #3, what kind of fuel are you using?
B490MTL is offline  
Reply With Quote
Old 08-18-2015, 05:07 PM
  #8
AudiWorld Senior Member
Thread Starter
 
D3Audi's Avatar
 
Join Date: Mar 2015
Posts: 929
Default

Originally Posted by B490MTL View Post
For problem #3, what kind of fuel are you using?
Shell 93 Octane Only.. Rare occasion Mobil or Sunocco... Now, I don't know what the previous owners put in it.. Could the gas be causing it?
D3Audi is offline  
Reply With Quote
Old 08-19-2015, 04:59 PM
  #9
AudiWorld Senior Member
Thread Starter
 
D3Audi's Avatar
 
Join Date: Mar 2015
Posts: 929
Default

So tonight I bought 2 1156 bulbs for the tail light.. I popped access panel off and removed bulb and discovered this..





The end looks a little burnt, here is the old bulb compared to the new bulb (old bulb left)





Then I plugged the new bulb in, shut the tailgate, and tried it again... And nope! So I took the bulb out and looked in the Socket thing and it looked burnt on the metal in there where it connects with bulb. Could I need to replace the socket? How do I clean this? I want to eventually do the facelift rear LED conversion.. Should these issues interfere with that upgrade? Should I do that upgrade now? Is this a common problem or should I take it to the dealer and see what
They think.. Here is a picture of the socket





What does everyone think? What should I do now.. As of right now my tail light is still not working.. Could it be a short?
D3Audi is offline  
Reply With Quote
Old 08-19-2015, 06:36 PM
  #10
AudiWorld Member
 
Join Date: Oct 2014
Location: Carlsbad NM
Posts: 500
Default

Your socket shorted out which cause your light bulb to burn. It is cause by last owner when replacing the bulb not using bulb grease and also putting in the socket to hard which crush the socket mating plate.
You would have to replace the socket, but a good time to do LED confer.
smith2010Q7 is offline  
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
NorthValley
Q5/SQ5 MKI (8R) Discussion
5
04-05-2016 06:38 AM
fmladineo
Q7 Discussion
2
10-05-2015 08:56 PM
smiladon
A4 (B5 Platform) Discussion
6
10-01-2015 01:31 AM
MissouriGirl
Q7 Discussion
10
09-30-2015 06:32 AM
spennysimmo
Q7 Discussion
0
09-29-2015 06:04 AM

Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 06:50 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: