Q7 MKII Discussion Discussion forum for the Audi Q7 MKII built from 2016 -
Sponsored By:
Sponsored By:

Anyone else: mildew?

 
Old 02-28-2019, 03:17 PM
  #1  
AudiWorld Member
Thread Starter
 
Join Date: May 2018
Posts: 109
Likes: 0
Received 0 Likes on 0 Posts
Default Anyone else: mildew?

Weird *** smell from Air Vents,

Smells like Wet Dog,

or Rotting food,

or Pool of Saliva,

Tried to put alcohol near vents, All I smell is alcohol, once it dissipates, and I turn on Air Blower, Smell this bad smell again
whyman is online now  
Old 03-01-2019, 02:55 AM
  #2  
JT4
AudiWorld Senior Member
 
JT4's Avatar
 
Join Date: May 2017
Location: NYC / LI
Posts: 1,078
Received 1 Like on 1 Post
Default

Maybe it's time for a cabin filter change? Even if it's not time for a change based on mileage or time, sometimes based on the environment you drive in it may warrant a change sooner.. For example, some CA members have changed their filter ahead of time due to the wildfires they experienced..

Check under your hood, if the smell is that bad it could be that a rodent crawled up under your hood and left a mess or died.. .
JT4 is offline  
Old 03-01-2019, 01:28 PM
  #3  
AudiWorld Member
Thread Starter
 
Join Date: May 2018
Posts: 109
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by JT4 View Post
Maybe it's time for a cabin filter change? Even if it's not time for a change based on mileage or time, sometimes based on the environment you drive in it may warrant a change sooner.. For example, some CA members have changed their filter ahead of time due to the wildfires they experienced..

Check under your hood, if the smell is that bad it could be that a rodent crawled up under your hood and left a mess or died.. .
changed Cabin air filter already
whyman is online now  
Old 03-01-2019, 02:19 PM
  #4  
AudiWorld Member
 
Join Date: Aug 2012
Location: BAY AREA, CA
Posts: 381
Likes: 0
Received 1 Like on 1 Post
Default

I had this issue before. I think it's moisture building up from running the A/C with the system on re circulation. I took out the cabin filter ran the system on high with the recirculation off and sprayed lysol disinfectant spray into the outisde vent..
erwheezy is offline  
Old 03-02-2019, 06:00 AM
  #5  
AudiWorld Member
 
Join Date: Feb 2018
Location: Texas
Posts: 344
Likes: 0
Received 0 Likes on 0 Posts
Default

That sounds like mold buildup on the evaporator. Not sure how to clear it out however.

Last edited by Corgiman; 03-02-2019 at 06:38 AM. Reason: Spelling
Corgiman is offline  
Old 03-02-2019, 06:12 AM
  #6  
AudiWorld Member
 
Join Date: Dec 2017
Posts: 338
Likes: 0
Received 0 Likes on 0 Posts
Default

Someone suggested spraying Ozium in to the vents on the footwell while the AC was recirculating air. I've heard Lysol, too, but I've heard good things about Ozium and people seemed more open to doing that rather than Lysol disinfectant.
smacky is offline  
Old 03-02-2019, 06:42 AM
  #7  
AudiWorld Super User
 
BigKutta's Avatar
 
Join Date: Nov 2016
Location: Washington DC burbs
Posts: 2,412
Likes: 0
Received 0 Likes on 0 Posts
Default

Is your "AC" on, or do you turn that off while running the heat in the winter?
BigKutta is offline  
Old 03-02-2019, 06:43 AM
  #8  
AudiWorld Member
 
Join Date: Feb 2018
Location: Texas
Posts: 344
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by smacky View Post
Someone suggested spraying Ozium in to the vents on the footwell while the AC was recirculating air. I've heard Lysol, too, but I've heard good things about Ozium and people seemed more open to doing that rather than Lysol disinfectant.
Quick Google and it looks like there are various kits out there to clean the evaporator. Also maybe the evaporator drain is clogged so water is not draining well? Just a guess.
Corgiman is offline  
Old 03-04-2019, 10:53 AM
  #9  
AudiWorld Senior Member
 
Join Date: Jul 2008
Location: Fresno, CA
Posts: 1,129
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by BigKutta View Post
Is your "AC" on, or do you turn that off while running the heat in the winter?
I always use the AC button to turn on my HVAC, regardless of the temperature. I feel like when I've used the heater with the AC button off in the past the windows fog up.
Blake P is offline  
Old 03-04-2019, 11:34 AM
  #10  
AudiWorld Super User
 
BigKutta's Avatar
 
Join Date: Nov 2016
Location: Washington DC burbs
Posts: 2,412
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by Blake P View Post
I always use the AC button to turn on my HVAC, regardless of the temperature. I feel like when I've used the heater with the AC button off in the past the windows fog up.
Yeah, you are supposed to, hence was asking the OP
BigKutta is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Roque
S4 / RS4 (B5 Platform) Discussion
9
04-03-2008 07:57 AM
ThorsHammer
Off-topic Discussion
1
01-09-2005 07:38 PM
Monkeyboy
Off-topic Discussion
16
07-08-2003 02:25 PM
laissezfaire
S4 / RS4 (B5 Platform) Discussion
9
10-10-2002 05:43 AM


Thread Tools
Search this Thread
Quick Reply: Anyone else: mildew?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: