P0411 Secondary Air Injection System Code SOLVED! - AudiWorld Forums


TT (Mk1) Discussion Discussion forum for the Mk1 Audi TT Coupe & Roadster produced from 2000-2006

P0411 Secondary Air Injection System Code SOLVED!

Reply
 
 
 
Thread Tools Search this Thread
Old 06-02-2008, 09:10 AM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2003
Posts: 734
Default P0411 Secondary Air Injection System Code SOLVED!

For a very long time I have had the infamous secondary air injection code thrown...
************************************************** ****
16795 - Secondary Air Injection System: Incorrect Flow Detected
P0411 - 35-10 - - - Intermittent
************************************************** ****
I replaced the secondary air injection solenoid valve (n112) leading to the secondary air pump--it actually was not bad b/c the old one did read the correct resistance (25 to 35 ohms). I replaced the secondary air injection pump--it was bad, the rivets holding it together had given way and air would rush out on start up. I pressure tested the system. I smoke tested the system. It held boost fine. But after resetting the code, it would come back after about 30 miles. This went on for nearly a year.

I did not give up.

The problem was found by actually disconnecting hose after hose and blowing smoke down them until we found the culprit. It was the vacuum hose shown in the picture. The hose had broken where it runs down under the manifold, and due to the closed one-way valve it comes off from, conventional smoke testing does not find it. The hose was replaced, and no more code being thrown.

<img src="http://www.epsthree.com/audi_pics/vacuum_hose.jpg">
GoTToGo is offline   Reply With Quote
Old 06-02-2008, 09:28 AM   #2
Member
 
Join Date: May 2002
Posts: 15,536
Default

Cool! Great trouble-shooting!!
AxeYrCat is offline   Reply With Quote
Old 06-02-2008, 11:05 AM   #3
AudiWorld Senior Member
 
Join Date: Aug 2002
Posts: 1,112
Default

Way to stick with it!
cedricl is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
:: ECS Tuning :: NEW!! B8 A4 2.0T ECS Baffled Oil Catch Can ECS Tuning-Audi A4 (B8 Platform) Discussion 14 12-23-2016 03:46 AM
No Start, Need Codes Diagnosis eggsngrits A8 / S8 (D3 Platform) Discussion 0 09-05-2015 10:22 AM
Frustrated 2004 Audi A8L 4.2L jeffkruse A8 / S8 (D3 Platform) Discussion 5 09-04-2015 11:59 AM
:: ECS Tuning :: NEW!! B7 A4 2.0T ECS Baffled Oil Catch Can ECS Tuning-Audi A4 (B7 Platform) Discussion 0 09-01-2015 09:16 AM
:: ECS Tuning :: NEW!! B8 A5 2.0T ECS Baffled Oil Catch Can ECS Tuning-Audi Audi A5 / S5 / RS5 Coupe & Cabrio (B8) 0 09-01-2015 08:27 AM


Tags
2005, a4, air, audi, code, detected, flow, hose, incorrect, p0411, po411, secondary, solved, troubleshooting, tt, vw

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 12:52 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send