Reduced Power - Lots of codes --- Help! - AudiWorld Forums

Go Back   AudiWorld Forums > Audi Models > Audi A6 / S6 / RS 6 > A6 / S6 (C5 Platform) Discussion
Log In 


A6 / S6 (C5 Platform) Discussion Discussion forum for the C5 Audi A6 and S6 produced from 1998-2004

Reduced Power - Lots of codes --- Help!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-11-2014, 01:43 PM   #1
AudiWorld Newcomer
 
Join Date: Sep 2013
Posts: 3
Default Reduced Power - Lots of codes --- Help!

2002 A6 Avant - 3.0 (I'm starting to dislike this engine)

Newbie poster, hoping to get some insight.

Driving down the highway and the EPC light and MIL come on with reduced power but still running reasonably well. Pull over check it out with no obvious issues. Starts back up and EPC and MIL come back on with reduced power but still drivable. 5 miles down the road it gets worse and worse. I'm close to home so pull off and take side streets home. It deteriorated to the point it would barely come off idle. Pulled over to let things cool off thinking it was a sensor. 15 minutes later it runs much better but EPC and MIL still on.

Get home and it has the following codes, none of which it has had prior:

11 Faults Found:
19756 - Exhaust Camshaft Position Sensor Bank 1 (G300)
P3300 - 002 - Short to Ground - MIL ON
17800 - Camshaft Position Sensor Bank 2 (G163)
P1392 - 001 - Open Short to Plus - MIL ON
17746 - Camshaft Position Sensor (G40)
P1338 - 001 - Open or Short to Plus - MIL ON
19759 - Exhaust Camshaft Position Sensor Bank 2 (G301)
P3303 - 001 - Open or Short to Plus - MIL ON
18041 - Accelerator Position Sensor 2 (G185)
P1633 - 002 - Signal too Low - MIL ON
18047 - Accelerator Position Sensor 1/2 (G79/G185)
P1639 - 008 - Implausible Signal - Intermittent
18321 - Pressure Sensor for Brake Boost (G294)
P1913 - 002 - Short to Ground - Intermittent
17796 - Control Module Malfunction - DBW Throttle Monitoring
P1388 - 008 - - Intermittent
17536 - Fuel Trim; Bank 1 (Mult)
P1128 - 001 - System too Lean - Intermittent
17538 - Fuel Trim; Bank 2 (Mult)
P1130 - 001 - System too Lean - Intermittent
16485 - Mass Air Flow Sensor (G70)
P0101 - 008 - Implausible Signal - MIL ON


I monitored all the throttle position sensors on measuring blocks and they seem okay. I cleared the codes and started it back up. Idles unstable but has only the following codes:

17800 - Camshaft Position Sensor Bank 2 (G163)
P1392 - 001 - Open Short to Plus
17746 - Camshaft Position Sensor (G40)
P1338 - 001 - Open or Short to Plus
19759 - Exhaust Camshaft Position Sensor Bank 2 (G301)
P3303 - 001 - Open or Short to Plus
19756 - Exhaust Camshaft Position Sensor Bank 1 (G300)
P3300 - 002 - Short to Ground

Did some research and suspect the cam position sensor circuit is bad. Planning on checking it out this weekend. Though I can't shake the feeling that the ECU went bad. I would appreciate feedback. Thanks!
kylepet is offline   Reply With Quote
Old 04-18-2014, 09:13 AM   #2
AudiWorld Member
 
snatchman's Avatar
 
Join Date: Jul 2012
Location: Columbia, SC
Posts: 101
Default

Quote:
Originally Posted by kylepet View Post
2002 A6 Avant - 3.0 (I'm starting to dislike this engine)

Newbie poster, hoping to get some insight.

Driving down the highway and the EPC light and MIL come on with reduced power but still running reasonably well. Pull over check it out with no obvious issues. Starts back up and EPC and MIL come back on with reduced power but still drivable. 5 miles down the road it gets worse and worse. I'm close to home so pull off and take side streets home. It deteriorated to the point it would barely come off idle. Pulled over to let things cool off thinking it was a sensor. 15 minutes later it runs much better but EPC and MIL still on.

Get home and it has the following codes, none of which it has had prior:

11 Faults Found:
19756 - Exhaust Camshaft Position Sensor Bank 1 (G300)
P3300 - 002 - Short to Ground - MIL ON
17800 - Camshaft Position Sensor Bank 2 (G163)
P1392 - 001 - Open Short to Plus - MIL ON
17746 - Camshaft Position Sensor (G40)
P1338 - 001 - Open or Short to Plus - MIL ON
19759 - Exhaust Camshaft Position Sensor Bank 2 (G301)
P3303 - 001 - Open or Short to Plus - MIL ON
18041 - Accelerator Position Sensor 2 (G185)
P1633 - 002 - Signal too Low - MIL ON
18047 - Accelerator Position Sensor 1/2 (G79/G185)
P1639 - 008 - Implausible Signal - Intermittent
18321 - Pressure Sensor for Brake Boost (G294)
P1913 - 002 - Short to Ground - Intermittent
17796 - Control Module Malfunction - DBW Throttle Monitoring
P1388 - 008 - - Intermittent
17536 - Fuel Trim; Bank 1 (Mult)
P1128 - 001 - System too Lean - Intermittent
17538 - Fuel Trim; Bank 2 (Mult)
P1130 - 001 - System too Lean - Intermittent
16485 - Mass Air Flow Sensor (G70)
P0101 - 008 - Implausible Signal - MIL ON


I monitored all the throttle position sensors on measuring blocks and they seem okay. I cleared the codes and started it back up. Idles unstable but has only the following codes:

17800 - Camshaft Position Sensor Bank 2 (G163)
P1392 - 001 - Open Short to Plus
17746 - Camshaft Position Sensor (G40)
P1338 - 001 - Open or Short to Plus
19759 - Exhaust Camshaft Position Sensor Bank 2 (G301)
P3303 - 001 - Open or Short to Plus
19756 - Exhaust Camshaft Position Sensor Bank 1 (G300)
P3300 - 002 - Short to Ground

Did some research and suspect the cam position sensor circuit is bad. Planning on checking it out this weekend. Though I can't shake the feeling that the ECU went bad. I would appreciate feedback. Thanks!
I am Curious to know what you found. I am having a similar issue with my 2002 A6 3.0. I found coolant in the ABS and ECU module wire harness, effectively trashing these to units. Hope your not having the same issue, I still have not track down the source of the coolant.
__________________

I love this car!
snatchman is offline   Reply With Quote
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
B7 RS4 misfires at high RPM Wombat1482 RS4 (B7 Platform) Discussion 5 08-14-2015 01:40 PM
Audi S3 Sedan by ABT has more power then RS3 trevakaed Audi A3 / S3 /RS 3 MKII 6 07-30-2015 06:56 AM
B9 A4 roadtest QUATTRO_PEARL A4 (B9 Platform) Discussion 0 07-24-2015 04:46 AM
P0299 but no loss of power tempests4 A4 (B8 Platform) Discussion 0 07-23-2015 03:55 PM
MMI Control Panel and Battery Issues benpitt A8 / S8 (D3 Platform) Discussion 4 07-23-2015 12:01 PM


All times are GMT -8. The time now is 08:17 AM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community