Reduced Power - Lots of codes --- Help! - AudiWorld Forums

Go Back   AudiWorld Forums > Audi Models > Audi A6 / S6 / RS 6 > A6 / S6 (C5 Platform) Discussion
Log In 


A6 / S6 (C5 Platform) Discussion Discussion forum for the C5 Audi A6 and S6 produced from 1998-2004

Reduced Power - Lots of codes --- Help!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-11-2014, 02:43 PM   #1
AudiWorld Newcomer
 
Join Date: Sep 2013
Posts: 3
Default Reduced Power - Lots of codes --- Help!

2002 A6 Avant - 3.0 (I'm starting to dislike this engine)

Newbie poster, hoping to get some insight.

Driving down the highway and the EPC light and MIL come on with reduced power but still running reasonably well. Pull over check it out with no obvious issues. Starts back up and EPC and MIL come back on with reduced power but still drivable. 5 miles down the road it gets worse and worse. I'm close to home so pull off and take side streets home. It deteriorated to the point it would barely come off idle. Pulled over to let things cool off thinking it was a sensor. 15 minutes later it runs much better but EPC and MIL still on.

Get home and it has the following codes, none of which it has had prior:

11 Faults Found:
19756 - Exhaust Camshaft Position Sensor Bank 1 (G300)
P3300 - 002 - Short to Ground - MIL ON
17800 - Camshaft Position Sensor Bank 2 (G163)
P1392 - 001 - Open Short to Plus - MIL ON
17746 - Camshaft Position Sensor (G40)
P1338 - 001 - Open or Short to Plus - MIL ON
19759 - Exhaust Camshaft Position Sensor Bank 2 (G301)
P3303 - 001 - Open or Short to Plus - MIL ON
18041 - Accelerator Position Sensor 2 (G185)
P1633 - 002 - Signal too Low - MIL ON
18047 - Accelerator Position Sensor 1/2 (G79/G185)
P1639 - 008 - Implausible Signal - Intermittent
18321 - Pressure Sensor for Brake Boost (G294)
P1913 - 002 - Short to Ground - Intermittent
17796 - Control Module Malfunction - DBW Throttle Monitoring
P1388 - 008 - - Intermittent
17536 - Fuel Trim; Bank 1 (Mult)
P1128 - 001 - System too Lean - Intermittent
17538 - Fuel Trim; Bank 2 (Mult)
P1130 - 001 - System too Lean - Intermittent
16485 - Mass Air Flow Sensor (G70)
P0101 - 008 - Implausible Signal - MIL ON


I monitored all the throttle position sensors on measuring blocks and they seem okay. I cleared the codes and started it back up. Idles unstable but has only the following codes:

17800 - Camshaft Position Sensor Bank 2 (G163)
P1392 - 001 - Open Short to Plus
17746 - Camshaft Position Sensor (G40)
P1338 - 001 - Open or Short to Plus
19759 - Exhaust Camshaft Position Sensor Bank 2 (G301)
P3303 - 001 - Open or Short to Plus
19756 - Exhaust Camshaft Position Sensor Bank 1 (G300)
P3300 - 002 - Short to Ground

Did some research and suspect the cam position sensor circuit is bad. Planning on checking it out this weekend. Though I can't shake the feeling that the ECU went bad. I would appreciate feedback. Thanks!
kylepet is offline   Reply With Quote
Old 04-18-2014, 10:13 AM   #2
AudiWorld Member
 
snatchman's Avatar
 
Join Date: Jul 2012
Location: Columbia, SC
Posts: 108
Default

Quote:
Originally Posted by kylepet View Post
2002 A6 Avant - 3.0 (I'm starting to dislike this engine)

Newbie poster, hoping to get some insight.

Driving down the highway and the EPC light and MIL come on with reduced power but still running reasonably well. Pull over check it out with no obvious issues. Starts back up and EPC and MIL come back on with reduced power but still drivable. 5 miles down the road it gets worse and worse. I'm close to home so pull off and take side streets home. It deteriorated to the point it would barely come off idle. Pulled over to let things cool off thinking it was a sensor. 15 minutes later it runs much better but EPC and MIL still on.

Get home and it has the following codes, none of which it has had prior:

11 Faults Found:
19756 - Exhaust Camshaft Position Sensor Bank 1 (G300)
P3300 - 002 - Short to Ground - MIL ON
17800 - Camshaft Position Sensor Bank 2 (G163)
P1392 - 001 - Open Short to Plus - MIL ON
17746 - Camshaft Position Sensor (G40)
P1338 - 001 - Open or Short to Plus - MIL ON
19759 - Exhaust Camshaft Position Sensor Bank 2 (G301)
P3303 - 001 - Open or Short to Plus - MIL ON
18041 - Accelerator Position Sensor 2 (G185)
P1633 - 002 - Signal too Low - MIL ON
18047 - Accelerator Position Sensor 1/2 (G79/G185)
P1639 - 008 - Implausible Signal - Intermittent
18321 - Pressure Sensor for Brake Boost (G294)
P1913 - 002 - Short to Ground - Intermittent
17796 - Control Module Malfunction - DBW Throttle Monitoring
P1388 - 008 - - Intermittent
17536 - Fuel Trim; Bank 1 (Mult)
P1128 - 001 - System too Lean - Intermittent
17538 - Fuel Trim; Bank 2 (Mult)
P1130 - 001 - System too Lean - Intermittent
16485 - Mass Air Flow Sensor (G70)
P0101 - 008 - Implausible Signal - MIL ON


I monitored all the throttle position sensors on measuring blocks and they seem okay. I cleared the codes and started it back up. Idles unstable but has only the following codes:

17800 - Camshaft Position Sensor Bank 2 (G163)
P1392 - 001 - Open Short to Plus
17746 - Camshaft Position Sensor (G40)
P1338 - 001 - Open or Short to Plus
19759 - Exhaust Camshaft Position Sensor Bank 2 (G301)
P3303 - 001 - Open or Short to Plus
19756 - Exhaust Camshaft Position Sensor Bank 1 (G300)
P3300 - 002 - Short to Ground

Did some research and suspect the cam position sensor circuit is bad. Planning on checking it out this weekend. Though I can't shake the feeling that the ECU went bad. I would appreciate feedback. Thanks!
I am Curious to know what you found. I am having a similar issue with my 2002 A6 3.0. I found coolant in the ABS and ECU module wire harness, effectively trashing these to units. Hope your not having the same issue, I still have not track down the source of the coolant.
__________________

I love this car!
snatchman is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
I have some fault codes and an engine light car stalled turned off saifxnyc A6 / S6 (C6 Platform) Discussion 9 11-30-2015 01:32 PM
2.0 TFSI power loss Tom10 Audi A3 / S3 / RS3 7 09-16-2015 12:17 PM
A4 b7 2005 2.0 tfsi power blips magikmushroom78 A4 (B7 Platform) Discussion 0 09-05-2015 02:39 AM
Got an A7, wanna ask some questions :) zhaoweitian A7 2 09-01-2015 04:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:30 PM.