Go Back   AudiWorld Forums > Audi Models > Audi Q3 /Q5 / Q7 > Q5/SQ5 Discussion
Sign in using an external account
Register Forgot Password?


Q5/SQ5 Discussion Discussion forum for the Audi Q5 SUV
Sponsored by: Audi

EPC and check engine light

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 09-30-2010, 11:19 AM   #1
AudiWorld Senior Member
Account #: 165556
 
BCD-1's Avatar
 
Join Date: Jul 2009
Posts: 644
Default EPC and check engine light

The EPC and check engine light in the dash came on, called the Dealer. Im back to the Dealer on Friday morning. My Dealer says
its the EPC Sensor that's on the Blink.....

Are there any other cases with Q5's with this problem ?

BCD-1
BCD-1 is offline   Reply With Quote
Old 09-30-2010, 11:32 AM   #2
AudiWorld Super User
Account #: 154402
 
Join Date: Oct 2008
Posts: 3,200
Default

Is your car misfiring or in limp mode? Maybe you can get the water pump replace at the same time.
The G Man is offline   Reply With Quote
Old 09-30-2010, 11:43 AM   #3
AudiWorld Senior Member
Account #: 165556
 
BCD-1's Avatar
 
Join Date: Jul 2009
Posts: 644
Default

My dealer just changed the water pump Yesterday.
The Q is running like a Charm. No misfiring at all ...

G Man Whats limp mode?

BCD-1
BCD-1 is offline   Reply With Quote
Old 09-30-2010, 11:47 AM   #4
AudiWorld Super User
Account #: 154402
 
Join Date: Oct 2008
Posts: 3,200
Default

Quote:
Originally Posted by BCD-1 View Post
My dealer just changed the water pump Yesterday.
The Q is running like a Charm. No misfiring at all ...

G Man Whats limp mode?

BCD-1
Are you sure your dealer didnt mess up something when they change the water pump?
Limp mode is when your car cuts power and rpm to protect itself. The computer will not allow the car to go over certain rpm or speed.
The G Man is offline   Reply With Quote
Old 09-30-2010, 11:51 AM   #5
AudiWorld Senior Member
Account #: 165556
 
BCD-1's Avatar
 
Join Date: Jul 2009
Posts: 644
Default

My Wife was Driving the Q5, we just had a little chat...
She had said that not only the epc LIGHT CAME ON But there was another message .... not to excide 4000 RPM ????

I just went for a quick spin. No warning lights on in the dash at all.

BCD-1
BCD-1 is offline   Reply With Quote
Old 09-30-2010, 11:55 AM   #6
AudiWorld Super User
Account #: 154402
 
Join Date: Oct 2008
Posts: 3,200
Default

Quote:
Originally Posted by BCD-1 View Post
My Wife was Driving the Q5, we just had a little chat...
She had said that not only the epc LIGHT CAME ON But there was another message .... not to excide 4000 RPM ????

I just went for a quick spin. No warning lights on in the dash at all.

BCD-1
Yeah, thats the limp mode, the dealer might have mess up your crankshaft position sensor or possibly a loose electrical connection.
The G Man is offline   Reply With Quote
Old 09-30-2010, 12:01 PM   #7
AudiWorld Senior Member
Account #: 165556
 
BCD-1's Avatar
 
Join Date: Jul 2009
Posts: 644
Default

I'm back in the Morning at the Dealer

BCD-1
BCD-1 is offline   Reply With Quote
Old 10-01-2010, 06:26 AM   #8
AudiWorld Senior Member
Account #: 165556
 
BCD-1's Avatar
 
Join Date: Jul 2009
Posts: 644
Default

Back from the Dealer


They replaced cam Shift actuator SENSOR # AUD 06E103697G

All is 100 %

BCD-1
BCD-1 is offline   Reply With Quote
Old 12-22-2010, 03:06 PM   #9
Audiworld Junior Member
Account #: 180140
 
Join Date: Mar 2010
Posts: 24
Default

I have the same EPC lights and now the CEL. The tech told me that there's no EPC code and that it's the camshaft shift sensor - on order till next week. The EPC light started to come on after the dealer replace the water pump (steam and water from the engine).
When the EPC light is ON, the engine seems like it has a high rpm and running slow. Pulled over, turn off the car and re-start and the EPC light goes off and runs normal gain.
I'm very unlucky to have this Q5 1. transmission problem 2. waterpump 3. EPC and CEL lights
Now I'm in the market for a new SUV - not Audi of course.
VetteSiNz is offline   Reply With Quote
Old 12-23-2010, 06:19 AM   #10
Audiworld Junior Member
Account #: 178353
 
Day Laborer's Avatar
 
Join Date: Feb 2010
Posts: 19
Default

Quote:
Originally Posted by BCD-1 View Post
Back from the Dealer


They replaced cam Shift actuator SENSOR # AUD 06E103697G

All is 100 %

BCD-1
Same thing happend to my wife's Q5.
Also had the Water Pump replaced a while back.

Seriously, I think its Audi & VW that gives German cars a bad reputation in terms of reliability.
Day Laborer is offline   Reply With Quote
Old 04-11-2013, 08:50 AM   #11
AudiWorld Newcomer
Account #: 255805
 
luckyluc70's Avatar
 
Join Date: Apr 2013
Posts: 5
Default Q5 3.2 epc and engine light on

Just bought yesterday a Q5, 3.2 2010 with 46,000km on it. i was driving this afternoon and boum epc light on and car seem to loose power at low idle and feel like it was shaking..... could it be just a software upgrade? or as i read in a few thread, sensor camshift replacement?

thanks for your help
luckyluc70 is offline   Reply With Quote
Old 04-15-2013, 02:35 AM   #12
AudiWorld Senior Member
Account #: 165556
 
BCD-1's Avatar
 
Join Date: Jul 2009
Posts: 644
Default

Quote:
Originally Posted by luckyluc70 View Post
Just bought yesterday a Q5, 3.2 2010 with 46,000km on it. i was driving this afternoon and boum epc light on and car seem to loose power at low idle and feel like it was shaking..... could it be just a software upgrade? or as i read in a few thread, sensor camshift replacement?

thanks for your help
On My Q They replaced cam Shift actuator SENSOR # AUD 06E103697G

BCD-1
BCD-1 is offline   Reply With Quote
Old 04-15-2013, 03:52 AM   #13
AudiWorld Newcomer
Account #: 255805
 
luckyluc70's Avatar
 
Join Date: Apr 2013
Posts: 5
Default

thanks BCD, im going to the dealer today, lets see what they will tell me
luckyluc70 is offline   Reply With Quote
Old 04-15-2013, 04:19 AM   #14
AudiWorld Senior Member
Account #: 165556
 
BCD-1's Avatar
 
Join Date: Jul 2009
Posts: 644
Default

Quote:
Originally Posted by luckyluc70 View Post
thanks BCD, im going to the dealer today, lets see what they will tell me
I had the same problem.. Not to worry
I was a easy fix

Regards BCD-1
BCD-1 is offline   Reply With Quote
Old 04-15-2013, 05:06 AM   #15
AudiWorld Newcomer
Account #: 242168
 
Join Date: Aug 2012
Location: Kaiserslautern Germany
Posts: 2
Default

Had this issue a few months ago. I had some rodents chew on some of the wires in the engine bay. Which produced a EPC and CEL. Cost me about 120 Euro, :-(
__________________
2012-Premium Plus 2.0T w/Advance Key, B&O, MMI NAV, Black w/Cinnimon Brown Seats, 19" Rims
rons-Q5 is offline   Reply With Quote
Old 04-17-2013, 05:50 AM   #16
AudiWorld Newcomer
Account #: 255805
 
luckyluc70's Avatar
 
Join Date: Apr 2013
Posts: 5
Default

back from the dealer, my EPC and engine light on was due to misfire in cylinder 3, sparkplug malfunction. it was changed and boum all is fine. Im happy.
luckyluc70 is offline   Reply With Quote
Old 08-31-2013, 05:56 PM   #17
AudiWorld Newcomer
Account #: 265855
 
Join Date: Aug 2013
Posts: 1
Default EPC LIGHT Q5

I had my Q5 do the same thing was driving EPC light come on revs went down. parked in garage now. is it safe to drive to workshop, has any one driven there's when EPC comes up on dash????
stu 0001 is offline   Reply With Quote
Old 09-04-2013, 01:42 PM   #18
AudiWorld Senior Member
Account #: 165556
 
BCD-1's Avatar
 
Join Date: Jul 2009
Posts: 644
Default

Quote:
Originally Posted by stu 0001 View Post
I had my Q5 do the same thing was driving EPC light come on revs went down. parked in garage now. is it safe to drive to workshop, has any one driven there's when EPC comes up on dash????
Yes I did...
I did not have a problem

BCD-1
BCD-1 is offline   Reply With Quote
Old 01-20-2014, 04:45 AM   #19
Audiworld Junior Member
Account #: 273728
 
Join Date: Dec 2013
Posts: 25
Default sq5

got a brand new sq5 last week, driving back from Vermont last night to ny on 95 the epc light came on and car went into limp mode, I had no power at all it seemed.
moving over 3 lanes of 95 going under 20 miles an hour now was a bit dangerous...

pulled over restarted the car and all was fine. I'm a bit nervous to let my fiancÚ drive this car on a day to day basis now I don't want this happening to her. Is there one specific thing that is wrong to have fixed or endless possibilities?
Jlnike is offline   Reply With Quote
Old 01-27-2014, 11:52 AM   #20
AudiWorld Senior Member
Account #: 165556
 
BCD-1's Avatar
 
Join Date: Jul 2009
Posts: 644
Default

Quote:
Originally Posted by Jlnike View Post
got a brand new sq5 last week, driving back from Vermont last night to ny on 95 the epc light came on and car went into limp mode, I had no power at all it seemed.
moving over 3 lanes of 95 going under 20 miles an hour now was a bit dangerous...

pulled over restarted the car and all was fine. I'm a bit nervous to let my fiancÚ drive this car on a day to day basis now I don't want this happening to her. Is there one specific thing that is wrong to have fixed or endless possibilities?
I would go to your Dealer as soon as can.

They replaced My cam Shift actuator SENSOR # AUD 06E103697G

All is 100 %

BCD-1
BCD-1 is offline   Reply With Quote
Old 01-27-2014, 11:52 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
a4, a8l, aud, audi, b7, car, check, engine, epc, light, lights, q5, rs4, speed, warning


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



Join AudiWorld

All times are GMT -8. The time now is 09:20 AM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community