Go Back  AudiWorld Forums > Audi Models > Audi Q3 /Q5 / Q7 / Q8 > Audi Q7 > Q7 Discussion
Reload this Page >

Clanking sound from undercarrige

Q7 Discussion Discussion forum for the Audi Q7 SUV built from 2005 to 2015
Sponsored By:
Sponsored By:

Clanking sound from undercarrige

 
Old 04-19-2019, 02:34 AM
  #1  
AudiWorld Junior Member
Thread Starter
 
Join Date: Jan 2014
Posts: 5
Default Clanking sound from undercarrige

Q7 2009 with 110k miles. I can hear a single metal "clank" when I drive over a bump or hit a hole in the road; I think it happens mostly at low speeds but I could be wrong. I can only hear it when I have the front windows open and near a side wall(building or cars parked) so the sound can bounce. It sounds like a pipe that is loose in the clamp. I also have an occasional error code about the EVAP system that shows up once and a while and then disappears; no idea if it is related. Happens on all tires. I've been to two mechanics that couldn't find the source. One of them said that he thinks it is the struts; all of them failing at the same time? Any ideas guys?
krassyg is offline  
Old 04-19-2019, 04:31 AM
  #2  
AudiWorld Member
 
Join Date: Apr 2018
Posts: 56
Default

A clang sounds exhaust related like a heat shield, just inspect it to see it one is loose.
Dudeness30 is offline  
Old 05-05-2019, 03:53 AM
  #3  
AudiWorld Junior Member
Thread Starter
 
Join Date: Jan 2014
Posts: 5
Default

I took it to a third guy and he couldn't find a problem with the undercarriage. The definitely hear the clang only at low speeds; I drove with the windows down near the divider on the highway and couldn't hear the clang. Does that mean a problem with the suspension? The car has been driven mostly in NY and NJ; the roads are terrible around here.

krassyg is offline  
Old 05-10-2019, 08:07 PM
  #4  
AudiWorld Newcomer
 
Join Date: Apr 2019
Posts: 3
Default

The problem could be the tie rods. I had the same problem on my C350. Here is what I would do. Jack up the front and the vehicle and check the front wheels by grabbing the wheel at 3 and 9 o'clock and push and pull on it to see if you feel any play. And then do the same thing to the rear.

Here is a good Youtube video.
nkq7 is offline  
Old 05-11-2019, 01:45 AM
  #5  
AudiWorld Super User
 
KevinGary's Avatar
 
Join Date: Mar 2005
Location: Long Island, New York
Posts: 6,101
Default

Take a look at the sway bar. It is a common Audi problem as the mileage gets higher.
KevinGary is offline  
Old 05-11-2019, 08:17 AM
  #6  
AudiWorld Senior Member
 
dreadlocks's Avatar
 
Join Date: Mar 2017
Location: Denver, CO
Posts: 1,277
Default

Center bearing on driveshaft, get under the vehicle.. its right in the middle of the vehicle.. give it a good shake and see how much it moves, its a common failure.
dreadlocks is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
netmet
A4 (B8 Platform) Discussion
1
08-27-2017 06:05 PM
adc
A4 (B5 Platform) Discussion
1
12-10-2001 02:54 PM
Couper
A4 (B5 Platform) Discussion
1
10-26-2001 05:20 AM


Thread Tools
Search this Thread
Quick Reply: Clanking sound from undercarrige


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: