Third row sunroof shade won't stay closed - AudiWorld Forums

Go Back  AudiWorld Forums > Audi Models > Audi Q3 /Q5 / Q7 > Audi Q7 > Q7 Discussion
Reload this Page > Third row sunroof shade won't stay closed
Notices
Q7 Discussion Discussion forum for the Audi Q7 SUV built from 2005 to 2015

Third row sunroof shade won't stay closed

Reply

 
 
Old 03-03-2014, 02:02 PM
  #1
Audiworld Junior Member
Thread Starter
 
pdisme's Avatar
 
Join Date: Jan 2014
Location: Tampa
Posts: 33
Default Third row sunroof shade won't stay closed

Anyone had this issue? About 50% of the time, if I'm able to get it to stay closed, it pops back open when hitting bumps or pulling into a driveway; the rest of the time it won't stay closed at all. The release lever in the middle of the shade handle feels like it actuates the release properly and it returns to the position where it should lock in place, but doesn't work so well.
pdisme is offline  
Reply With Quote
Old 03-03-2014, 04:40 PM
  #2
Audiworld Junior Member
 
Join Date: Jul 2011
Posts: 51
Default

I did as well I noticed that the plastic bar that catches was broken and was catching
You also have to insure the tab is flexing back allowing it to catch...
henryt111 is offline  
Reply With Quote
Old 03-04-2014, 03:13 PM
  #3
Audiworld Junior Member
Thread Starter
 
pdisme's Avatar
 
Join Date: Jan 2014
Location: Tampa
Posts: 33
Default

Seems to be; guess I'll make another trip to the dealer. Second issue with my month old vehicle.
pdisme is offline  
Reply With Quote
Old 03-05-2014, 06:08 AM
  #4
Audiworld Junior Member
 
Join Date: Jun 2009
Posts: 23
Default

Yes, I had the same issue. took it to the dealer and dropped $235 for them to replace that small hatch. The part is $100 plus their 1hr labor another $134.99.

If you have warranty then by all means take it to the dealer, if not I would order the part and do it myself its pretty simple.

Thanks
nmm987 is offline  
Reply With Quote
Old 03-05-2014, 08:16 AM
  #5
Audiworld Junior Member
Thread Starter
 
pdisme's Avatar
 
Join Date: Jan 2014
Location: Tampa
Posts: 33
Default

Yep, it's only a month old so plenty of warranty left. I'm going to take it in tomorrow. I've also had one of the 12v power jacks fail, so kind of curious what other minor things got overlooked during the build.
pdisme is offline  
Reply With Quote
Old 04-24-2014, 05:17 PM
  #6
AudiWorld Member
 
Join Date: Mar 2002
Posts: 151
Default

Do you have the part number?
Same issue.



Originally Posted by nmm987 View Post
Yes, I had the same issue. took it to the dealer and dropped $235 for them to replace that small hatch. The part is $100 plus their 1hr labor another $134.99.

If you have warranty then by all means take it to the dealer, if not I would order the part and do it myself its pretty simple.

Thanks
zerophat is offline  
Reply With Quote
Old 05-04-2014, 02:40 PM
  #7
Audiworld Junior Member
Thread Starter
 
pdisme's Avatar
 
Join Date: Jan 2014
Location: Tampa
Posts: 33
Default

Would love to have that too. I continue to have the issue but it never occurs when I bring the car in lol. I'd like to insist they go ahead and replace the part if I know what to insist on.
pdisme is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mkiv808
Audi A3 / S3 / RS3
11
02-14-2016 09:57 PM
Cboogie
A8 / S8 (D3 Platform) Discussion
12
10-02-2015 12:43 PM
JohnHugill
A8 / S8 (D4 Platform) Discussion
25
09-22-2015 03:37 PM
chubs636
TT (Mk1) Discussion
3
09-14-2015 03:42 PM
Clarkbowman
Audi allroad
3
09-10-2015 05:46 AM


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 07:50 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: