Code P0421 was NOT catalytic converter - AudiWorld Forums

Go Back  AudiWorld Forums > Audi Models > Audi A4 > A4 (B5 Platform) Discussion
Reload this Page > Code P0421 was NOT catalytic converter
Notices
A4 (B5 Platform) Discussion Discussion forum for the B5 Audi A4 produced from 1995-2001 B5 FAQ
Sponsored by:
Sponsored by:

Code P0421 was NOT catalytic converter

Reply

 
 
Old 02-24-2010, 10:54 AM
  #1
AudiWorld Newcomer
Thread Starter
 
Join Date: Feb 2010
Posts: 2
Default Code P0421 was NOT catalytic converter

I have a 2000 A4 with the 2.8 V6 and 139k. I recently had the check engine light come on and found it was code P0421. Most people told me it was the cats. I took it to a very reputable German car mechanic who said he's seen this in these Audi's and he felt that it was a faulty code, that the ECU parameters were too stringent.

Based on that info, I took it in to Audi and had them flash the ECU. That was about 1k miles ago and I haven't had the light come back on.
dpeverhart is offline  
Reply With Quote
Old 02-24-2010, 11:03 AM
  #2
Tech Guru
 
4Driver4's Avatar
 
Join Date: Oct 2002
Posts: 33,594
Default

Common issue and fix. There is a TSB on this. Lucky your tech was sharp enough to dig it up.
4Driver4 is offline  
Reply With Quote
Old 02-24-2010, 11:06 AM
  #3
AudiWorld Newcomer
Thread Starter
 
Join Date: Feb 2010
Posts: 2
Default

There was a TSB? Does that mean I shouldn't have paid for it? They charged me $189 plus another $50 to remove the radio to get the radio code.

Originally Posted by 4Driver4 View Post
Common issue and fix. There is a TSB on this. Lucky your tech was sharp enough to dig it up.
dpeverhart is offline  
Reply With Quote
Old 02-24-2010, 01:47 PM
  #4
Tech Guru
 
4Driver4's Avatar
 
Join Date: Oct 2002
Posts: 33,594
Default

Originally Posted by dpeverhart View Post
There was a TSB? Does that mean I shouldn't have paid for it?
No. Audi service sucks.

They issue a TSB instead of a recall so they can decide who pays and who doesn't. Unless you are the original owner and the car has been serviced at Audi, forget it.

BTDT with the local dealer and Audi of America.
Their contention: car is out of warranty.
My contention: warranty period not applicable since nothing is broken; car is functioning as designed. Design flaw should be corrected at Audi expense.
4Driver4 is offline  
Reply With Quote
Old 03-10-2010, 01:48 PM
  #5
Audiworld Junior Member
 
Join Date: May 2009
Posts: 17
Default

Originally Posted by dpeverhart View Post
Code P0421 was NOT catalytic converter : I have a 2000 A4 with the 2.8 V6 and 139k. I recently had the check engine light come on and found it was code P0421. Most people told me it was the cats. I took it to a very reputable German car mechanic who said he's seen this in these Audi's and he felt that it was a faulty code, that the ECU parameters were too stringent.

Based on that info, I took it in to Audi and had them flash the ECU. That was about 1k miles ago and I haven't had the light come back on.

That sucks that they charged you
jbracefan1977 is offline  
Reply With Quote
Old 10-06-2014, 08:29 AM
  #6
AudiWorld Newcomer
 
Join Date: Sep 2014
Posts: 2
Default

I'm having that problem with my A4 right now. I just contacted the dealer and they told me they are no longer doing the flash. Is there any way to take care of it myself? I'm going to try the spark plug defouler trick to see if that works. The dealer wanted to just replace the cats. I guess there wasn't enough money for them in just resetting the parameters.
rpmccas is offline  
Reply With Quote
Old 10-07-2014, 11:30 AM
  #7
AudiWorld Super User
 
Prospeeder's Avatar
 
Join Date: Aug 2011
Location: Washington
Posts: 2,369
Default

Originally Posted by rpmccas View Post
I'm having that problem with my A4 right now. I just contacted the dealer and they told me they are no longer doing the flash. Is there any way to take care of it myself? I'm going to try the spark plug defouler trick to see if that works. The dealer wanted to just replace the cats. I guess there wasn't enough money for them in just resetting the parameters.
Spark plug defouler trick does work. But you have to grind out the inside of one of the foulers to make room for the end of the o2 sensor. Alittle tedious with a dremel but so far has worked on the couple cars iv done it to. Seems some 30v 2.8 cars 98-00 Seem to have the issue.
Prospeeder is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Cmmartin23
Parts For Sale
26
08-23-2016 04:44 PM
BriGuy01-2.7T
A6 / S6 (C5 Platform) Discussion
37
10-22-2015 08:04 AM
N_Jay
A6 / S6 (C5 Platform) Discussion
12
09-22-2015 08:22 AM
cope
TT (Mk1) Discussion
5
09-10-2015 12:12 PM
cope
TT (Mk3) Discussion
2
09-09-2015 07:31 AM


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 02:33 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: