A4 (B7 Platform) Discussion Discussion forum for the B7 Audi A4 produced from 2005-2008.5

Audi A4 B7 losing coolant

 
Old 05-17-2019, 03:43 PM
  #1  
AudiWorld Newcomer
Thread Starter
 
Join Date: May 2019
Posts: 1
Default Audi A4 B7 losing coolant

Hey guys,

My 2005 Audi A4 B7 with a BGB engine is losing coolant and not heating up to a decent temperature when driving on the highway however it will get to temperature when driving around town.

It is not blowing any white smoke and the oil is not a milky colour. The coolant also is red and there is no oil in it.

There are also no check engine lights.

I suspect the thermostat could potentially be the problem however I don't want to go and buy one if this isn't the problem.

Do any of you think it could be something else? Any help would be greatly appreciated.

Cheers.
luke96241 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
urs6ville
Audi Original "S" Cars
7
07-08-2008 02:41 PM
gogu
Audi 90 / 80 / Coupe quattro / Cabriolet
20
05-03-2006 05:41 PM
Grapeking
A6 / S6 (C5 Platform) Discussion
14
11-07-2003 10:25 PM
tb1200 - word up doc
A4 (B6 Platform) Discussion
7
12-13-2002 11:13 AM


Thread Tools
Search this Thread
Quick Reply: Audi A4 B7 losing coolant


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: