Help! Camshaft (hall) position sensor problem - AudiWorld Forums

Go Back  AudiWorld Forums > Audi Models > Other Audi > Audi 100 / A6 (C4 Platform)
Reload this Page > Help! Camshaft (hall) position sensor problem
Notices

Help! Camshaft (hall) position sensor problem

Reply

 
 
Old 04-11-2011, 10:41 AM
  #1
Audiworld Junior Member
Thread Starter
 
Join Date: Aug 2009
Posts: 16
Default Help! Camshaft (hall) position sensor problem

While trying to replace a vacuum hose, I accidentally broke the wire clip off my camshaft position sensor on the back of the cam. I was vaguely informed that if you replace this sensor, you need to realign the timing belt and such.

Does anyone know if I just reconnect the wiring harness to the existing sensor and expect it to work? I've turned the engine over several times, but it (obviously) hasn't started with the sensor disconnected. I haven't yet touched the sensor itself, just severed the wires leading to it (ack.)

Since the wires are so short and tiny and the sensor is so difficult to reach, I haven't yet been able to reconnect it as an experiment. and it's not worth the trouble if I have to realign the sensor anyway, I'd just replace it instead.

Thanks so much in advance --

JP
DrunkOnWine is offline  
Reply With Quote
Old 04-11-2011, 11:28 PM
  #2
AudiWorld Super User
 
Join Date: Jan 2003
Location: Lake Tapps, WA
Posts: 5,786
Default

You don't need to realign the timing belt to replace the cam sensor, they are totally independent of each other. If you broke the wiriing clip on the wire, then you can replace the clip at the dealer (they replace plastic wiring clips all the time because they are easily broken). If the clip is broken on the sensor itself, just purchase a new sensor, replace the damage unit, and plug it it. It should work just fine if the wiring is undamaged.
A6Gary is offline  
Reply With Quote
Old 04-13-2011, 09:37 AM
  #3
Audiworld Junior Member
Thread Starter
 
Join Date: Aug 2009
Posts: 16
Default

Thanks, thats encouraging to hear. I was able to reconnect the harness and clear 2113 (hall sensor) .. hopefully I won't have to replace it right away, but if I do I'm glad to hear I can do it myyself.
DrunkOnWine is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
marshap1
Wheels & Tires Discussion
0
09-06-2015 12:21 PM
ajg617
A6 / S6 (C5 Platform) Discussion
0
09-06-2015 07:23 AM
eggsngrits
A8 / S8 (D3 Platform) Discussion
0
09-05-2015 10:22 AM
wjhpilot
S4 (B8 Platform) Discussion
0
09-04-2015 01:43 PM
irelandbuyer
A8 / S8 (D3 Platform) Discussion
2
09-02-2015 06:01 PM


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 05:33 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: