Go Back   AudiWorld Forums > Audi Models > Audi TT / TT-S / TT-RS > TT (Mk1) Discussion
Sign in using an external account
Register Forgot Password?


TT (Mk1) Discussion Discussion forum for the Mk1 Audi TT Coupe & Roadster produced from 2000-2006

Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 02-05-2010, 08:07 AM   #1
AudiWorld Newcomer
Account #: 178134
 
Join Date: Feb 2010
Posts: 1
Default Quattro and Headlight problem.. 2001 TT

I have a couple questions about my 2001 Audi TT Quattro..

First one is my headlight on passenger side died... I can turn on the headlights, the headlight will come on, off, on, stay off.. for a split second.. I tried testing the plug with a multimeter and I get no power. So my question is does the TT have some kind of computer on the headlights or transformer? Does it shut off power to the headlight if it doesn't get any power being drawn? I haven't tried changing the bulb, as I think it is something else causing the problem as the headlight comes on, off, on, stays off..

Next question.. My Quattro does not work.. my car is stuck in FWD, the rear wheels do not turn at all whether I have traction control on or off... a while back my car used to die out in the summer time for no reason, like if I started boosting to pass someone then let off throttle the car acted like it was turned off, but tracton control light would appear on dash and car would idle at around 800 rpm's but no matter how far you press the gas the car would stay at 800 rpm's (idle).. I would have to shut the key off and turn car back on and everything worked fine again.. I'm guessing this has something to do with the Quattro as it was slowly going out? I don't know if the Quattro ever worked since I bought the car, this was first winter I used it and first snow I found rear wheels would not spin.. I checked fuse, and scanned OBD, not sure if anything quattro related would show on a OBD scan or not, but only thing I get on OBD scan is my 2nd O2 sensor (guessing from having a borla exhaust installed).. I was told about the Haldex fluid and filter need changed every 20,000 miles.. since I've bought this car I've probably put 20K miles on it.. so could that make the rear wheels not spin if the fluid is low ?

Also I can not find a Haynes or Chilton's manual for the 2001 Audi TT Quattro are their any other repair manuals out there that are worth buying for this car?

Thanks..
maximumHAX is offline   Reply With Quote
Old 02-10-2010, 05:07 AM   #2
AudiWorld Senior Member
Account #: 6210
 
Join Date: Jun 2000
Posts: 668
Default

Do you have check engine, ABS, and/or ESP lights on all the time?

That's an odd issue with your headlight. If you have Xenons, I would suspect the Ballast. I think you'll have to replace the entire headlight unit, but I haven't had this issue...

The O2 sensor problem shouldn't be due to the Borla. I've had to replace an O2 sensor, it happens. Unless you removed the cat, that'll throw a code...

Scanning OBD won't tell you anything about Quattro, you need a VAG-COM and scan the Haldex. I would also scan the ABS module.

I have the repair manual from Bentley. http://www.robertbentley.com
HaTTfield is offline   Reply With Quote
Old 02-10-2010, 06:05 AM   #3
AudiWorld Member
Account #: 139766
 
Join Date: Dec 2007
Posts: 202
Default

The Bentley manual is about the only repair manual you can find.

So far as the Haldex (Quattro) system is concerned, my OEM Haldex computer crapped out on me at about 95k and I replaced it with the "Blue" Haldex controller - which now works just great (especially in the snow).

You should VAGcom to see if the Haldex system is throwing a code - mine threw the "Could not communicate with controller" code.

Headlights - mine are flaky as well and I JUST noticed the other day that I am getting condensation in the DS headlight...wonderful. I'll have to fix this in about 4 months when it's not below zero here.

I had to change out my front O2 sensor last year as well. Fun stuff.
SlapTTy is offline   Reply With Quote
Old 02-10-2010, 06:05 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
2001, 2003, a5, a6, audi, b5, failure, headlight, headlights, problem, problems, quattro, tt, turn, wont


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:20 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community