Performance and Tuning Discussion forum for various performance tuning techniques and questions
Sponsored by:
Sponsored by:

CEL issue

 
Old 09-17-2017, 11:24 AM
  #1  
AudiWorld Newcomer
Thread Starter
 
Join Date: Sep 2017
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default CEL issue

whats up guys, so I have a '13 A4 2.0T, APR stage 2 tune, 034 high flow cat and full AWE Tuning exhaust. I'm having an issue getting it to pass NY states stupid emissions test, it throws a code for the O2 sensor. I already have an O2 spacer installed which has not remedied the issue. Was wondering if anyone had any insight on how to trick the system or get it to pass emissions; without having to reinstall the stock cat. Any help would be appreciated
markv0118 is offline  
Old 11-07-2017, 04:25 PM
  #2  
Audiworld Junior Member
 
Join Date: May 2017
Posts: 29
Likes: 0
Received 0 Likes on 0 Posts
Default

https://www.europaparts.com/oxygen-s...-mini-cat.html

put one on each side in place for the rear O2 sensors and you will never have to worry about a check engine light again. i originally used the curved spacers from vibrant performance and it would only keep the light off for about 100 miles, i did not try the other 2 gas flow inserts but i liked the idea of the mini cat and my car runs so much better now cause the mini cats give the o2 sensor the correct reading so it wont run so rich and now that the air fuel ratio is much better my gas mileage went up about 125 miles per tank, and i have a heavy foot too, but overall this was the best $100 i have spent cause my car runs freaking incredible now and it passes the dreaded smog test, as long as they dont look under the hood lol
bbarrow313 is offline  
Old 11-07-2017, 05:42 PM
  #3  
AudiWorld Newcomer
Thread Starter
 
Join Date: Sep 2017
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Awesome Iíll have to try that! So you put one in for the rear sensor only or one for front and rear? Thanks for the help man!
markv0118 is offline  
Old 11-07-2017, 09:43 PM
  #4  
Audiworld Junior Member
 
Join Date: May 2017
Posts: 29
Likes: 0
Received 0 Likes on 0 Posts
Default

I bought 2 for mine cause it has 4 02 sensors, one on each side before the cats and one on each side after the cats. I think your car only has 2 o2 sensors since there's only one pipe. If that's the case, you just need one and put it after the cat. What happens when you remove the cats or put a high flow cat, the secondary O2 sensor senses too much oxygen and thinks the car is running way to lean so it tries to compensate by dumping a ton of fuel to make the air fuel mixture more rich. This in turn causes horrible gas mileage and the car seems like something is off, it runs pretty good but you can just feel that it's just not where it should be. This mini cat O2 spacer will divert a small amount of air flow to the O2 sensor and in turn give it the correct reading that the cat or cats are working like they should and it'll lean out your air fuel ratio and you'll see what I mean as soon as you take it for a test drive. I never even had to clear a check engine light after I put them in. It blew some black smoke out when I first cranked it but it's running better than ever now. Shifts are crisper and smoother. Too most folks they don't notice and say well it's still super loud but you'll definitely notice how much better it sounds. One last tip, when you install it, use thread lock or lock tight and make sure you get it in there really tight and same with the O2 sensor so there's no leak. And make sure not to have the wires for the O2 sensor all twisted up, either unclip the wire for it or twist the O2 sensor backwards 3-4 times then screw it in so that way once it's in the wires goin in the O2 sensor won't be twisted, this is important because the sensor actually breathes through the top where the wires come into it so hopefully that helps you out and kind of gives you a little background info on how that stuff works and why as well. Just let me know if you got any more questions about this or anything else
bbarrow313 is offline  
Old 11-08-2017, 12:25 AM
  #5  
AudiWorld Newcomer
Thread Starter
 
Join Date: Sep 2017
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks for the info, I definitely know what youíre saying about it not being where it should be even though itís running good. Hopefully this takes care of it. Thanks again.
markv0118 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Smdude35
A4 (B5 Platform) Discussion
4
12-23-2014 04:09 AM
j2mc
Audi 5000 / 200 / V8 Discussion
13
01-16-2009 06:32 AM
BlueChip
TT (Mk1) Discussion
21
05-23-2008 02:04 PM
s54m3
A4 (B5 Platform) Discussion
11
10-08-2002 10:05 PM


Thread Tools
Search this Thread
Quick Reply: CEL issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: