RS4 (B7 Platform) Discussion Discussion forum for the B7 Audi RS4
Sponsored by:
Sponsored by:

Help! AUDI RS4 RANDOM MISSFIRE

 
Old 12-22-2016, 01:53 PM
  #1  
AudiWorld Newcomer
Thread Starter
 
Join Date: Dec 2016
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Help! AUDI RS4 RANDOM MISSFIRE

Hi Everyone! I've got a problem with my rs4 and i'm not able to find the solution. The car make random missfire on every cylinder P0300. I start the car and it run poorly. When I accelerate it's even worst.
I notice when i reset the ecm on the car ( disconnect the batterie) and reconnect the battery the car seem to run smoother for a few minute on idle but when i drive it pass 2000 rpm it do a lot of missfire.The car have a magnaflow X pipe with no cat with oxygen fooler on the back but the car seen to smell gaz a lot.
What i do during the pass 2 week

1- Complete carbon clean up
2- Change all the spark plug
3- Change all the injector for new hitachi
4- Pevious owner change the coilpack.... but is it true ?

I already scan the car with a scanner but it reveal nothing but the random missfire

What you think i can do to solve my problem ??
1- Change the coilpack
2- Change the Maf
3- Change the front 02 sensor

I want to know you opinion about my problem!
Thanks and sorry for my bad english
Flix
Felix Bouvet is offline  
Old 01-02-2017, 05:17 PM
  #2  
AudiWorld Newcomer
Thread Starter
 
Join Date: Dec 2016
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

!UPTADE ! with more detail and scan

Hi Everyone! I've got a problem with my Audi rs4 2007 and i'm not able to find the solution. The car make random missfire. I start the car and it run with a light missfire. You can ear it at idle but no dtc. When I accelerate it's even worst and the check engine appear and flash.
I notice when i clear the dtc ( with vcds), the car seem to run smoother for a few minute on idle. Check the link on youtube.
I recorded the two oxygen sensor reading and at the start they measure the same value but after 30 second its completely different.
Also, you can see my scan from VCDS. The car give me missfire on cylinder 5-6-7-8 when I drove for a few miles but when I drove for a bigger distance all the cylinder have missfire. Check the scan in the link.
I try to swap coil but nothing change. Maybe I need 8 new coils but Im not sure ? Is a one bad coil can create random missfire
Also, I notice something really strange when I remove the spark plug. On one side, (cyl 1 to 4) the spark plug are carbonized ( really rich) . And the other side (cyl 5 to 8 ) the spark plug are the perfect coffee color. What can cause that ?

What i do during the pass 2 week to solve the problem but no good result

1- Complete carbon clean up
2- Change all the spark plug
3- Change all the injector for new hitachi

4- Compression Test good
Cyl1: 137 psi Cyl2 : 142 psi Cyl3 : 132 psi Cyl4: 145 psi
Cyl5 : 143 psi Cyl6; 142 psi Cyl7 : 144 psi Cyl8 : 155 psi

5- Change the two Bank 1 o2 sensor

What you think i can do next ??
1- Change the coilpack for 8 new? I dont think it will solve it
2- Change the Mass air flow ( check the video in the link to see the value on idle)
3- Change the ECU ? By the way witch ECU control the engine( 2 ecu on the RS4). Ive got a DTC for a faulty memory for ECU2 check the VCDS Scan.
Attached Files
File Type: txt
File Type: txt
VCDS scan for a long drive.txt (30.3 KB, 733 views)
Felix Bouvet is offline  
Old 01-21-2017, 01:35 PM
  #3  
AudiWorld Senior Member
 
Join Date: Apr 2005
Posts: 606
Likes: 0
Received 0 Likes on 0 Posts
Default

I have a similar issue with my 07 A8 4.2q.

Im pretty handy and usually can figure things out, but in this case Im stumped. I started with sputtering/misfiring on acceleration, lack in power. Replaced the fuel filter, then things got way worse. I barely made it to the dealer (no indy shops in my area that I trust).

The dealer replaced the fuel pump sensors (high and low), did a carbon cleanout service on the intake and valves since the manifold was off, and ended up replacing the high pressure fuel pumps since they were reading at 6bar rather than 25bar. They also replaced a motor mount - apparently the sensor was bad and it is somehow connected to the fuel pump sensors, and the sensor needed replacement for them to diagnose the system.

Picked up the car this morning, and the car accelerates normal now when lightly accelerating, but I can feel the shutter when I go beyond 50% throttle and the CEL briefly flashed. CEL light is off, so Im thinking its still misfiring.

Plugs are maybe 5k miles old - I did notice oil leaking from an intake man gasket into the plug hole. Not sure if this can cause the issue. The only thing I havent replaced is the low pressure fuel pumps.

I would recommend going down the path i did with checking the fuel pump pressures on the high side and low side to see if you are out of spec like me. Looks like Im going to be changing out my low pressure fuel pumps since Ive done everything else....
gtreng1 is offline  
Old 02-23-2017, 04:26 PM
  #4  
AudiWorld Newcomer
 
Join Date: Jan 2015
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

i'm having the same cylinder 3 misfire.
Coils ok, plugs ok, injector ok, wiring ok....
Did you find your problem?
gbert is offline  
Old 03-01-2017, 10:33 PM
  #5  
AudiWorld Newcomer
 
Join Date: Mar 2017
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi guys, has anybody found some sort of a solution...i hav the same issues...slightly diff. starts perfect, idles perfect, but as soon as i accellerate, its like the exhause picks up whole different sound. Really sounds like a diesel bakkie (South Africa). I stop, switch off, start again... as soon as i accellerate, same thing car has been carbon cleaned, plug and coils also... please help... [email protected]
pablok is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
a3almeida986
Audi A3 / S3 / RS 3
0
05-29-2016 10:47 AM
Rich sanders
RS4 (B7 Platform) Discussion
2
04-04-2014 02:46 PM
gousgounis
Audi 90 / 80 / Coupe quattro / Cabriolet
1
02-05-2010 05:27 PM
ChucktownS4
S4 / RS4 (B5 Platform) Discussion
15
06-26-2007 11:27 AM
Johnny Bravo
S4 / RS4 (B5 Platform) Discussion
5
09-20-2005 06:03 PM


Thread Tools
Search this Thread
Quick Reply: Help! AUDI RS4 RANDOM MISSFIRE


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: