2007 Audi A4 Turbo Replacement Problem - Page 2 - AudiWorld Forums

Go Back  AudiWorld Forums > Technical Discussion > Motors > 2.0T FSI Discussion
Reload this Page > 2007 Audi A4 Turbo Replacement Problem
Notices

2007 Audi A4 Turbo Replacement Problem

Reply

 
 
Old 05-15-2017, 07:57 AM
  #11
AudiWorld Newcomer
 
Join Date: Nov 2016
Posts: 9
Default

Bummer. Are you sure about the vacuum lines being in the proper place. I'd be happy to snap a picture if that would help. As for the carbon thing, I've heard they just make a mess. I'd go with the old one or throw some ultra black, be sure to let it dry, and be done with it.
JimmyChee is offline  
Reply With Quote
Old 05-15-2017, 12:05 PM
  #12
Audiworld Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 23
Default

Originally Posted by JimmyChee View Post
Bummer. Are you sure about the vacuum lines being in the proper place. I'd be happy to snap a picture if that would help. As for the carbon thing, I've heard they just make a mess. I'd go with the old one or throw some ultra black, be sure to let it dry, and be done with it.
Would you be able to snap a pic of your vaccum lines when you get a chance? The only thing I've done to the car is swap the turbo so I don't know the lines on the rest of the car. I found the old gasket on my old turbo and got it back on last night and will be checking when I get home if there is a leak. But I'm thinking I got that fixed, if not I can at least get it worked out. Let me outline all the problems I'm seeing with the car maybe that could help someone with more knowledge identify what's wrong lol

The turbo gauge sits at 0 psi the entire time I'm idle and drivingc we hear what we assume to be rushing air near the air filter, not sure if we are expecting to hear the air rushing out around there or not..

I have a CEL light and the ECP light on still. The car is hard to turn over so I think it's my CRanshaft sensor for the ECP. Not 100% sure. (Tried to read both codes and my vagcom failed to communicate with the engine controller (I can communicate with other modules) and my obd2 program didn't identify the car (think that was software as I used ScanXL).

When I start the car it's real rough, definitely missing, you can hear and smell it running rich. When I drive it feels smooth, no lurching, stalling, etc. when I step on the gas to pick up speed the car will rev up to 4000rpm and seem to sit there, shifting, but not dropping RPM as the gears shift. None of this makes sense to me.

Anyone got any ideas? Is there a sensor on the A4 B7 for the turbo that may be bad? I didn't see any fuses or relays for the turbo under my dash. Anyone got possible ways I can scan my vagcom I got a vagcom 409.1 I think and it came with a cd that looks to be some version of Ross tech vcds. I tried both Ross tech lite version and the one that came with my cd.

Im at a complete loss and really want to start driving my new car any help is appreciated!
AudiA4Sline is offline  
Reply With Quote
Old 05-16-2017, 03:57 PM
  #13
AudiWorld Newcomer
 
Join Date: Nov 2016
Posts: 9
Default


Do your connections look like this?
JimmyChee is offline  
Reply With Quote
Old 05-16-2017, 05:57 PM
  #14
Audiworld Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 23
Default

Originally Posted by JimmyChee View Post

Do your connections look like this?
Yes they look just like that, all of that came on the new turbo so I was able to leave the old ones and use the new tubing, clamps, and DV. Does anyone know if there is a fuse or relay for the turbo? I didn't see anything on th diagram and can't find a solid one for relays.
AudiA4Sline is offline  
Reply With Quote
Old 05-18-2017, 03:55 PM
  #15
Audiworld Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 23
Default

Update: Rented a Vagcom. Heres the output of the auto scan on the car! Some things such as Navigation show from 05 but I am currently at 110600ish miles so many of the faults apply. Anyone had similar faults? This ECM module seems to be a big one that ties into alot of errors.

Thursday,18,May,2017,19:21:49:32983
VCDS -- Windows Based VAG/VAS Emulator Running on Windows 10 x64
VCDS Version: 17.1.3.0 (x64)
Data version: 20170320 DS267.7
Ross-Tech: Home


VIN: License Plate:
Mileage: 178030km-110622mi Repair Order:



--------------------------------------------------------------------------------
--------------------------------------------------------------------------------


Chassis Type: 8E (8E - Audi A4/S4/RS4 B6/B7 (2001 > 2008))
Scan: 01 02 03 08 09 0F 11 15 16 17 18 25 36 37 45 46 55 56 57 65
67 69 75 76 77

VIN: Mileage: 178030km-110622miles
-------------------------------------------------------------------------------
Address 01: Engine Labels: 06F-907-115-AXX.clb
Part No SW: 8E0 910 115 P HW: 8E0 907 115 D
Component: 2.0l R4/4V TFSI 0030
Revision: 5EH15--- Serial number:
Coding: 0104010A190F0120
Shop #: WSC 66565 257 00032
VCID: 2E534364B99792314B-807A

8 Faults Found:
008852 - Fuel Pressure Regulator Valve (N276)
P2294 - 004 - Open Circuit - Intermittent - MIL ON
Freeze Frame:
Fault Status: 10100100
Fault Priority: 2
Fault Frequency: 5
Reset counter: 255
Mileage: 177918 km
Time Indication: 0

Freeze Frame:
RPM: 200 /min
Load: 71.7 %
Speed: 0.0 km/h
Temperature: 27.0°C
Temperature: 34.0°C
Absolute Pres.: 1000.0 mbar
Voltage: 10.922 V

008567 - Bank 1; System Too Lean off Idle
P2177 - 001 - - Intermittent
Freeze Frame:
Fault Status: 10100100
Fault Priority: 2
Fault Frequency: 5
Reset counter: 255
Mileage: 177918 km
Time Indication: 0

008504 - Accelerator Position Sensors (G79) / (G185)
P2138 - 008 - Implausible Correlation - Intermittent
Freeze Frame:
Fault Status: 00101000
Fault Priority: 2
Fault Frequency: 1
Reset counter: 255
Mileage: 177935 km
Time Indication: 0

Freeze Frame:
RPM: 0 /min
Load: 0.0 %
Speed: 0.0 km/h
Temperature: 66.0°C
Temperature: 63.0°C
Absolute Pres.: 1000.0 mbar
Voltage: 12.446 V

000770 - Cylinder 2
P0302 - 008 - Misfire Detected - Intermittent
Freeze Frame:
Fault Status: 00101000
Fault Priority: 2
Fault Frequency: 1
Reset counter: 255
Mileage: 177935 km
Time Indication: 0

005634 - Power Supply Terminal 30
P1602 - 002 - Voltage too Low - Intermittent
Freeze Frame:
Fault Status: 00100010
Fault Priority: 2
Fault Frequency: 1
Reset counter: 255
Mileage: 0 km
Time Indication: 0

Freeze Frame:
RPM: 0 /min
Load: 0.0 %
Speed: 0.0 km/h
Temperature: -40.0°C
Temperature: -40.0°C
Absolute Pres.: 0.0 mbar
Voltage: 0.000 V

001152 - Coolant Fan Control Circuit 1
P0480 - 001 - Electrical Malfunction - Intermittent
Freeze Frame:
Fault Status: 00100010
Fault Priority: 2
Fault Frequency: 1
Reset counter: 255
Mileage: 0 km
Time Indication: 0

000256 - Mass Air Flow Sensor (G70)
P0100 - 004 - Supply Voltage - Intermittent
Freeze Frame:
Fault Status: 00100100
Fault Priority: 2
Fault Frequency: 1
Reset counter: 255
Mileage: 178028 km
Time Indication: 0

Freeze Frame:
RPM: 0 /min
Load: 0.0 %
Speed: 0.0 km/h
Temperature: 30.0°C
Temperature: 25.0°C
Absolute Pres.: 1000.0 mbar
Voltage: 12.065 V

008825 - Leak in Air Intake System
P2279 - 002 -
Freeze Frame:
Fault Status: 00100100
Fault Priority: 2
Fault Frequency: 1
Reset counter: 255
Mileage: 178028 km
Time Indication: 0

Readiness: 0010 0000

-------------------------------------------------------------------------------
Address 02: Auto Trans Labels: 09L-927-760.lbl
Part No SW: 8E1 910 156 K HW: 09L 927 156 B
Component: AG6 09L 2,0TFSI USA 0040
Revision: --H01--- Serial number: 4241801
Coding: 0000002
Shop #: WSC 06325 000 00000
VCID: 2F6D5E60BE9D9B3940-807A

4 Faults Found:
006273 - Powertrain Data Bus: Missing Message
P1881 - 000 - Acceleration Request - Intermittent
Freeze Frame:
Fault Status: 00100000
Fault Priority: 0
Fault Frequency: 29
Reset counter: 255
Mileage: 0 km
Time Indication: 0

Freeze Frame:
RPM: 0 /min
RPM: 128 /min
RPM: 0 /min
(no units): 30.0
(no units): 25.0
Temperature: 5.0°C
T.B. Angle: 60.0°

049408 - No Communication with Engine Control Module (SAE ECM/PCM)
U0100 - 000 - - Intermittent
Freeze Frame:
Fault Status: 00100000
Fault Priority: 0
Fault Frequency: 29
Reset counter: 255
Mileage: 0 km
Time Indication: 0

006241 - Throttle Position Sensor (G79)
P1861 - 000 - Error Message from ECU - Intermittent
Freeze Frame:
Fault Status: 00100000
Fault Priority: 0
Fault Frequency: 5
Reset counter: 255
Mileage: 0 km
Time Indication: 0

006231 - Load Signal
P1857 - 001 - Error Message from ECU - Intermittent
Freeze Frame:
Fault Status: 00100000
Fault Priority: 0
Fault Frequency: 5
Reset counter: 255
Mileage: 0 km
Time Indication: 0


-------------------------------------------------------------------------------
Address 03: ABS Brakes Labels: 8E0-910-517.clb
Part No SW: 8E0 910 517 J HW: 8E0 614 517 BH
Component: ESP8 quattro H06 0140
Revision: 00000000 Serial number: 00000000000000
Coding: 0004528
Shop #: WSC 06325 000 00000
VCID: 2E534364B99792314B-807A

3 Faults Found:
01314 - Engine Control Module
013 - Check DTC Memory - Intermittent
Freeze Frame:
Fault Status: 00101101
Fault Priority: 2
Fault Frequency: 12
Reset counter: 15
Time Indication: 0

Freeze Frame:
Hex Value: 0x0100
Hex Value: 0x4002
Hex Value: 0x0029
Hex Value: 0x01A9
Hex Value: 0x0001

01826 - Sensor for Steering Angle (G85); Supply Voltage Terminal 30
000 - - - Intermittent
Freeze Frame:
Fault Status: 00101101
Fault Priority: 2
Fault Frequency: 12
Reset counter: 15
Time Indication: 0

18265 - Load Signal
P1857 - 000 - Error Message from ECU - Intermittent
Freeze Frame:
Fault Status: 00100000
Fault Priority: 2
Fault Frequency: 1
Reset counter: 39
Time Indication: 0

Freeze Frame:
Hex Value: 0x0000
Hex Value: 0x4202
Hex Value: 0x0028
Hex Value: 0x0193
Hex Value: 0x0001


-------------------------------------------------------------------------------
Address 08: Auto HVAC Labels: 8E0-820-043.lbl
Part No: 8E0 820 043 BL
Component: A4 Klimaautomat 2833
Coding: 00000
Shop #: WSC 00000
VCID: 6CD7896C1C0B202125-5122

No fault code found.

-------------------------------------------------------------------------------
Address 09: Cent. Elect. Labels: 8E0-907-279-8EC.lbl
Part No: 8E0 907 279 N
Component: int. Lastmodul ECE 0907
Coding: 00001
Shop #: WSC 06325
VCID: 3D71742837F179A9C2-4B00

No fault code found.

-------------------------------------------------------------------------------
Address 15: Airbags Labels: 8E0-959-655-94.lbl
Part No SW: 8E0 959 655 H HW: 8E0 959 655 H
Component: Airbag 9.41 H12 3840
Revision: 91H12384 Serial number: 0036N0G0FZ5H
Coding: 0032607
Shop #: WSC 22164 444 54140
VCID: 3C77792C7FEB70A1F5-8068

Subsystem 1 - Part No: 8E0 910 339 D
Component: BF-Gewichtsens. H03 0080

Subsystem 2 - Serial number: 02647

Subsystem 3 - Serial number: 0001.01.0000H0300000000000˙†63

Subsystem 4 - Serial number: 000000˙†6332DRB4040C0D95Q˙†63

Subsystem 5 - Serial number: C0D95Q˙†6342DRB4040B4F8F+˙†63

Subsystem 6 - Serial number: B4F8F+˙†6352ARB401B77093K˙†63

Subsystem 7 - Serial number: 77093K˙†6362ARB401B769FE3˙†63

Subsystem 8 - Serial number: 769FE3˙†63729RB401B887B9 ˙†63

Subsystem 9 - Serial number: 887B9 ˙†63829RB401B88792U˙

Subsystem 10 - Serial number: 88792U˙

No fault code found.

-------------------------------------------------------------------------------
Address 16: Steering wheel Labels: 8E0-953-549.lbl
Part No: 8E0 953 549 Q
Component: Lenksáulenmodul 0701
Coding: 02141
Shop #: WSC 06325
VCID: 418908D84B091D49A6-4B1A

2 Faults Found:
01317 - Control Module in Instrument Cluster (J285)
49-10 - No Communications - Intermittent
01304 - Radio
49-10 - No Communications - Intermittent

-------------------------------------------------------------------------------
Address 17: Instruments Labels: 8E0-920-9xx-8EC.lbl
Part No SW: 8E0 920 982 F HW: 8E0 920 982 F
Component: KOMBI+WFS 4 H14 0120
Revision: 0120 Serial number: 00000000000000
Coding: 0023201
Shop #: WSC 22501 512 00000
VCID: 31695818ABA98DC956-515E

1 Fault Found:
01314 - Engine Control Module
004 - No Signal/Communication - Intermittent

-------------------------------------------------------------------------------
Address 25: Immobilizer Labels: 8E0-920-9xx-8EC.lbl
Part No SW: 8E0 920 982 F HW: 8E0 920 982 F
Component: KOMBI+WFS 4 H14 0120
Revision: 0120 Serial number: 00000000000000
Coding: 0023201
Shop #: WSC 22501 512 00000
VCID: 31695818ABA98DC956-515E

1 Fault Found:
01314 - Engine Control Module
004 - No Signal/Communication - Intermittent

-------------------------------------------------------------------------------
Address 37: Navigation Labels: 8E0-035-192-RNSE.clb
Part No SW: 8E0 035 192 J HW: 8E0 035 192 J
Component: RNS-E US H72 0260
Revision: 03S Serial number: AUZBZ7F2490465
Coding: 0301117
Shop #: WSC 06325 000 00000
VCID: 2B554A708985E7196C-517C

5 Faults Found:
00532 - Supply Voltage B+
002 - Lower Limit Exceeded - Intermittent
Freeze Frame:
Fault Status: 00100010
Fault Priority: 7
Fault Frequency: 1
Reset counter: 28
Time Indication: 0
Date: 2005.02.10
Time: 00:01:00

Freeze Frame:
Voltage: 11.90 V

00446 - Function Limitation due to Under-Voltage
002 - Lower Limit Exceeded - Intermittent
Freeze Frame:
Fault Status: 00100010
Fault Priority: 7
Fault Frequency: 1
Reset counter: 28
Time Indication: 0
Date: 2005.02.10
Time: 00:01:00

00858 - Connection; Radio Intermediate Frequency (IF) Output to Antenna Amplifier
011 - Open Circuit - Intermittent
Freeze Frame:
Fault Status: 00100010
Fault Priority: 7
Fault Frequency: 1
Reset counter: 28
Time Indication: 0
Date: 2005.02.10
Time: 00:01:00

01317 - Control Module in Instrument Cluster (J285)
008 - Implausible Signal - Intermittent
Freeze Frame:
Fault Status: 00101000
Fault Priority: 5
Fault Frequency: 1
Reset counter: 27
Time Indication: 0
Date: 2005.02.11
Time: 22:16:58

Freeze Frame:
Bin. Bits: 11011011
Bin. Bits: 11

01305 - Databus for Infotainment
004 - No Signal/Communication - Intermittent
Freeze Frame:
Fault Status: 00101000
Fault Priority: 5
Fault Frequency: 1
Reset counter: 27
Time Indication: 0
Date: 2005.02.11
Time: 22:16:58


-------------------------------------------------------------------------------
Address 46: Central Conv. Labels: 8E0-959-433-MAX.clb
Part No: 8E0 959 433 CG
Component: Komfortgerát T7B 4135
Coding: 11884
Shop #: WSC 06325
VCID: 78FFA53C58539C81D1-4B1A

Subsystem 1 - Part No: 8E1959801G
Component: Tőrsteuer.FS BRM 0706

Subsystem 2 - Part No: 8E1959802G
Component: Tőrsteuer.BF BRM 0706

Subsystem 3 - Part No: 8E0959801E
Component: Tőrsteuer.HL BRM 0606

Subsystem 4 - Part No: 8E0959802E
Component: Tőrsteuer.HR BRM 0606

1 Fault Found:
00956 - Key 2
35-10 - - - Intermittent

-------------------------------------------------------------------------------
Address 56: Radio Labels: 8E0-035-192-RNSE.clb
Part No SW: 8E0 035 192 J HW: 8E0 035 192 J
Component: RNS-E US H72 0260
Revision: 03S Serial number: AUZBZ7F2490465
Coding: 0301117
Shop #: WSC 06325 000 00000
VCID: 2B554A708985E7196C-517C

5 Faults Found:
00532 - Supply Voltage B+
002 - Lower Limit Exceeded - Intermittent
Freeze Frame:
Fault Status: 00100010
Fault Priority: 7
Fault Frequency: 1
Reset counter: 28
Time Indication: 0
Date: 2005.02.10
Time: 00:01:00

Freeze Frame:
Voltage: 11.90 V

00446 - Function Limitation due to Under-Voltage
002 - Lower Limit Exceeded - Intermittent
Freeze Frame:
Fault Status: 00100010
Fault Priority: 7
Fault Frequency: 1
Reset counter: 28
Time Indication: 0
Date: 2005.02.10
Time: 00:01:00

00858 - Connection; Radio Intermediate Frequency (IF) Output to Antenna Amplifier
011 - Open Circuit - Intermittent
Freeze Frame:
Fault Status: 00100010
Fault Priority: 7
Fault Frequency: 1
Reset counter: 28
Time Indication: 0
Date: 2005.02.10
Time: 00:01:00

01317 - Control Module in Instrument Cluster (J285)
008 - Implausible Signal - Intermittent
Freeze Frame:
Fault Status: 00100010
Fault Priority: 7
Fault Frequency: 1
Reset counter: 28
Time Indication: 0
Date: 2005.02.10
Time: 00:01:00

01305 - Databus for Infotainment
004 - No Signal/Communication - Intermittent
Freeze Frame:
Fault Status: 00100010
Fault Priority: 7
Fault Frequency: 1
Reset counter: 28
Time Indication: 0
Date: 2005.02.10
Time: 00:01:00


End-------------------------(Elapsed Time: 06:12)--------------------------


If that seems familiar or identifiable to anyone let me know! Ill be searching google!!!
AudiA4Sline is offline  
Reply With Quote
Old 05-23-2017, 06:33 PM
  #16
AudiWorld Newcomer
 
Join Date: Nov 2016
Posts: 9
Default

I wanted to follow up. I'm at a loss. Any further progress? What happens when you clear the codes? Just replacing the turbo should not result is anything like those codes.
​​​​​​
JimmyChee is offline  
Reply With Quote
Old 05-28-2017, 04:36 AM
  #17
Audiworld Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 23
Default

Originally Posted by JimmyChee View Post
I wanted to follow up. I'm at a loss. Any further progress? What happens when you clear the codes? Just replacing the turbo should not result is anything like those codes.
​​​​​​
Hey man sorry I haven't had a chance to reply I've been wrapped up in work and class. So I cleared the codes and ran it again, got the fuel pump relay error and ended up getting it to my dealership who called me yesterday and told me it was the fuel pump. So they are going to replace it as well as my takata airbag recall. Hopefully I will have it by next Wednesday to see if that resolved all my issues! Or at least let me narrow down the possible issues. I found my old air pump so I plan to use that regardless to check for any leaks. I got the car about 130 miles with all these codes and it drove real well surprisingly. Kinda makes me wonder how legitimate all these codes are lol
AudiA4Sline is offline  
Reply With Quote
Old 06-15-2017, 06:37 PM
  #18
Audiworld Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 23
Default

Update:

In case anyone is interested I found no leak from the turbo air intake and on though I don't know where else to check lines at. I swapped the LPFP and will be swapping the fuel filter tomorrow. This weekend I will also check me ecu relays as I found many similar posts to my problems from others who had water in the ecu box. Will let everyone know what I find out!!
AudiA4Sline is offline  
Reply With Quote
Old 06-21-2017, 09:29 AM
  #19
Audiworld Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 23
Default

Update:

relays and fuel filter did nothing except get my cel blinking for what I suspect was a misfire. Replaced ignition coils and will be swapping o2, maf, and crankshaft position sensor this week to see that that helps with rough idle and hard start and hopefully get me out of limp mode. No vagcom at the moment so going off regular P trouble codes.
AudiA4Sline is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 01:09 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: