Go Back  AudiWorld Forums > Audi Models > Audi Q3 /Q5 / Q7 / Q8 > Audi Q7 > Q7 Discussion
Reload this Page >

Q7 Major electrical issue!!! Please help!

Q7 Discussion Discussion forum for the Audi Q7 SUV built from 2005 to 2015
Sponsored By:
Sponsored By:

Q7 Major electrical issue!!! Please help!

 
Old 04-14-2019, 07:18 PM
  #1  
AudiWorld Newcomer
Thread Starter
 
Join Date: Apr 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Q7 Major electrical issue!!! Please help!

Hello, I just got back from a 2 week vacation and when I got back the vehicle battery was dead. Today I went and jump started the vehicle and all seemed well and I let it idle for a while.
A few hours later I jumped into the vehicle to run some errands and it started for a split second then would die. I tried to start it about 5 times and it eventually started.
After I got it running after many attempts the ABS, Traction Control, and headlight control warning lights were all on. Also the gauge cluster would turn on and turn off while driving, the radio speakers would cut in and out, the turn signals stopped working, and the windshield wipers also were not working.

Before my vacation the vehicle was running perfect with no concern. Any idea as to why I could have so many electrical issues with the vehicle many sitting for a few days with a dead battery?

Thanks! Any input is greatly appreciated!
Alex Boussatta is offline  
Old 04-14-2019, 07:23 PM
  #2  
AudiWorld Newcomer
Thread Starter
 
Join Date: Apr 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default 2008 Audi Q7

It's a 2008 Audi Q7

Originally Posted by Alex Boussatta View Post
Hello, I just got back from a 2 week vacation and when I got back the vehicle battery was dead. Today I went and jump started the vehicle and all seemed well and I let it idle for a while.
A few hours later I jumped into the vehicle to run some errands and it started for a split second then would die. I tried to start it about 5 times and it eventually started.
After I got it running after many attempts the ABS, Traction Control, and headlight control warning lights were all on. Also the gauge cluster would turn on and turn off while driving, the radio speakers would cut in and out, the turn signals stopped working, and the windshield wipers also were not working.

Before my vacation the vehicle was running perfect with no concern. Any idea as to why I could have so many electrical issues with the vehicle many sitting for a few days with a dead battery?

Thanks! Any input is greatly appreciated!
Alex Boussatta is offline  
Old 04-14-2019, 08:48 PM
  #3  
AudiWorld Member
 
Built4Sin's Avatar
 
Join Date: Jun 2017
Location: FL
Posts: 343
Received 1 Like on 1 Post
Default

Go have a battery test done, could be your battery was on the way out and your vacation finished it off. Likely a dead cell or two.
Built4Sin is offline  
Old 04-15-2019, 12:22 AM
  #4  
AudiWorld Newcomer
 
Join Date: Mar 2017
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

Charge the battery with a 15 amp charger to 100%. It took mine 1.5 days to charge. I got whacky fault codes because of a low battery.
Fixit Nau is offline  
Old 04-15-2019, 07:22 AM
  #5  
AudiWorld Member
 
Join Date: Mar 2008
Location: PNW
Posts: 339
Likes: 0
Received 1 Like on 1 Post
Default

More than likely your battery needs replacement. Get it checked out, and if you get it replaced, make sure that the car gets coded to the new battery, otherwise the car will not charge the new battery properly, and your new battery will be ruined.
chingwodapigu is offline  
Old 04-15-2019, 05:54 PM
  #6  
AudiWorld Member
 
Join Date: Apr 2018
Posts: 75
Likes: 0
Received 1 Like on 1 Post
Default

Battery is the first thing to rule out, then clear faults and try again.
Dudeness30 is offline  
Old 04-30-2019, 06:23 PM
  #7  
AudiWorld Member
 
Join Date: Dec 2015
Location: 2007 Q7 3.6
Posts: 326
Likes: 0
Received 0 Likes on 0 Posts
Default

When the battery is a low voltage this car starts FREAKING THE H out... it will throw every fault code in the world if it feels like it.
So you need to make sure the battery is 100% charged, and if that doesnt fix it then its possible you battery was near end of life.

the great news here is ((SARCASM)) you cant just drive this car to somewhere and have them test the battery. because it they try testing it from the posts in the engine area, that is a bogus test as the regulator interferes with it. you have to physically tip the left front seat up and get to the battery directly.
I made a battery video on how to get it out if you need to do that
https://www.youtube.com/user/bobspurloc/search?query=q7
bspurloc is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Pculvert
A4 (B8 Platform) Discussion
4
08-10-2018 09:07 AM
MCPaudiTT - DEFCON 1
TT (Mk1) Discussion
17
08-30-2007 05:50 AM
FSuperDuty
A4 (B5 Platform) Discussion
8
04-13-2007 01:01 PM
sub1427
A4 (B5 Platform) Discussion
13
02-09-2007 07:02 PM
Distinct
S4 / RS4 (B5 Platform) Discussion
6
07-30-2005 02:28 PM


Thread Tools
Search this Thread
Quick Reply: Q7 Major electrical issue!!! Please help!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: