Go Back  AudiWorld Forums > Technical Discussion > Engines > 4.2 V8 Discussion
Reload this Page >

2007 Q7 4.2 FSI misfire problems

2007 Q7 4.2 FSI misfire problems

 
Old 06-20-2018, 08:58 PM
  #1  
AudiWorld Newcomer
Thread Starter
 
Join Date: Jun 2018
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default 2007 Q7 4.2 FSI misfire problems

Iím having a prblem with my engine. When i first start the engine, it seems to run fine for about 1 min then it starts running very rough and I get multiple cylinder,(clyinders 2, 4, and 7) misfire codes. I have replaced the pcv valve because I had a loud whining noise and once i remove the old valve, about 1/4th of the o-ring was melted/destroyed. Iím thinking there must still be a vacuum leak or sensor problem since the engine is running perfectly fine for that first minute. Any help or suggestions about where to look would be greatly appreciated.
ChiefKC is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Nightlifephantom
A6 / S6 (C6 Platform) Discussion
1
08-01-2017 08:15 PM
audi1031
A4 (B6 Platform) Discussion
1
02-06-2010 12:43 PM
MADSKOTZMAN
Audi 90 / 80 / Coupe quattro / Cabriolet
3
03-16-2004 06:21 PM
QuattroRocket
A4 (B6 Platform) Discussion
1
09-17-2003 09:18 AM
Audi-Impaired
Audi 90 / 80 / Coupe quattro / Cabriolet
3
06-03-2003 08:39 PM


Thread Tools
Search this Thread
Quick Reply: 2007 Q7 4.2 FSI misfire problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: